Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

No DHCP refresh on cisco 827 and Demon DSL

Since a few weeks I have a cisco 827 adsl router/modem and a DSL connection from Demon Internet (in Holland) encapsulation protocol RFC1483 LLC Bridged IP.

I got the internet connection working, The virtual interface BVI1 gets a static IP# by dhcp (I keep the same IP address) from Demon with a lease time of 30 minutes and a refresh time of 15 minutes. Internet works perfect for 15 minutes, but after 15 minutes when the IP address is refreshed (with the same number) I get the debug message "interface BVI1 is attempting to shutdown" and I'm disconnected.

The temp.solution is to give a shut to bvi1 and a no shut and it works again.

I also tried to give BVI1 a static IP address (wich came from the dhcp server from Demon), but this is not accepted by Demon. I also gave BVI1 a static

mac-address.

I also tried the web interface and let him search the settings, also this works, but also for only 15 minutes.

I searched the whole cisco site regarding this problem, but could't find

anything about this problem. I tried to use another modem (Alcatel speedtouch home) and this works fine.

Is someone familiar with this problem? I have a cisco 827 ADSL

modem/router with standard IP (16MB/8MB)and IOS 12.1 Early release. I think

it's a bug in the IOS version, but I could be wrong.

Can somebody please help me to get the source/solution of the problem?

Regards,

Bert van der Kolk

1 REPLY
Bronze

Re: No DHCP refresh on cisco 827 and Demon DSL

From your description, it is quite possible that it could be a problem with the 827. I have heard about DHCP related problems with BVI and ATM interface earlier. If you have access to Bug Toolkit, you can use it to see if there are known issues related to your problem. You can also try upgrading to a different image and check.

261
Views
0
Helpful
1
Replies
CreatePlease to create content