Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

No Free B-channels

I need some help:

I have to configure 3 BRIs to work together as a DDR backup for a leased-line, so a maximum of 384Kbps. The chasis is CS 2620, IOS is c2600-js-mz.121-10a. It looks line the ISDN is not brought up by the Diaer1 interface:

ISDN BRI1/2: isdn_is_bchannel_available: No Free B-channels

ISDN BRI1/1: isdn_is_bchannel_available: No Free B-channels

ISDN BRI1/0: isdn_is_bchannel_available: No Free B-channels

The ISDN lines have been tested and confirmed OK by the telco provider.

However, sh isdn status looks like foll:

lmil055#sh isdn sta

Global ISDN Switchtype = basic-net3

ISDN BRI1/0 interface

dsl 8, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED ????????????????????????

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 8 CCBs = 0

The Free Channel Mask: 0x3 ???????????????????????

Number of L2 Discards = 0, L2 Session ID = 239

while the one that is NOT configured looks like:

ISDN BRI1/3 interface

dsl 11, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 11 CCBs = 0

The Free Channel Mask: 0x80000003 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Number of L2 Discards = 0, L2 Session ID = 0

Total Allocated ISDN CCBs = 0

When statring debug isdn q921/931/events and calling the ISDN numbers, it looks good, but the call is cleared, as it is voice. This seems normal.

Anyone, any ideas??? Thanx in advance for a hint.

I have attached here the config:

version 12.1

no service pad

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname xxxxxxx

!

boot system flash c2600-js-mz.121-10a

boot system flash

boot system rom

logging buffered 8192 debugging

no logging console

!

!

ip subnet-zero

no ip domain-lookup

!

no ip bootp server

ip multicast-routing

ip dvmrp route-limit 7000

ipx routing 0008.2160.9f40

isdn switch-type basic-net3

!

!

interface Loopback1954

description --- Special SRC interface used for CARI only

ip address 10.191.0.14 255.255.255.255

!

interface FastEthernet0/0

ip address 10.129.12.1 255.255.255.0

ip pim sparse-dense-mode

no ip route-cache

ip cgmp

no ip mroute-cache

duplex auto

speed auto

ipx input-sap-filter 1004

ipx network D6800000

!

interface Serial0/0

no ip address

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

no fair-queue

no frame-relay inverse-arp

!

interface Serial0/0.2 point-to-point

ip address 57.192.228.81 255.255.255.252

ip ospf cost 3125

ip ospf hello-interval 30

ipx network 19492080

ipx output-rip-delay 200

ipx output-sap-delay 200

ipx update interval rip 300

ipx update interval sap 300

frame-relay interface-dlci 159 IETF

!

interface Serial0/0.1111 multipoint

ip address 57.2.95.64 255.255.255.128

frame-relay map ip 57.2.3.201 48 IETF

frame-relay map ip 57.2.3.148 40 IETF

no frame-relay inverse-arp

!

interface Serial0/1

no ip address

shutdown

!

interface BRI1/0

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

keepalive 12

dialer pool-member 1 max-link 2

isdn switch-type basic-net3

no fair-queue

compress stac

no cdp enable

ppp authentication chap callin

ppp pap refuse

ppp multilink

!

interface BRI1/1

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

keepalive 12

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

compress stac

no cdp enable

ppp authentication chap callin

ppp pap refuse

ppp multilink

!

interface BRI1/2

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

keepalive 12

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

compress stac

no cdp enable

ppp authentication chap callin

ppp multilink

!

interface BRI1/3

no ip address

shutdown

isdn switch-type basic-net3

!

interface Dialer1

ip address 57.196.255.3 255.255.255.128

encapsulation ppp

no ip route-cache

no ip mroute-cache

keepalive 12

dialer pool 1

dialer remote-name sita-nas

dialer idle-timeout 100

dialer enable-timeout 10

dialer string 0286457516

dialer string 011558261

dialer load-threshold 150 either

dialer-group 1

no fair-queue

compress stac

no cdp enable

ppp authentication chap callin

ppp chap hostname xxxxxxx

ppp chap password yyyyyyy

ppp pap refuse

ppp multilink

multilink max-links 6

multilink min-links 2

multilink max-fragments 4

!

router eigrp 1949

passive-interface FastEthernet0/0

passive-interface Loopback1954

offset-list 0 in 2147483647 Dialer1

offset-list 0 out 2147483647 Dialer1

network 10.129.12.0 0.0.0.255

network 57.196.255.0 0.0.0.127

network 57.0.0.0

distribute-list 14 out Serial0/0.2

distribute-list 14 out Dialer1

distribute-list NONE in Dialer1

no auto-summary

no eigrp log-neighbor-changes

!

router ospf 100

no log-adjacency-changes

passive-interface FastEthernet0/0

network 10.129.12.0 0.0.0.255 area 0.0.0.0

network 10.191.0.14 0.0.0.0 area 0.0.0.0

network 57.192.228.80 0.0.0.3 area 0.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.191.0.17 240

ip route 0.0.0.0 0.0.0.0 Dialer1 250

ip route 57.2.3.0 255.255.255.0 57.2.3.201

ip route 57.2.3.148 255.255.255.255 Serial0/0.1111

ip route 57.2.3.201 255.255.255.255 Serial0/0.1111

ip route 57.7.0.0 255.255.0.0 Null0

ip route 57.7.0.0 255.255.224.0 57.2.3.201

ip route 57.7.20.0 255.255.255.0 57.2.3.148

no ip http server

!

!

ip access-list standard NONE

deny any

logging trap warnings

logging 57.7.20.10

logging 10.10.11.84

access-list 5 permit 10.64.56.128

access-list 14 permit 10.129.12.0 0.0.0.255

access-list 23 permit 57.7.0.0 0.0.255.255

access-list 23 permit 57.2.3.0 0.0.0.255

access-list 23 permit 57.2.95.0 0.0.0.255

access-list 23 permit 57.192.228.0 0.0.0.255

access-list 24 permit 57.2.95.0 0.0.0.255

access-list 24 permit 57.192.228.0 0.0.0.255

access-list 25 permit 10.10.12.77

access-list 25 permit 10.132.64.6

access-list 25 permit 10.197.36.1

access-list 25 permit 10.11.8.0 0.0.0.255

access-list 80 permit 57.7.0.0 0.0.63.255

access-list 81 permit 10.132.64.6

access-list 81 permit 10.197.50.44

access-list 81 permit 10.10.11.0 0.0.0.255

access-list 81 permit 10.10.12.0 0.0.0.255

access-list 81 permit 10.11.8.0 0.0.0.255

access-list 101 deny ip any host 255.255.255.255

access-list 101 deny eigrp any any

access-list 101 permit ip 10.129.12.0 0.0.0.255 any

access-list 101 permit ip any host 57.196.255.1

access-list 101 permit ip any host 1.1.1.1

access-list 1004 permit FFFFFFFF 4

access-list 1004 permit FFFFFFFF 29

access-list 1004 permit FFFFFFFF A0

access-list 1004 permit FFFFFFFF 98

access-list 1004 permit FFFFFFFF 103

access-list 1004 permit FFFFFFFF 115

access-list 1004 permit FFFFFFFF 12B

access-list 1004 permit FFFFFFFF 130

access-list 1004 permit FFFFFFFF 152

access-list 1004 permit FFFFFFFF 1E4

access-list 1004 permit FFFFFFFF 26B

access-list 1004 permit FFFFFFFF 278

access-list 1004 permit FFFFFFFF 39B

access-list 1004 permit FFFFFFFF 3DE

dialer-list 1 protocol ip list 101

!

........

privilege exec level 1 traceroute

privilege exec level 1 ping

privilege exec level 15 show ip access-lists

privilege exec level 1 show ip

privilege exec level 15 show access-lists

privilege exec level 1 show

!

........

10 REPLIES
Bronze

Re: No Free B-channels

The "sh isdn status" output would lead me to suspect the physical layer (cisco, cable, NT, etc). Since you do NOT have "isdn tei first" configured (although if you are in Germany that may be required), the physical layer should be up. The fact that you can attempt to make a voice call is interesting, too. Try adding the above command to the global config and see if that helps.

New Member

Re: No Free B-channels

1st: the router is based in Italy, I am based in Germany, so I do not think this solves the problem

2. I have done a loopback call on the BRI interfaces, that is using 1 B-channel to call the other B-channel with "isdn call interface BRIx/y and I could see that there was nothing wrong with Layer 1

3. I have checked and we could be experiencing several CISCO bugs like: CSCdu38445, CSCdu31091 and CSCuk24873.

Should we open a TAC case to confirm this??

New Member

Re: No Free B-channels

Hello Mihai,

We have the same problem on 2610 running 12.1(12b), with configuring pool members. With rotary-groups it seems to run correctly.

Have you opened a case ? What are the results ?

Kind regards,

Bernard GUY

TRANSPAC

New Member

Re: No Free B-channels

Hello,

we have had the same problems with IOS 12.1(11). Since we upgraded the Cisco's 2600 to 12.2(7) w have no further problems.

regards Ulrich

www.netaid.de

New Member

No Free B-channels

Am in Cameroon and i have thesame issue here is my config

controller E1 0/1/0

linecode ami

pri-group timeslots 1-16

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

dial-peer voice 54 pots

destination-pattern 0T

port 0/1/0:15

incoming called-number .

direct-inward-dial

!

isdn test call interface serial 0/0/0:15 00023775697183

Hall of Fame Super Gold

No Free B-channels

You're resurrecting a 10 yeard old thread.

Anyway, you can take "debug isdn Q.931" with "term mon", to check what happens.

New Member

No Free B-channels

#isdn test call interface Serial0/1/0:15 0023775697183

Nov 29 12:06:32.275: ISDN TEST CALL #0 to 0023775697183 at 64 Kbps failed aborting the remaining 1 calls

Hall of Fame Super Gold

No Free B-channels

If no debug output, you have controller or interface down, usually due to faulty circuit.

New Member

No Free B-channels

here is the config

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

dial-peer voice 54 pots

destination-pattern 0T

port 0/1/0:15

incoming called-number .

direct-inward-dial

!

isdn test call interface serial 0/0/0:15 00023775697183

Here is my error message

Nov 29 10:35:42.928: ISDN Se0/1/0:15 EVENTd: isdn_is_bchannel_available: No Free B-channels

Nov 29 10:35:42.928: ISDN TEST CALL #0 to 0023775697183 at 64 Kbps failed aborting the remaining 1 calls

my card is NM-2CE1T1-PRI on a 2800 series router

Hall of Fame Super Gold

Re: No Free B-channels

As indicated above already: Check controller and interface status.      

660
Views
0
Helpful
10
Replies
CreatePlease to create content