Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

no ip conection

I am trying to replace a 3com office connect(which is working fine) with a cisco 1720 and cannot get the replacement to talk to the core routers. The router has three connections, ethernet to local LAN which works fine. The other connections are two frame relay pvc's to different 3com NB11 routers, one is the backup to the other. It is these that have the problem.

They are both in seperate sub-nets. I have double checked that the pvc's ends are not swapped and I have aligned the ip subnets correctly with the pvc's.

I cannot ping the other end of the connection even though the router reports the link up and SH INT shows the interfaces to be up. I did check I'd enabled ip routing.

Help!!

config is below

sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname aniasgair

!

enable secret xxxxxx

enable password xxxxx

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip domain-lookup

!

!

!

interface Loopback0

ip address 55.55.55.55 255.255.255.255

no ip directed-broadcast

!

interface Serial0

no ip address

ip helper-address 57.200.127.255

ip directed-broadcast

encapsulation frame-relay

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0.16 point-to-point

description Backup link to HQ

bandwidth 64

ip address 57.4.14.129 255.255.255.128

ip helper-address 57.200.127.255

ip directed-broadcast

ip ospf authentication-key cisco

ip ospf cost 4000

no cdp enable

frame-relay class data

--More-- frame-relay interface-dlci 16

!

interface Serial0.17 point-to-point

description Primary link to Longman

bandwidth 64

ip address 57.4.14.1 255.255.255.128

ip helper-address 57.200.127.255

ip directed-broadcast

ip ospf authentication-key cisco

no cdp enable

frame-relay class data

frame-relay interface-dlci 17

!

interface FastEthernet0

ip address 57.55.31.1 255.255.128.0

ip directed-broadcast

half-duplex

no cdp enable

!

router ospf 100

log-adjacency-changes

area 0.0.0.55 authentication

redistribute connected metric 2000 metric-type 1 subnets

--More-- network 57.5.84.1 0.0.0.0 area 0.0.0.55

network 57.5.84.129 0.0.0.0 area 0.0.0.55

network 57.72.31.1 0.0.0.0 area 0.0.0.55

!

ip classless

ip forward-protocol udp 1604

no ip http server

!

!

map-class frame-relay data

no frame-relay adaptive-shaping

frame-relay cir 48000

frame-relay bc 48000

frame-relay be 16000

frame-relay mincir 48000

no cdp run

snmp-server engineID local 00000009020000036B9A1443

snmp-server community public RO

snmp-server community private RW

snmp-server host 57.200.91.65 private

!

aniasgair#

When I run various forms of DEBUG IP .... I see that packets from the core router interfaces are not only being sent and recieved but I am also seeing packets (icmp) from my network manager. The ospf side of things is obviously not happening as basic ip connectivity has not be achieved.

  • Other Network Infrastructure Subjects
2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Re: no ip conection

Hi,

The most obvious thing I can see here is that you are using the encapsulation frame-relay command [ which uses Cisco frame-relay encapsulation]. You need to change this to IETF. Look at the example below-

The following example configures Cisco Frame Relay encapsulation on interface serial 1:

interface serial 0

encapsulation frame-relay

Use the ietf keyword if your router or access server is connected to another vendor's equipment across a Frame Relay network to conform with RFC 1490:

interface serial 0

encapsulation frame-relay ietf

New Member

Re: no ip conection

You have to run IETF for these two devices to be able to communicate.

Dennis

3 REPLIES
New Member

Re: no ip conection

Hi,

The most obvious thing I can see here is that you are using the encapsulation frame-relay command [ which uses Cisco frame-relay encapsulation]. You need to change this to IETF. Look at the example below-

The following example configures Cisco Frame Relay encapsulation on interface serial 1:

interface serial 0

encapsulation frame-relay

Use the ietf keyword if your router or access server is connected to another vendor's equipment across a Frame Relay network to conform with RFC 1490:

interface serial 0

encapsulation frame-relay ietf

Silver

Re: no ip conection

What does 'sh frame-relay pvc' show ? active inactive or deleted pvcs?

If they are active , I would remove the ospf authentication and see if it works with out authenication configured , if it still fails , I would remove the ip helper statement .

New Member

Re: no ip conection

You have to run IETF for these two devices to be able to communicate.

Dennis

94
Views
0
Helpful
3
Replies
This widget could not be displayed.