Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

no shutdown problems

Hello,

I am running version 11.2(8.1)SA6 IOS on a Cisco Catalyst 2924.

We are experiencing problems when issuing the 'no shutdown' command on the switch.

Although a switch port can be shutdown, the command to enable it again 'no shutdown' fails to bring the port administratively up again.

Does anyone have any ideas why this is happening ?

Many Thanks,

Charles

6 REPLIES

Re: no shutdown problems

Have you tried to loop a port via CLI, there is a bug associated with a similar issue but only when port is attached to a router, also this was found in an earlier version but no fix applied that i can see.

The workaround was to loop then no shut immediately (give or take 2 seconds).

New Member

Re: no shutdown problems

Hi - thanks for replying so quickly.

The port(s) in question are user ports. Can you tell me what you mean by loop the ports ?

Thanks,

Charles

Re: no shutdown problems

You can loop the ports, this is just to trick the IOS basically.. I will not guarantee this will fix it.

If this works it will just be a workaround..:(

Eg:

int fast 0/ x

no shut

loop

no loop

Also you could try clear int fas 0/x

New Member

Re: no shutdown problems

Unfortunately, no joy doing this.

It looks like I will just have to upgrade the IOS.

Thanks for your help.

Re: no shutdown problems

Yip, seems the only way.. Sorry about that.

New Member

Re: no shutdown problems

i ran into a similar problem just yesterday. the problem i ran into is that the vlan assigned to the port wasn't actually a vlan within the VTP domain, so the client and the switch would not signal properly. I ended up with an amber light on the switch, a green light on the client, and a status of down, down on the interface. I did a shut and a no shut on the ports, but they would not come up until I put the ports in a VLAN within the vtp domain. i hope this helps.

138
Views
0
Helpful
6
Replies
CreatePlease login to create content