Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

No Telnet access anymore

Hi,

I have a 826 ADSL Router.

It used to work as a dynamic NAT router. Recently I needed to change the ethernet interface's IP adres, and turn off dynamic NAT (Because we had a public IP subnet. There ares still several static NAT entries).

I changed the interface's IP addressand the access list used. But since then I can't use telnet anymore to configure te router. I only can configure it with the console interface. The router works fine, but fysical access is difficult, so I want to be able to use telnet again. I tried some variations in the vty line settings, but the router refuses all requests on port 23.

Can anyone help me out here.

Thanks in advance.

8 REPLIES
New Member

Re: No Telnet access anymore

What message it is giving when u try to telnet.?

Also it seems you have console access to the router. So remove any

access-class statements on all the vty lines. and try configuring the vty lines.

set the login and password.

This should work.

-Deepu

New Member

Re: No Telnet access anymore

Thanks for the help,

I removed the access-class, I set the login and the password again, but I still get the following messing when trying to connect (win 2000):

Connecting To X.X.X.X ...Could not open a connection to host on port 23 : Co

nnect failed

Now it is getting strange, I did a port scan on the router, and guess port 23 is a listening port, I tried to connect to it with hyperterminal, and then I get a connection! (This didn't work before so thanks for the answer you provided)

What could that be?

Kind regards

Silver

Re: No Telnet access anymore

Cross check your NATting config. You might be trying to telnet into an address that is being NATted. Depending on your config, you might not be able to telnet into it. Post your config for more help. Thanks

New Member

Re: No Telnet access anymore

Hi,

check if you have configured firewall or nat. post you config if possible.

Regards

Kiruba

New Member

Re: No Telnet access anymore

Thanks for the help,

I removed the access-class, I set the login and the password again, but I still get the following messing when trying to connect (win 2000):

Connecting To X.X.X.X ...Could not open a connection to host on port 23 : Co

nnect failed

Now it is getting strange, I did a port scan on the router, and guess port 23 is a listening port, I tried to connect to it with hyperterminal, and then I get a connection! (This didn't work before so thanks for the answer you provided)

What could that be?

Kind regards

Silver

Re: No Telnet access anymore

If you can connect on the console do so and do a sh line , you may have the exec-timeout on your vty lines to set to infilinty, the command is 'exec-timeout 0 0 ' do a sh line and see how mant vty sessions are open, If this is the case use the command 'exec-timeout 15 0 ' this will set the timeout to 15 minutes then clear all the vty lines.

New Member

Re: No Telnet access anymore

You need to give transport input telnet or transport input all to allow the telnet session.

try giving this command under the vty lines.

-Deepu

New Member

Re: No Telnet access anymore

Thank you all for the response, everything is working just fine now (I disabled and enables the vty lines).

Kind regards and many thanks to all of you,

Glenn Volckaert

151
Views
0
Helpful
8
Replies
CreatePlease to create content