Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

No VLAN.DAT file; VTP client mode, will switch boot OK?

Hi,

I've been having reachability problems with a few of my remote switches and attempted a CiscoWorks RME IOS upgrade to 1 of them last night.

CiscoWorks copied the image down alright but lost it's connection to the switch before it could finish it's stuff. As a result a few of the files from flash are missing.

My question is if I schedule a reload of the router tonight will it re-establish it's connection to the network? It is currently running OK.

Here is some output from the switch that I think is relevant (ie. vtp status, contents of flash, typical access port config, and trunked port config):

SandalwoodYard#show vtp status

VTP Version : 2

Configuration Revision : 331

Maximum VLANs supported locally : 254

Number of existing VLANs : 90

VTP Operating Mode : Client

VTP Domain Name : cob

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Enabled

MD5 digest : 0x02 0xE0 0x83 0x3C 0x65 0x25 0x04 0x52

Configuration last modified by 172.30.11.202 at 5-18-06 14:56:43

SandalwoodYard#dir flash:

Directory of flash:/

2 -rwx 342 Jun 14 2006 09:35:15 env_vars

3 -rwx 1593344 Jun 14 2006 03:20:16 c2900xl-c3h2s-mz.120-5.WC15.bin

4 -rwx 5417 Jun 14 2006 09:37:19 config.text

3612672 bytes total (2012160 bytes free)

SandalwoodYard#sh run int Fa0/3

Building configuration...

Current configuration:

!

interface FastEthernet0/3

switchport access vlan 211

spanning-tree portfast

no cdp enable

end

SandalwoodYard#sh run int Fa2/4

Building configuration...

Current configuration:

!

interface FastEthernet2/4

description Fibre Link to City Hall 2nd Floor Data Centre

duplex full

speed 100

switchport trunk encapsulation dot1q

switchport trunk native vlan 99

switchport trunk allowed vlan 1,99,211,1002-1005

switchport mode trunk

end

SandalwoodYard#

Basically, I'm wondering if on reboot if the VLANs will be defined properly (by this VTP client pulling VLAN info from the VTP server) or if without a VLAN.DAT file the switch won't have any VLANs defined after a reboot.

If a reboot will cause me problems, is there anything I can do proactively to rectify this (ie. putting the switch in transparent mode)? Note: This switch is at a remote location so not easily accessible.

Let me know if you need more information.

Thanks, Ian.

9 REPLIES

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

Hello,

Make sure that the server have a higher configuration revision that this client. eventhough this is a client, if it has a higher configuration revision and it does not have all the vlan that the server suppose to have, this clietn will overwirte the server's vtp due to the client's higher config revision. an example is as follows:

The configuration revision number of the switch that you inserted was higher than the configuration revision number of the VTP domain. Therefore, your recently introduced switch, with almost no configured VLANs, erased all VLANs through the VTP domain.

This happens whether the switch is a VTP client or a VTP server. A VTP client can erase VLAN information on a VTP server. You can tell that this has happened when many of the ports in your network go into inactive state but continue to be assigned to a nonexistent VLAN.

The following link have different scenarios on VTP problems and how to T/S it:

http://www.cisco.com/en/US/tech/tk389/tk689/technologies_tech_note09186a0080094c52.shtml

New Member

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

Hi,

Thanks for your reponse. The version number on the server is 331 like the client. This vtp client switch is already on the network. I'm aware of the issues with vtp revision numbers ... I'm just unsure if this switch will re-establish it's connection to the network on reboot given it's current config AND the fact it does not have a VLAN.DAT file in flash.

Ian.

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

VTP is exchanged when the trunk between the client and the server are established, that's when the vtp on the client gets updated. no trunk no vtp exchange.

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

Can we do like...

i think you should first of all connect then new switch if you have...and make it server and lets the existing server to send its vlan information to it so you will have the all the same vlan on the existing server to the newly attached server and then remove your old one and just reaload it ...and then again connect to the same network...may it will be help full to you...

rate this post if it helps

regards

Devang

New Member

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

Thanks for your response. When you say " that's when the vtp on the client gets updated", am I to assume that this is when the VLAN.DAT file gets created on the client? There was a VLAN.DAT on the vtp client switch and during the partial IOS upgrade by CiscoWorks it was lost. I am assuming that the VLAN.DAT file on the VTP client is needed since it used to be there.

Ian.

Gold

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

Been watching this thread and have a concern that I have not seen addressed.

It is my impression that the vlan.dat file contains the vtp domain. When I erase the vlan.dat file it set its back to blank as well as vtp server mode.

If you do not use a password I suspect the switch will come up in the correct vtp domain since it seems to set itself to the first it hears but it will be in server mode. You would need to change it back to client. If you use a password it will stay set to blank so it will not get any data and you must manually set the vtp domain and password.

I tested this on 2 of my lab switches and it appears you can get the client to recreate the vlan.dat file by adding a vlan on the vtp server. If you do this it should be ok when you reboot

New Member

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

the amount of aggrevation caused by vtp in a network is now visible...

My question is HOW big is this network? Do you even need vtp ?

If your network is under 20 switches (and it should be even if you have more than 20 switches, as you should be breaking things up with layer 3 routing after 3 switches anyway, just set vtp to transparent (or even better, OFF if you have CATOS).

VTP is not really worth the extra effort, unless you have a really old switched network with many switches (like a college campus) and have not redesigned to a layer 3 routed environemnt from distribution and up yet. IMHO vtp is a dog with fleas for all the reasons we have seen in the thread...(GVRP is even worse)

New Member

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

Hi,

I have migrated most of the switches to vtp transparent mode but just have not got them all done yet ... so much to do and no one to delegate to :-) ... oh well, keeps me out of trouble!

Thanks, Ian.

New Member

Re: No VLAN.DAT file; VTP client mode, will switch boot OK?

Fantastic! I just deleted a VLAN I know longer need on my 6513 which is the VTP server and voila ... all of a sudden a VLAN.DAT file appeared on the switch in question.

Thanks for your assistance, Ian.

581
Views
5
Helpful
9
Replies
CreatePlease to create content