Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Not able to change auto to trunk mode on switch

SW-B-TOP(config-if)#switchport mode trunk

When trying to execute the above command am getting the following error.

Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

17 REPLIES
Purple

Re: Not able to change auto to trunk mode on switch

You have to specifically set the encapsulation type first "switchport encapsulation dot1q" then try youir command...

New Member

Re: Not able to change auto to trunk mode on switch

it's not accepting.

SW-B-TOP(config-if)#switchport encapsulation dot1q

^

% Invalid input detected at '^' marker

the model is CGESM.

New Member

You forgot the "TRUNK"

You forgot the "TRUNK" portion to the command. It's SWITCHPORT TRUNK ENCAPSULATION DOT1Q

New Member
Purple

Re: Not able to change auto to trunk mode on switch

You need to specifically set the encapsulation first , "switchport encapsulation dot1q" then issue your trunk command...

Purple

Re: Not able to change auto to trunk mode on switch

can you post the config...

Re: Not able to change auto to trunk mode on switch

Hi All,

The command which he need to enter first is

"switchport trunk encapsulation dot1q " and then he can confgigure the interface in trunk mode.

So try this command

switch(config)#interface fa0/1

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)#switchport mode trunk

and you will be good to go.

HTH, if yes please rate the post.

Ankur

New Member

Re: Not able to change auto to trunk mode on switch

Thanks Ankur

Should we need to disable the concerned vlan of the port before entering the configuration.

Re: Not able to change auto to trunk mode on switch

Hi Friend,

Thats not required because if you put the config which I posted in my previous mail it will take care of the issue.

HTH, if yes please rate the post.

Ankur

New Member

Not able to change auto to trunk mode on switch

This worked on one of the switches and not the other?! 

What do you think could be the cause besides lab technical issues?

New Member

Not able to change auto to trunk mode on switch

Could you run a " sh int gig #/# capabilities"

look under Trunk encap. type:

and Trunk mode:

it will give you capabilities information of the port

New Member

Not able to change auto to trunk mode on switch

The command is "switchport TRUNK encapsulation dot1q".  This will then allow the command "Switchport MODE TRUNK".

This is the core to the configuration - You NEED this command to run a standard trunk configuration otherwise it WILL NOT work...

New Member

Hi Ankur,I have question why

Hi Ankur,

I have question why for switch multilayer is different from switch not multilayer if we need configure trunk on port?

 

Thanks,

New Member

Thank you that worked for me!

Thank you that worked for me!

New Member

switchport trunk

switchport trunk encapsulation dot1q is not working.  After switchport trunk its not accepting encapsulation

New Member

Akser I believe u r trying

Akser

New Member

Thanks your guidance worked

Thanks your guidance worked great and now my ports are trunking.

33791
Views
74
Helpful
17
Replies