Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Not getting IP from DHCP on 2950

Dear all,

access switch is connected to base switch and base switch is connected to DHCP server, however users are connected to access switch are not getting IP address. Hence i would like to know the solution from experts.

I remember there is a command in CATOS "set port host" by this way we can enhance port to get IP quickly..if there is any command similiar in IOS?

Your assistance will be highly appreciated.

Regards,

Khan.

4 REPLIES

Re: Not getting IP from DHCP on 2950

Khan,

The problem of users not getting IP from the DHCP usually happens when 'spanning-tree portfast' is not enabled on access ports. PCs don't wait long enough for DHCP responses and time out.

Can you make sure all the access ports, to which the users are connected to, have spanning tree portfast enabled.

HTH,

Sundar

New Member

Re: Not getting IP from DHCP on 2950

Yes, Spanning tree portfast enabled for all access ports...still not able to get IP from DHCP?

Re: Not getting IP from DHCP on 2950

Is the DHCP server on the same VLAN as the users having the problem?

Purple

Re: Not getting IP from DHCP on 2950

The equivalent command for set port host in catos on a IOS box is the "switchport host" command ,turns on portfast, turns off trunking and channeling... The other question is , is the dhcp server on the same subnet and vlan as the users that aren't getting an IP ? If yes then I wouls suspect the dhcp server itself..

124
Views
0
Helpful
4
Replies
CreatePlease login to create content