Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NTP synchronization problem

HI dear All

I have confiured my one of routers (3640) in LAN like this .....

! interface ethernet 0/0

Ip address 192.168.70.3

!

! Ntp Server 192.168.70.234 prefer

Ntp source ethernet 0/0

!

Here 192.168.70.234 is my PC (windows 2000 ) IP address ., which is running

NTP Service , and i have configred my PC to to synchronize time from other PUblic ntp servers like 132.163.4.102 ,132.163.40.103 etc ..etc

Now if we give following NTP status commands on router ......

router# show ntp status

clock is unsynchronized, stratum 16....

.........

.....

and if we give this command

router#show ntp associations

address ref clock st when poll reach ~192.168.70.234 132.163.4.102 2 4 64 377

* master (synced) #master(unsynced) + selected

n if we give this command

router#show ntp associations detail

master 192.168.70.234 clock is insane ,invalid

ref ID 132.163.4.102 stratum 2

somthing like this,, these are short command outputs ,if u need full , then i can send it again

Why router is not getting sync where as it is taking ref clock as public stratum 2 server. How it is so ?

Any suggestions are welcome for this query !

thanks n regards

naveen

5 REPLIES
New Member

Re: NTP synchronization problem

Hi,

What NTP service are you using? Is it a full NTP port? If so, you should have the 'ntptrace' and 'ntpq' client tools. If not, you can get them in the NTP NT port at http://www.five-ten-sg.com . 'ntptrace' verifies the current ntp chain to the stratum 1 server. 'ntpq' is an interactive tool with commands similar to the 'sho ntp' output. The 'assoc' and 'peer' commands will show you what you need.

Run them on the pc to verify that it is synchronized. Based on the output above, it doesn't look it is.

Greg

New Member

Re: NTP synchronization problem

Hi

thanks for ur support.

I have 'ntptrace' and 'ntpq' client tools. i installed the GUI ntp 4.1.71 from

http://www.five-ten-sq.com on my windows2000 PC.

NTP service in administrative tools -> services is running. after that i tried with following commands -

P:\>ntptrace

naveen.moe.edu.kw: stratum 16, offset 0.003512, synch distance 0.01486

naveen.moe.edu.kw: *Not Synchronized*

Note : naveen.moe.edu.kw is my PC name

ntpq> asso

ind assID status conf reach auth condition last_event cnt

===========================================================

1 46924 8000 yes yes none reject

2 46925 8000 yes yes none reject

ntpq> peer

remote refid st t when poll reach delay offset jitter

==============================================================================

time-B.timefreq 0.0.0.0 16 u - 64 0 0.000 0.000 4000.00

time-C.timefreq 0.0.0.0 16 u - 64 0 0.000 0.000 4000.00

ntpq>

i think my PC is not getting synchronized

i have following public servers in my ntp.conf file .

132.163.4.102

132.163.4.103

what should i do ?

wating for ur reply

thanks n regards

bye

naveen

New Member

Re: NTP synchronization problem

Hi Naveen,

You're right, your pc is definitely not syncing with these servers. Be sure you can ping them to rule out routing issues, but since 'reach' is 'yes' you probably can. My best guess is that since these are NIST servers, they might be restricting the response to North America.

It isn't a good idea to be pulling time from that far away anyway. You should really try to find servers that are close geographically and and net hop wise. Also, you should try to pull time from separate sources, not from the same company or agency. It is also considered good netiquette for individuals and smaller institutions to pull time from Stratum 2 servers.

Check this list: http://www.eecis.udel.edu/~mills/ntp/clock2.htm

.. for public Stratum 2 servers. I didn't seen any in Kuwait, but you could probably pull time from somewhere in Europe. Once you've selected a few, run traceroutes to see which ones are consistently close. Also check with your ISP. They might have servers their clients can use.

Greg

New Member

Re: NTP synchronization problem

Oh, one more thought. If you are running the latest version 4 software, you might want to try setting the requests to version 3, which has been the standard until recently. The lines in ntp.conf should look like:

server 132.163.4.102 version 3

Your earlier post showed that you had synced at stratum 2, but were 'insane'. This could be caused by extreme variability in response times by going to the other side of the world. It may eventually sync up over several hours, but will drift in and out of 'insanity'.

Greg

New Member

Re: NTP synchronization problem

Hi Dear Greg

I tried to get the closest NTP hop from kuwait with traceroute , and i foundthat the one which i have configured in NTP.CONF file --- 132.163.4.102 is close as compared to other servers wheather it is in Europe.

bcoz the configured one is taking 21 hops , but other are reachable going more than 21 hops.

even though i configured ,, and put version 3 than also it is not able to get synchronize.

on the other hand i have installed one atomic clock sync client from internet to sync my pc time. and this one is able correct my PC time.

than why not the NTP service is not syncronizing ?

do u think bcoz of Firewall also it does affect ?

my pC is behind firewall.

but how ? as far as reach = yes when we ask ntpq->asso

reach = 0 when we ask ntpq-> peer

i don't think firewall is blocking

have any other solution for this ?

tell me

naveen

322
Views
0
Helpful
5
Replies
CreatePlease login to create content