Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

null entry in "sh ip route"

Hi All,

why am I getting the below, a null entry for 192.168.169.0.?

Roger#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

192.168.169.0/24 is variably subnetted, 2 subnets, 2 masks

D 192.168.169.0/24 is a summary, 00:03:25, Null0

C 192.168.169.0/30 is directly connected, FastEthernet0/0

Here is sh run

Roger#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Roger

!

enable secret xxxx

enable password regor

!

!

!

!

!

ip subnet-zero

ip host tom 192.168.169.1

!

!

!

process-max-time 200

!

interface FastEthernet0/0

ip address 192.168.169.2 255.255.255.252

no ip directed-broadcast

speed 100

full-duplex

!

interface FastEthernet0/0.110

no ip directed-broadcast

!

interface FastEthernet0/1

ip address 192.168.168.1 255.255.255.0

no ip directed-broadcast

!

router eigrp 1

network 192.168.168.0

network 192.168.169.0

!

ip classless

no ip http server

!

!

line con 0

transport input none

line aux 0

line vty 0 4

password 1234

login

!

no scheduler allocate

end

Roger#

This is just a study device at home. 2 2600s connected via crossover and a switch on either router(1900 and 2900).

Cheers.

coolboarderguy...

8 REPLIES

Re: null entry in "sh ip route"

When you look at the routing info a bit more carefully, you will see that the "null" entry is preceded by a capital D.

This means the route was learned by eigrp. I guess that one of your previous experiments on the other router included eigrp route summarization!?

Regards,

Leo

New Member

Re: null entry in "sh ip route"

****

I guess that one of your previous experiments on the other router included eigrp route summarization!?

****

Hi All,

thanx, Leo but I have never summarized on either routers, though. Cheers.

coolboarderguy...

New Member

Re: null entry in "sh ip route"

Hi All,

the 2nd router, Tom, is showing similar.

Tom#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.167.0/24 is directly connected, FastEthernet0/1

192.168.169.0/24 is variably subnetted, 2 subnets, 2 masks

D 192.168.169.0/24 is a summary, 00:00:10, Null0

C 192.168.169.0/30 is directly connected, FastEthernet0/0

Tom#

and the sh run

Tom#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Tom

!

enable secret 5 $1$pwJW$eRCDshGxVapccQPG8oG2U/

!

!

!

!

!

ip subnet-zero

ip host roger 192.168.169.2

!

!

!

process-max-time 200

!

interface FastEthernet0/0

ip address 192.168.169.1 255.255.255.252

no ip directed-broadcast

speed 100

full-duplex

!

interface FastEthernet0/1

ip address 192.168.167.1 255.255.255.0

no ip directed-broadcast

!

router eigrp 1

network 192.168.167.0

network 192.168.169.0

!

ip classless

no ip http server

!

!

line con 0

transport input none

line aux 0

line vty 0 4

password 1234

login

!

end

Tom#

Cheers.

coolboarderguy...

Re: null entry in "sh ip route"

OK, now I see. On both sides, you specified network 192.168.169.0. With EIGRP, the default is to summarize routes. The /24 is a summary of all routes within 192.168.169. There is only one, a /30 that you use for your router-router subnet.

Use the additional eigrp-command: no auto-summary to alter this.

Regards,

Leo

Re: null entry in "sh ip route"

Hi Coolderbyguy,

Both EIGRP and OSPF in new IOS codes generates a route pointing to null interface if route summarization is been done to avoid possible routing loop.

EIGRP is auto summarization and in ospf when you summarize the routes on ABR you will always see this route pointing to null interface to avoid loop.

In old codes it was recommended to configure manually but new IOS codes are smart enough.

HTH

Ankur

Hall of Fame Super Silver

Re: null entry in "sh ip route"

Leo is correct in identifying the null route as a default behavior of EIGRP. And he is correct that if you want to not have the summary route that no auto-summary will make EIGRP not insert it. But I am not sure that Mark in the original post was objecting to it, I interpret the original post as wanting to understand where it came from and why it is there.

Leo correctly observes that the default behavior of EIGRP is to summarize routes. It is a reflection of the background of EIGRP originating in a mostly classful orientation and trying to create a routing protocol with classless capability. It is an essentially classful behavior to summarize routes at network edges. So you configure the router to know about a small part of the network (192.168.169.1 255.255.255.252) and the router will advertise over interfaces in other networks 192.168.169.0 255.255.255.0.

Now lets consider what happens when the router does advertise that. It is telling its neighbors that if they need to get to anything in the 192.168.169.0 network that they can forward to this router. So what happens if some neighbor forwards a packet whose destination addrress is 192.168.169.251? How do you forward that packet? So EIGRP creates the summary route to the /24 and points it to null. This protects against getting a packete for forward and having nowhere to forward it.

So that is why EIGRP automatically summarizes and why it needs to create the null route. You will need to evaluate whether your network implementation is better to keep the default behavior (let EIGRP summarize and create the summary to null) or to change the behavior with no auto-summary.

HTH

Rick

New Member

Re: null entry in "sh ip route"

Hi All,

thanx, Rick, very handy info, indeed. Cheers.

coolboarderguy...

New Member

Re: null entry in "sh ip route"

Hi All,

thanx, Leo, great stuff. Cheers.

coolboarderguy...

199
Views
0
Helpful
8
Replies