Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

on 3640, line is still up till 8 sec after disconnecting..

Hi

I have 3640 router with async modules. I make a callback on this async lines. when user disconnect the line, after that line is still up till 8 to 10 sec, It's not down automatically same time.

please help me..

3 REPLIES
Cisco Employee

Re: on 3640, line is still up till 8 sec after disconnecting..

Turn on "debug modem" to track the modem activities when the user hang up the line..Post it here..Thx..Tejal

New Member

Re: on 3640, line is still up till 8 sec after disconnecting..

The problem is that, when one time user is connected and disconnect the line,, another user can connect through this line at around one or two min.. I change the line configration different way but result is same, no change...Tthe show ver, sh run and debug modem is as follow:

------------------ show version ------------------

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-I-M), Version 12.1(4), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Wed 30-Aug-00 04:49 by cmong

Image text-base: 0x60008940, data-base: 0x60898000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (f

c1)

SABAS uptime is 6 weeks, 5 days, 1 hour, 30 minutes

System returned to ROM by power-on

System image file is "flash:c3640-i-mz_121-4.bin"

cisco 3640 (R4700) processor (revision 0x00) with 28672K/4096K bytes of memory.

Processor board ID 07674692

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

32 terminal line(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

------------------ show running-config ------------------

Building configuration...

Current configuration : 20712 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname SABAS

!

logging buffered 20000 debugging

no logging console

enable password 7

!

ip subnet-zero

ip name-server 168.187.9.2

ip name-server 168.187.9.3

ip name-server 208.222.12.24

!

chat-script offhook "" "ATH1" OK \c

chat-script mod ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 30 CONNECT \

c

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30 CON

NECT \c

!

!

!

interface FastEthernet0/0

ip address 192.168.2.254 255.255.255.0

duplex auto

speed auto

!

interface Group-Async1

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

async dynamic address

async mode interactive

peer default ip address pool g1

compress mppc

ppp authentication pap

group-range 33 48

!

interface Group-Async3

ip unnumbered FastEthernet0/0

encapsulation ppp

no ip mroute-cache

async mode interactive

peer default ip address pool g1

compress mppc

ppp authentication pap

group-range 97 112

!

router rip

network 192.168.2.0

!

ip local pool g1 192.168.2.221 192.168.2.253

no ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.10

ip route 192.168.1.0 255.255.255.0 192.168.2.10

no ip http server

!

!

line con 0

exec-timeout 0 0

password 7

logging synchronous

transport input none

line 33 48

timeout login response 3

autoselect ppp

script dialer mod

login local

modem InOut

transport preferred none

transport input all

transport output none

stopbits 1

flowcontrol hardware

line 97 112

timeout login response 3

autoselect ppp

script dialer mod

login local

modem InOut

transport input all

stopbits 1

flowcontrol hardware

line aux 0

line vty 0 4

exec-timeout 0 0

password 7

logging synchronous

login

!

end

Debug modem:-

Config change: asserting DTR

/1 Mcom: in modem state 'Dialing/Answering'

/1 Mcom: in modem state 'Incoming ring'

/1 Mcom: in modem state 'Waiting for Carrier'

/1 Mcom: in modem state 'Connected'

/1 Mcom: CONNECT at 21600/14400(Tx/Rx), V34, LAPM, V42bis, Answer

DSR came up

Modem: IDLE->(unknown)

Autoselect started

create timer type 0, 120 seconds

Autoselect sample 7E

Autoselect sample 7EFF

Autoselect sample 7EFF7D

Autoselect sample 7EFF7D23

utoselect cmd: ppp negotiate

destroy timer type 0 (OK)

EXEC creation

create timer type 1, 600 seconds

destroy timer type 1 (OK)

destroy timer type 0

-UPDOWN: Interface Async98, changed state to up

/1 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

/1 Mcom: switching to PPP mode

/1 Mcom: PPP escape map: Tx map = 0, Rx map = 0

OTO-5-UPDOWN: Line protocol on Interface Async98, changed state t

CONFIG_I: Configured from console by aha on vty0 (192.168.1.58)

/1 Mcom: in modem state 'Disconnecting'

/1 Mcom: DISCONNECT, duration = 00:00:51, reason (0xE) Remote Lin

DSR was dropped

Modem: READY->(unknown)

OTO-5-UPDOWN: Line protocol on Interface Async98, changed state t

/1 Mcom: in modem state 'Idle'

dropping DTR, hanging up

Async Int reset: Dropping DTR

Modem: HANGUP->(unknown)

/1 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

cleanup pending. Delaying DTR

-CHANGED: Interface Async98, changed state to reset

cleanup pending. Delaying DTR

cleanup pending. Delaying DTR

cleanup pending. Delaying DTR

/1 Mcom: switching to character mode

destroy timer type 0

destroy timer type 1

destroy timer type 3

destroy timer type 4

destroy timer type 2

: allowing modem_process to continue hangup

restoring DTR

-UPDOWN: Interface Async98, changed state to down

/1 Mcom: in modem state 'Dialing/Answering'

/1 Mcom: in modem state 'Incoming ring'

/1 Mcom: in modem state 'Waiting for Carrier'

/1 Mcom: in modem state 'Disconnecting'

/1 Mcom: DISCONNECT, duration = 00:00:00, reason (0x2) No carrier

/1 Mcom: in modem state 'Idle'

CONFIG_I: Configured from console by aha on vty0 (192.168.1.58)

CONFIG_I: Configured from console by aha on vty0 (192.168.1.58)

CONFIG_I: Configured from console by aha on vty0 (192.168.1.58)

CONFIG_I: Configured from console by aha on vty0 (192.168.1.58)

/1 Mcom: in modem state 'Dialing/Answering'

/1 Mcom: in modem state 'Incoming ring'

/1 Mcom: in modem state 'Waiting for Carrier'

/1 Mcom: in modem state 'Connected'

/1 Mcom: CONNECT at 21600/12000(Tx/Rx), V34, LAPM, V42bis, Answer

DSR came up

Modem: IDLE->(unknown)

Autoselect started

create timer type 0, 120 seconds

Autoselect sample 7E

Autoselect sample 7EFF

Autoselect sample 7EFF7D

Autoselect sample 7EFF7D23

utoselect cmd: ppp negotiate

destroy timer type 0 (OK)

EXEC creation

create timer type 1, 600 seconds

destroy timer type 1 (OK)

destroy timer type 0

-UPDOWN: Interface Async98, changed state to up

/1 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

/1 Mcom: switching to PPP mode

/1 Mcom: PPP escape map: Tx map = 0, Rx map = 0

OTO-5-UPDOWN: Line protocol on Interface Async98, changed state t

/1 Mcom: in modem state 'Disconnecting'

/1 Mcom: DISCONNECT, duration = 00:00:24, reason (0xE) Remote Lin

OTO-5-UPDOWN: Line protocol on Interface Async98, changed state t

DSR was dropped

Modem: READY->(unknown)

/1 Mcom: in modem state 'Idle'

Async Int reset: Dropping DTR

/1 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

dropping DTR, hanging up

Modem: HANGUP->(unknown)

1 Mcom: in modem state 'Dialing/Answering'

/1 Mcom: in modem state 'Incoming ring'

/1 Mcom: in modem state 'Waiting for Carrier'

Modem State: Disconnec

: event-MODEM_DISCONNECTED New State-IDLE_STATE

End connection: Retransmits for MNP block (TX/RX) = 0/0

Duration = 0:00:00, Number of TX/RX char = 125379/2538419

Local Disc Reason = No carrier..

Cisco Employee

Re: on 3640, line is still up till 8 sec after disconnecting..

Config looks fine but we love to have the timestamps in msec in the debug to measure the time from received the disconnect to "asserting DTR". Modem needs some time to do the cleanup work for the previous call before it can accept the new call.

/1 Mcom: in modem state 'Disconnecting'

/1 Mcom: DISCONNECT, duration = 00:00:51, reason (0xE) Remote Lin

DSR was dropped

****we got the disconnect from the other side

Modem: READY->(unknown)

OTO-5-UPDOWN: Line protocol on Interface Async98, changed state t

/1 Mcom: in modem state 'Idle'

dropping DTR, hanging up

Async Int reset: Dropping DTR

*****DTR dropped on line and it should be dropped for 5 secs before you see

restoring DTR

see "sh line x" at this time.

Now turn on msec in debug using following command

service timestamps debug datetime msec

service timestamps log datetime msec

110
Views
0
Helpful
3
Replies
CreatePlease login to create content