Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

one router running OSPF with dual links

Hello all,

I have the following scenario:

a. one router (6513) with two WAN cards (POS & ATM-DS-3).

2. This router belongs to area 0.

3. The POS link is connected to a remote 7206 router at central site.

4. The DS-3 wireless link goes to another 7204 router located at central site.

5. Both 7200's also are in area 0.

Now, I need to setup the DS-3 link as backup of the POS line. I've been trying to get this to work from yesterday but did not worked.

The test I did yesterday was to first, shut down interface pos3/0/0. To see if the DS-3 link came up. I configured the DS-3 as backup of the POS with a delay of 10 60. The Ds-3 stayed as down.

Then I took the fiber connectors out of the POS and the DS-3 came up, but not traffic was going to central site.

Any ideas on how to get this to work as required. Does anyone have some tips on configuration that must be done for this?

Thanks,

Carlos Roque

Office Of Management and Budget

Commonwealth Of Puerto Rico

Inter Agency Backbone Network Operation Center

croque@ogp.gobiernop.pr

7 REPLIES

Re: one router running OSPF with dual links

First things first,

Is the physical layer up via both the links ? Can you ping the neighbor (7200s) via either links).

If yes, has OSPF neighbor relationship formed via either links ? (show ip ospf neighbor)

To configure backup link via OSPF, do the following,

On the primary link configure a lower cost for OSPF, and on the secondary link (ds3) configure a higher cost.

Command to use is "ip ospf cost ".

Before doing the above, you need to remove the "backup" commands that you have configured on the primary link.

OSPF will select all routes coming from the 7200s, via the primary link, due to lower cost. Once the primary link goes down, it should revert to the DS3 link.

Also configure the same cost command at either ends of the link.

New Member

Re: one router running OSPF with dual links

Hello,

Yes both links are up when entering sh int command. I can ping the remote 7204 ds-3 interface from the 6513 and the same from the 7204 to the ds-3 link connected to the 6513. However I cannot ping the ds-3 interface while located on the router trough telnet. If I connect to the 7204 with telnet I can ping the remote end but not the local ds-3 interface. The same with the 6513.

When I check the ip ospf neigh status, I see the following on the 7204:

Neighbor ID Pri State Dead Time Address Interface

64.195.xxx.3 1 FULL/DR 00:00:37 64.195.xxx.3 GigabitEtherne

t0/0

On the 7206:

Neighbor ID Pri State Dead Time Address Interface

64.195.xxx.129 0 FULL/ - 00:00:32 64.195.xxx.66 POS2/0

64.195.xxx.4 1 FULL/BDR 00:00:33 64.189.xxx.4 GigabitEtherne

t0/1

And on the 6513:

Neighbor ID Pri State Dead Time Address Interface

64.195.xxx.3 1 FULL/ - 00:00:32 64.195.xxx.65 POS3/1/0

As shown above I do not see a neighbor link from the 7204 ---> 6513 over the ds-3 link.

The cost for the POS on the 6513 is

POS ----> 1

DS-3 ----> 2

It is the same on the 7206 and 7204. This is the deafult for OSPF, because I have not change that.

The routing table shows from the 7206 that to get to 64.195.xxx.70 it will go trough the POS link.

To get to 64.195.xxx.69 will go trough the 7204 giga interface which is 64.195.xxx.4.

I do not know for sure why the 6513 and 7204 have not created a neighbor relationship using the DS-3 link. any ideas?.

Thanks for your reply ....

Regards,

Carlos Roque

Gold

Re: one router running OSPF with dual links

If you're not getting an adjacency to form across the DS3, the routers aren't going to route across it. I'd start with a debug ip ospf adj to get a general idea of what's going on--why the two routers aren't forming an adjacency. It could be any number of things--mismatched MTU's, mismatched subnet addresses, mismatched network types, multicast not working, etc.

Russ.W

New Member

Re: one router running OSPF with dual links

Hello,

I checked both interface on each router and the ip address settings are correct. Also I checked the network statement under router ospf section and the network command has the netmask as 0.0.31.255 and not the exact netmask configured on each interface. This command is the same on each router 7204, 7206 an 6513.

Also what is the difference of having the default-information originate command on both 7200's and not using this option. I know this is to propagate a default gateway under OSPF. Can this affect the router selection when using backup interface option on the 6513?.

Carlos Roque

Gold

Re: one router running OSPF with dual links

Okay, so it sounds like OSPF is running on the interfaces, which is good. Again, though, we're probably going to need the output of show ip ospf adj to figure out what the problem is--why the two routers won't form an adjacency over this link.

Default information originate just originates a default route--you can use this if you need it, or not. This shouldn't impact anything we're seeing here.

Russ.W

Bronze

Re: one router running OSPF with dual links

First of all, is ospf active on the interfaces?

Check "show ip ospf interface" on the 6513 and the 7204.

Do you have a network statement under router ospf, for the subnet used on the DS3?

If that's not it, try debug ip ospf adj.

Anyway, when the neighbor relation problem is solved you will have to increase the cost of the DS3 link since the default of 2 will not be high enough: the routes from the 7204 via the 7206 to the 6513 will also have a cost of 2 (POS=1 + GigE=1).

hth

Herbert

New Member

Re: one router running OSPF with dual links

Both interfaces appear under the sh ip ospf interface command. The network statement have the 0.0.31.255 mask in all three routers. But I do not see a neighbor peering link between the 6513 and the 7204 on the Ds-3 link.

Any ideas?.

Also I found out that the ospf router-id was using the vlan interface on the 6513. And that interface was configured as a passive interface because there is not another router behind that segment. I changed the router-id to the ip address of the POS interface on the 6513 router.

Now I can see the route to 64.192.xxx.73 (7204 DS-3 interface) with a gateway pointing to the POS on the 7206 router.

Another thing I found out was that the 6513 router had the maximum-path 2 command under the router ospf section. I was testing this when I changed the cost of the Ds-3 link to 1 on both 7204 and 6513 routers.

I took that command out...

Carlos Roque

496
Views
0
Helpful
7
Replies
CreatePlease login to create content