Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSI CLNS router config for DCN network

Hi

I'm just starting a new project to build a new DCN network and require info on CLNS routing and Multi-Area OSI routing. I've some experience with CLNS routing in a single area, but not with multi area routing.

The plan at the moment is to us IS-IS for IP and CLNS.

  • Other Network Infrastructure Subjects
9 REPLIES
New Member

Re: OSI CLNS router config for DCN network

I am assuming you are talking about areas and not domains. When designing the network design your areas to communicate with Level 1 adjacencies and your inter area or domain connections as Level 2. Doing so you will create areas where all level 1 devices communicate with each other and the level 2 device router between level 1 areas creating an intradomain backbone. There is a whole lot more to it than just this and if you would like more info please ask.

M.

New Member

Re: OSI CLNS router config for DCN network

Hi

Thanks for your response.

I've been looking around on CCO and other web sites and have found that there is little info available on this subjet. If you have any good info, example config etc I would be greatful of your help.

The plan at the moment is this.

1. Core will be running IS-IS (Level 2), IP only, looking to tunnel OSI through the Core

2. Gateway Sites (Sites that connect to the optical/sdh devices) will be Level 1 devices for CLNS and IP. Optical devices are managed via OSI, SDH devices are managed via IP

3. Each gateway site will need to support multiple optical/SDH rings. Looking to terminate these as multiple Level 1 areas within a single router (Cisco 2621).

Sound ok!

New Member

Re: OSI CLNS router config for DCN network

Here is an example config. Using a router and a switch at the gateway sites. Create VLANs for each management connection and VLANs for each ADM or DWDM at the site. Connect them to the associated VLANs. ADM 1 in this example will be in VLAN 3 and ADM 2 will be in VLAN 4, add a VLAN for each additional ADM. At the core sites you could modify the serial configs for what ever type of interface you have at these sites. I have not used a 2621 for this purpose but I think it will work. You'll have to check that out. You may find two issues here.

1. In this example I have included a level 2 sub-int on the Fa0/0 for level 2 comms in between the gateway and the systems. You may need to remove that section if L1 is the only necessary level in side the site.

2. I have included tarp enable in each sub-int. You may find this is necessary as the ES does not support the creation of tid address translation tables. There can be some performance issues if you have tarp enabled thru out the network.

3. Question: What is the manufacture of the SDH systems? Just curious. Answer at your discretion.

Gateway config example NOTE: I did not pay any mind to the IP address, just popped some in there to fill in one. Additionally, this may have holes in it. Test first!

!

hostname Boston1

!

logging rate-limit console 10 except errors

enable password cisco

!

ip subnet-zero

!

no ip finger

!

clns routing

!

interface FastEthernet0/0

no ip address

no ip mroute-cache

duplex half

!

interface FastEthernet0/0.1

description IP management system primary

encapsulation isl 1

ip address 10.10.0.1 255.0.0.0

no ip redirects

no ip mroute-cache

standby 1 timers 5 15

standby 1 ip 10.10.0.2

!

interface FastEthernet0/0.2

description ip management system Secondary

encapsulation isl 2

ip address 10.10.0.3 255.0.0.0

no ip redirects

no ip mroute-cache

standby 2 timers 5 15

standby 2 ip 10.10.0.4

!

interface FastEthernet0/0.3

description OSI-only Optical System1

encapsulation isl 3

no ip redirects

clns router isis 10.10-Bos01-OS1

tarp enable

!

interface FastEthernet0/0.4

description OSI-only Optical System2

encapsulation isl 4

no ip redirects

clns router isis 10.10-Bos01-OS2

tarp enable

!

interface FastEthernet0/0.30

description OSI-level 2 routing

encapsulation isl 30

no ip redirects

clns router isis 10.10-Bos01

isis circuit-type level-2-only

!

interface Serial 1/0

description Connected to Hartford1

ip address 10.10.0.5 255.0.0.0

clns router isis 10.10-Bos01

isis circuit-type level-2-only

tarp enable

no shutdown

!

interface Serial 2/0

description connected to Providence1

ip address 10.10.2.5 255.0.0.0

clns router isis 10.10-Bos01

isis circuit-type level-2-only

tarp enable

no shutdown

!

router isis 10.10-Bos01

description NSAP to be inserted here with the MAC of the fa0/0.

net DFI.ORG.Reserved.RD.Area..00

!

router isis 10.10-Bos01-OS1

description NSAP of the 1st ADMs isis cmd RD and area need to match ADM in VLAN 3

net DFI.ORG.Reserved.RD.Area..00

is-type level-1

!

router isis 10.10-Bos01-OS2

description NSAP of the 2nd ADMs isis cmd RD and area need to match ADM in VLAN 4

net DFI.ORG.Reserved.RD.Area..00

is-type level-1

!

ip classless

!

tarp run

tarp tid Boston1

!

line con 0

exec-timeout 0 0

password cisco

login

transport input none

line aux 0

line vty 0 4

exec-timeout 0 0

password cisco

login

line vty 5 15

login

!

end

New Member

Re: OSI CLNS router config for DCN network

Hi

Thanks for the example config. Things are starting to full into place.

The manufacture of the SDH/DWDM kit is NEC. Are you aware of any issues?

New Member

Re: OSI CLNS router config for DCN network

The only issues that might arrise are the formats available for addressing. Confirm that the equipment can support the format of the NSAP format you wish to use in your network. Some will only support rigid formats whilst others will allow the fixed 20 byte, fixed 10 byte, or flexible format. Additionally, confirm that the SDH systems can be configured as IS-IS systems not not just ES-IS. This may affect your planning. For example if the node is ES-IS only and a client of your client contracts for management services of a remote ADM where they want to piggyback the other ADM off of an ADM connected to the DCN via the MS-RS DCC channel you may find they are not able to as the system will not be able to route the info from the remote ADM to the DCN.

New Member

Re: OSI CLNS router config for DCN network

Hi

Thanks for all your input.

I have another little problem ;-)

The plan is to run ISIS in the core. At The GW sites we will be redistributing the RIP learned routes from the NE's into ISIS. When we redistribute from RIP into ISIS we lose the RIP metric, the problem with this is, we wise to us the closest gateway router to the NE when connecting from the NMS.

The only work-around I came up with is to us a route-map and set the ISIS metric for each route that we redisbribute into ISIS.

Have you encounterd this problem?.

Is it our design that's causing this problem?

How would you do this?

thanks

New Member

Re: OSI CLNS router config for DCN network

Your planning sounds good. But be aware of the following aspect:

If you enable Integrated IS-IS on the gateway sites, you should not include the multiple level-1 areas. I believe that your optical/sdh equipment do not support Integrated IS-IS. If you are running Integrated IS-IS in this areas as well, your optical/sdh equipment will have IP-based TLVs in their level-1-database. Normaly a router should ignore unsupported or unknown TLVs (ISO 10589) - but in practice ...?

It might be helpful for me as well to know, if this theoretical aspect might become a problem. I have never tested this, but we want to implement the same design in our DCN.

New Member

Re: OSI CLNS router config for DCN network

Hi

The optical/sdh kit (NEC) is managaged by OSI or IP not both. i.e. the DWDM kit will be managed by OSI and the SDH layer is managed by IP.

The optical/sdh supports IS-IS Level 1 routing. I don't think the problem you raised will affect us. (I hope)

thanks

New Member

Re: OSI CLNS router config for DCN network

The sdh/optical IS don`t support the integrated IS-IS, when you try to configure IP and CLNS in the same LAN the sdh/optical change the adjacency from L1 to IS. The message that the router writes in the log (debug isis adjacency) is the following:

ISIS-Adj: Rec L1 IIH from 00a0.fa00.1018 (Ethernet0), cir type 1, cir id 00A0.FA00.1018.01

ISIS-Adj: No usable IP interface addresses in LAN IIH from Ethernet0

Thanks

913
Views
0
Helpful
9
Replies
This widget could not be displayed.