Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

OSPF / ABR not reachable

i am running in to bug, i think

i habe a hub&spoke NBMA network with 1 Hub and 3 Spokes

2 spokes receive all routes and work find but 1 router get LSA into Database but can't install those routes into the rouring table.

i debug ip ospf spf and the failure reason is always

OSPF: ABR not reachable 11.22.6.6

but i can ping this address!

wg1r1#clear ip osp p

Reset ALL OSPF processes? [no]: y

wg1r1#

00:08:15: %OSPF-5-ADJCHG: Process 1, Nbr 11.22.6.6 on Serial2/0 from FULL to DOWN, Neighbor Down: Interface down or detached

00:08:15: %OSPF-5-ADJCHG: Process 1, Nbr 192.1.1.8 on FastEthernet1/0 from FULL to DOWN, Neighbor Down: Interface down or detached

wg1r1#

00:08:20: OSPF: running SPF for area 1

00:08:20: OSPF: Initializing to run spf

00:08:20: It is a router LSA 11.22.1.1. Link Count 2

00:08:20: Processing link 0, id 192.168.1.0, link data 255.255.255.0, type 3

00:08:20: Add better path to LSA ID 192.168.1.255, gateway 192.168.1.0, dist 64

00:08:20: Add path: next-hop 192.168.1.1, interface Serial2/0

00:08:20: Processing link 1, id 11.22.1.1, link data 255.255.255.255, type 3

00:08:20: Add better path to LSA ID 11.22.1.1, gateway 11.22.1.1, dist 1

00:08:20: Add path: next-hop 11.22.1.1, interface Loopback0

00:08:20: OSPF: Adding Stub nets

00:08:20: OSPF: insert route list LS ID 11.22.1.1, type 0, adv rtr 11.22.1.1

00:08:20: OSPF: insert route list LS ID 192.168.1.255, type 0, adv rtr 11.22.1.1

00:08:20: OSPF: Entered old delete routine

00:08:20: OSPF: running SPF for area 2

00:08:20: OSPF: Initializing to run spf

00:08:20: It is a router LSA 11.22.1.1. Link Count 1

00:08:20: Processing link 0, id 192.1.1.0, link data 255.255.255.0, type 3

00:08:20: Add better path to LSA ID 192.1.1.255, gateway 192.1.1.0, dist 1

00:08:20: Add path: next-hop 192.1.1.1, interface FastEthernet1/0

00:08:20: OSPF: Adding Stub nets

00:08:20: OSPF: insert route list LS ID 192.1.1.255, type 0, adv rtr 11.22.1.1

00:08:20: OSPF: Entered old delete routine

00:08:20: OSPF: running spf for summaries area 0

00:08:20: OSPF: sum_delete_old_routes area 0

00:08:20: OSPF: running spf for summaries area 1

00:08:20: OSPF: sum_delete_old_routes area 1

00:08:20: OSPF: running spf for summaries area 2

00:08:20: OSPF: sum_delete_old_routes area 2

00:08:20: OSPF: Started Building Type 5 External Routes

00:08:20: OSPF: ex_delete_old_routes

00:08:20: OSPF: Started Building Type 7 External Routes

00:08:20: OSPF: ex_delete_old_routes

00:08:20: OSPF: Started Building Type 7 External Routes

00:08:20: OSPF: ex_delete_old_routes

00:08:20: OSPF: Started Building Type 7 External Routes

00:08:20: OSPF: ex_delete_old_routes

00:08:23: OSPF: Schedule partial SPF - type 5 id 192.168.1.10 adv rtr 192.168.1.6

00:08:23: OSPF: Schedule partial SPF - type 5 id 192.168.1.10 adv rtr 11.22.6.6

00:08:23: %OSPF-5-ADJCHG: Process 1, Nbr 192.1.1.8 on FastEthernet1/0 from LOADING to FULL, Loading Done

00:08:23: OSPF: Service partial SPF 0/2/0

00:08:23: OSPF: Start partial processing Type 5 External LSA 192.168.1.10, mask 255.255.255.255, adv 11.22.6.6, age 355, seq 0x80000024, metric 2000, metric-type 2

00:08:23: OSPF: Did not find route to ASBR 11.22.6.6

00:08:23: OSPF: Start partial processing Type 5 External LSA 192.168.1.10, mask 255.255.255.255, adv 192.168.1.6, age 1633, seq 0x80000001, metric 2000, metric-type 2

00:08:23: OSPF: Did not find route to ASBR 192.168.1.6

00:08:24: OSPF: Detect change in self LSA type 1, LSID 11.22.1.1, from 11.22.1.1 area 2

wg1r1#

00:08:26: OSPF: Do not schedule partial SPF - type 3 id 150.1.1.0 adv rtr 11.22.6.6, INTRA/INTER spf scheduled

00:08:26: OSPF: Do not schedule partial SPF - type 3 id 11.22.6.6 adv rtr 11.22.6.6, INTRA/INTER spf scheduled

00:08:26: OSPF: Do not schedule partial SPF - type 3 id 10.1.3.0 adv rtr 11.22.6.6, INTRA/INTER spf scheduled

wg1r1#

00:08:26: %OSPF-5-ADJCHG: Process 1, Nbr 11.22.6.6 on Serial2/0 from LOADING to FULL, Loading Done

00:08:28: OSPF: Detect change in LSA type 1, LSID 192.1.1.8, from 192.1.1.8 area 2

00:08:30: OSPF: running SPF for area 1

00:08:30: OSPF: Initializing to run spf

00:08:30: It is a router LSA 11.22.1.1. Link Count 2

00:08:30: Processing link 0, id 192.168.1.6, link data 192.168.1.1, type 2

00:08:30: Can not find next node 192.168.1.6 listed in LSA LSA type 1, LS ID 11.22.1.1

00:08:30: Processing link 1, id 11.22.1.1, link data 255.255.255.255, type 3

00:08:30: Add better path to LSA ID 11.22.1.1, gateway 11.22.1.1, dist 1

00:08:30: Add path: next-hop 11.22.1.1, interface Loopback0

00:08:30: OSPF: Adding Stub nets

00:08:30: OSPF: delete lsa id 11.22.1.1, type 0, adv rtr 11.22.1.1 from delete list

00:08:30: OSPF: insert route list LS ID 11.22.1.1, type 0, adv rtr 11.22.1.1

00:08:30: OSPF: Entered old delete routine

00:08:30: OSPF: No ndb for STUB NET old route 192.168.1.0, mask /24, next hop 192.168.1.1

00:08:30: OSPF: delete lsa id 192.168.1.255, type 0, adv rtr 11.22.1.1 from delete list

00:08:30: OSPF: running SPF for area 2

00:08:30: OSPF: Initializing to run spf

00:08:30: It is a router LSA 11.22.1.1. Link Count 1

00:08:30: Processing link 0, id 192.1.1.8, link data 192.1.1.1, type 2

00:08:30: Add better path to LSA ID 192.1.1.8, gateway 192.1.1.1, dist 1

00:08:30: Add path: next-hop 192.1.1.1, interface FastEthernet1/0

00:08:30: OSPF: insert route list LS ID 192.1.1.8, type 2, adv rtr 192.1.1.8

00:08:30: It is a network LSA 192.1.1.8. Router Count 2

00:08:30: Processing router id 192.1.1.8

00:08:30: Add better path to LSA ID 192.1.1.8, gateway 192.1.1.8, dist 1

00:08:30: Add path: next-hop 192.1.1.8, interface FastEthernet1/0

00:08:30: Processing router id 11.22.1.1

00:08:30: New newdist 1 olddist 0

00:08:30: It is a router LSA 192.1.1.8. Link Count 2

00:08:30: Processing link 0, id 11.22.8.8, link data 255.255.255.255, type 3

00:08:30: Add better path to LSA ID 11.22.8.8, gateway 11.22.8.8, dist 2

00:08:30: Add path: next-hop 192.1.1.8, interface FastEthernet1/0

00:08:30: Processing link 1, id 192.1.1.8, link data 192.1.1.8, type 2

00:08:30: Ignore newdist 11 olddist 1

00:08:30: OSPF: Adding Stub nets

00:08:30: OSPF: Add Network Route to 11.22.8.8 Mask /32. Metric: 2, Next Hop: 192.1.1.8

00:08:30: OSPF: insert route list LS ID 11.22.8.8, type 0, adv rtr 192.1.1.8

00:08:30: OSPF: Entered old delete routine

00:08:30: OSPF: No ndb for STUB NET old route 192.1.1.0, mask /24, next hop 192.1.1.1

00:08:30: OSPF: delete lsa id 192.1.1.255, type 0, adv rtr 11.22.1.1 from delete list

00:08:30: OSPF: running spf for summaries area 0

00:08:30: OSPF: sum_delete_old_routes area 0

00:08:30: OSPF: running spf for summaries area 1

00:08:30: OSPF: Start processing Summary LSA 10.1.3.0, mask 255.255.255.0, adv 11.22.6.6, age 365, seq 0x80000001 (Area 1)

00:08:30: OSPF: ABR not reachable 11.22.6.6

00:08:30: OSPF: Start processing Summary LSA 11.22.6.6, mask 255.255.255.255, adv 11.22.6.6, age 394, seq 0x80000001 (Area 1)

00:08:30: OSPF: ABR not reachable 11.22.6.6

00:08:30: OSPF: Start processing Summary LSA 150.1.1.0, mask 255.255.255.0, adv 11.22.6.6, age 394, seq 0x80000001 (Area 1)

00:08:30: OSPF: ABR not reachable 11.22.6.6

00:08:30: OSPF: sum_delete_old_routes area 1

00:08:30: OSPF: running spf for summaries area 2

00:08:30: OSPF: sum_delete_old_routes area 2

00:08:30: OSPF: Started Building Type 5 External Routes

00:08:30: OSPF: Start processing Type 5 External LSA 192.168.1.10, mask 255.255.255.255, adv 11.22.6.6, age 362, seq 0x80000024, metric 2000, metric-type 2

00:08:30: OSPF: Did not find route to ASBR 11.22.6.6

00:08:30: OSPF: Start processing Type 5 External LSA 192.168.1.10, mask 255.255.255.255, adv 192.168.1.6, age 1640, seq 0x80000001, metric 2000, metric-type 2

00:08:30: OSPF: Did not find route to ASBR 192.168.1.6

00:08:30: OSPF: ex_delete_old_routes

00:08:30: OSPF: Started Building Type 7 External Routes

00:08:30: OSPF: ex_delete_old_routes

00:08:30: OSPF: Started Building Type 7 External Routes

00:08:30: OSPF: ex_delete_old_routes

00:08:30: OSPF: Started Building Type 7 External Routes

00:08:30: OSPF: ex_delete_old_routes

wg1r1#

wg1r1#sh ip osp d

OSPF Router with ID (11.22.1.1) (Process ID 1)

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count

11.22.1.1 11.22.1.1 31 0x80000002 0x00ECAF 2

11.22.2.2 11.22.2.2 371 0x80000002 0x00DBBD 2

11.22.3.3 11.22.3.3 363 0x80000002 0x00FC94 2

11.22.6.6 11.22.6.6 363 0x80000004 0x00A6E2 2

Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

192.168.1.2 11.22.2.2 372 0x80000001 0x00E96C

192.168.1.3 11.22.3.3 364 0x80000001 0x00E56B

Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

10.1.3.0 11.22.6.6 393 0x80000001 0x000669

11.22.6.6 11.22.6.6 422 0x80000001 0x001AC7

150.1.1.0 11.22.6.6 422 0x80000001 0x00CE9E

Router Link States (Area 2)

Link ID ADV Router Age Seq# Checksum Link count

11.22.1.1 11.22.1.1 28 0x80000008 0x002532 1

192.1.1.8 192.1.1.8 36 0x80000118 0x00267E 2

Net Link States (Area 2)

Link ID ADV Router Age Seq# Checksum

192.1.1.8 192.1.1.8 37 0x80000003 0x00A80C

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag

192.168.1.10 11.22.6.6 391 0x80000024 0x00BC5B 0

192.168.1.10 192.168.1.6 1669 0x80000001 0x002EC9 0

wg1r1#

7 REPLIES
Gold

Re: OSPF / ABR not reachable

What we really need is a show ip ospf data for the specific received entries that won't install in the routing table. It'd be much easier to read than the output above, which isn't really telling us why the router thinks the LSA is unreachable. My suspicion is that you're running a mismatched DR/BDR on the multipoint link, or some sort of stub area that's blocking the type 4 generation or something along those lines. :-)

Russ.W

New Member

Re: OSPF / ABR not reachable

Hi

the routing table was empty, i can see only connected networks. In the meantime it works i reloaded all routers tree times.

Gold

Re: OSPF / ABR not reachable

Well, okay, but we needed to know what the OSPF database said about hte LSAs it had in the local database--why the routing bits weren't set, etc.

Russ.W

New Member

Re: OSPF / ABR not reachable

its really funny i just reload again and the problem appears again.

here's what you ask fo

wg1r3#sh ip osp da

OSPF Router with ID (11.22.3.3) (Process ID 1)

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count

11.22.3.3 11.22.3.3 114 0x80000031 0x00BCA2 2

172.16.1.1 172.16.1.1 129 0x80000027 0x0048F8 2

192.168.1.1 192.168.1.1 120 0x80000003 0x00AA64 2

192.168.1.6 192.168.1.6 134 0x80000003 0x0062CF 1

Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

192.168.1.1 192.168.1.1 135 0x80000001 0x00EE98

192.168.1.2 172.16.1.1 129 0x80000001 0x000DD2

Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

10.1.3.0 192.168.1.1 100 0x80000001 0x00D11F

10.1.3.0 192.168.1.6 152 0x80000001 0x0031FA

11.22.6.6 192.168.1.1 100 0x80000001 0x00E57D

11.22.6.6 192.168.1.6 180 0x80000001 0x004559

11.22.8.8 192.168.1.1 121 0x80000025 0x00FA7F

11.22.8.8 192.168.1.6 104 0x80000001 0x00A7B1

150.1.1.0 192.168.1.1 101 0x80000001 0x009A54

150.1.1.0 192.168.1.6 181 0x80000001 0x00F930

192.1.1.0 192.168.1.1 121 0x80000025 0x005198

192.1.1.0 192.168.1.6 104 0x80000001 0x00FDCA

Summary ASB Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

192.168.1.6 192.168.1.1 101 0x80000001 0x00EB34

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag

172.16.1.1 192.168.1.6 136 0x80000029 0x006421 0

192.168.1.10 192.168.1.6 149 0x80000026 0x00E3EE 0

wg1r3#

and here a show ip route

wg1r3#sh ip rou

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

11.0.0.0/24 is subnetted, 1 subnets

C 11.22.3.0 is directly connected, Loopback0

C 192.168.1.0/24 is directly connected, Serial0/0

wg1r3#

the config is pretty basic, everithing default without authentication. I see this problem only on NBMA.

when i start debug ospf spf i receive

00:07:11: OSPF: Did not find route to ASBR 192.168.1.6

or

00:07:11: OSPF: ABR not reachable 192.168.1.6

but look at this

wg1r3#ping 192.168.1.6

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms

wg1r3#

Gold

Re: OSPF / ABR not reachable

It looks like s0/0 is set up as a broadcast network, because 192.168.1.0/24 is included as a network link state in your database--is this correct? What's the config on that interface look like?

Most likely the problem is that you're running this as a broadcast network, and the DR is not the hub router. If you're running it as a broadcast link, then try setting each of the remote routers to OSPF priority 0 on their serial interface leading back to the hub router.

ip ospf priority 0

Under the interface. Leave the hub at its default--don't configure this command on the hub at all. In fact, I'm almost certain that's what the problem is, since the 192.168.1.0/24 network shows up twice in your database, with two different router ID's, which is an almost certain sign there are two DR's on that link.

Russ.W

New Member

Re: OSPF / ABR not reachable

its NBMA configured because enc. is frame-relay

here's the hub config

interface Serial0/0

no ip address

encapsulation frame-relay

no frame-relay inverse-arp

frame-relay lmi-type cisco

!

interface Serial0/0.1 multipoint

ip address 192.168.1.6 255.255.255.0

frame-relay map ip 192.168.1.1 601 broadcast

frame-relay map ip 192.168.1.2 602 broadcast

frame-relay map ip 192.168.1.3 603 broadcast

wg1r6#sh ip osp nei

Neighbor ID Pri State Dead Time Address Interface

11.22.5.5 1 FULL/ - 00:00:32 10.1.3.5 Tunnel0

192.168.1.3 0 FULL/DROTHER 00:01:37 192.168.1.3 Serial0/0.1

172.16.1.1 1 FULL/DROTHER 00:01:59 192.168.1.2 Serial0/0.1

192.168.1.1 100 FULL/DR 00:01:51 192.168.1.1 Serial0/0.1

wg1r6#

------------------------------------------------

here's the spoke config

interface Serial0/0

ip address 192.168.1.3 255.255.255.0

encapsulation frame-relay

frame-relay map ip 192.168.1.1 306 broadcast

frame-relay map ip 192.168.1.2 306 broadcast

frame-relay map ip 192.168.1.6 306 broadcast

no frame-relay inverse-arp

frame-relay lmi-type cisco

wg1r3#sh ip osp nei

Neighbor ID Pri State Dead Time Address Interface

192.168.1.6 255 FULL/DR 00:01:30 192.168.1.6 Serial0/0

wg1r3#

as you can see, i have two other spokes but the problem exist only on one of them.

Regarding 2x 192.168.1.0/24 in database, i run a virtual link on one of the other spokes which works perfect. I have checked the ospf DB on another spoke and it appears in the DB as well and this router works as fine.

Gold

Re: OSPF / ABR not reachable

OSPF thinks it's a broadcast interface, though. Again, try setting the ospf proirity on the spokes to 0. I have a good section in one of my networkers slides about this, but I'm not certain it's on the web anyplace you can actually get to.

Basic problem: DR mismatch.

Russ.W

778
Views
0
Helpful
7
Replies
CreatePlease to create content