Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

OSPF and Secondary Addresses

I have a 3550-EMI running OSFP.

Is there any way I can get the switch to advertise seconary addresses into OSPF. The secondary addresses are included in the OSFP network statement

3 REPLIES
Bronze

Re: OSPF and Secondary Addresses

Hi

For sure you can not establish a ospf adjaccency.

See:

http://www.cisco.com/warp/public/104/29.html#adj

What you can do is create a static route which points

to the null interface and redistribute the static route.

ip route x.x.x.x x.x.x.x null 0

router ospf 1

redistribute static subnets

Hope that helps

Roger

Bronze

Re: OSPF and Secondary Addresses

In my experience (I just looked at one of my old routers, not a 3550) OSPF will advertise secondary addresses AS LONG AS THE PRIMARY IS ADVERTISED. Check the network statement and make sure it is correct.

Gold

Re: OSPF and Secondary Addresses

This is correct--as long as the primary is covered by a network statement, the secondary will be advertised. On a router:

interface Ethernet1/2

ip address 144.1.1.1 255.255.255.0 secondary

ip address 208.0.6.4 255.255.255.0

ip directed-broadcast

no ip route-cache

no ip mroute-cache

duplex half

!

router ospf 100

log-adjacency-changes

network 144.1.1.0 0.0.0.255 area 0

network 208.0.6.0 0.0.0.255 area 0

....

7206F#sho ip ospf data router

OSPF Router with ID (208.0.10.4) (Process ID 100)

Router Link States (Area 0)

LS age: 75

Options: (No TOS-capability, DC)

LS Type: Router Links

Link State ID: 208.0.10.4

Advertising Router: 208.0.10.4

LS Seq Number: 80000002

Checksum: 0x27BD

Length: 48

AS Boundary Router

Number of Links: 2

Link connected to: a Stub Network

(Link ID) Network/subnet number: 208.0.6.0

(Link Data) Network Mask: 255.255.255.0

Number of TOS metrics: 0

TOS 0 Metrics: 10

Link connected to: a Stub Network

(Link ID) Network/subnet number: 144.1.1.0

(Link Data) Network Mask: 255.255.255.0

Number of TOS metrics: 0

TOS 0 Metrics: 10

It won't advertise the secondary without the primary listed in the network statement.

Russ.W

334
Views
0
Helpful
3
Replies
CreatePlease to create content