Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ospf and vrf route strange question?

a network like below:

(R1)--------(R2)

|

|

|

(R3)--------(R4)

r2 is vrf route

all the four routes are runing ospf.if all the routes are in the same area , it work well. If r1 and r2 and part of r3 are in same area , r3 and r4 in area 0 ,it also work well.

but if in below situation,

r1 and r3,r4 is ospf area 0

r1 and r2 is ospf area 1

when you run "show ip route " on r2, there is not any route appeared . also " show ip ospf database " on r2 you can see all the route from other route , it just not put them into route table.

Why?

thanks

4 REPLIES
Gold

Re: ospf and vrf route strange question?

Not enough information, I'm afraid....

Any chance you can actually post the ospf configurations and output of show ip ospf data for the four routers? I would actually want to see show ip ospf data router on R1, if possible.

Russ.W

New Member

Re: ospf and vrf route strange question?

output of r1 shows that area 1 is a stub area.why?

I don't configure area 1 as a stub area.

sh run

Building configuration...

Current configuration : 2042 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname r1

!

logging queue-limit 100

!

ip subnet-zero

!

!

no ip domain lookup

!

mpls ldp logging neighbor-changes

frame-relay switching

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

!

!

!

!

!

interface Ethernet1/0

ip address 30.1.1.1 255.255.255.0

half-duplex

!

interface TokenRing1/0

no ip address

shutdown

ring-speed 16

!

interface Serial4/0

no ip address

shutdown

!

interface Serial4/1

no ip address

shutdown

!

interface Serial4/2

ip address 10.1.1.1 255.255.255.0

clockrate 64000

!

router ospf 9

log-adjacency-changes

network 10.1.1.0 0.0.0.255 area 1

network 30.1.1.0 0.0.0.255 area 0

!

ip http server

ip classless

!

!

!

!

!

!

call rsvp-sync

!

voice-port 2/0/0

!

voice-port 2/0/1

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

length 0

line aux 0

line vty 0 4

login

!

!

end

r1#sh ip ospf data

OSPF Router with ID (30.1.1.1) (Process ID 9)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count

30.1.1.1 30.1.1.1 1455 0x80000004 0x00336C 1

30.1.1.3 30.1.1.3 398 0x80000004 0x0018D7 2

192.168.0.104 192.168.0.104 398 0x80000003 0x00737E 1

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum

30.1.1.3 30.1.1.3 1456 0x80000001 0x002788

40.1.1.4 192.168.0.104 398 0x80000001 0x000540

Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum

10.1.1.0 30.1.1.1 1489 0x80000002 0x006797

20.2.2.0 30.1.1.1 1489 0x80000002 0x0032B6

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count

20.2.2.2 20.2.2.2 1686 0x80000003 0x0044BB 3

30.1.1.1 30.1.1.1 1489 0x80000005 0x00A5E4 2

Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

30.1.1.0 30.1.1.1 1446 0x80000004 0x0025C9

40.1.1.0 30.1.1.1 388 0x80000003 0x00277E

r1#sh ip rout

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 1 subnets

O 20.2.2.0 [110/791] via 10.1.1.2, 00:24:52, Serial4/2

40.0.0.0/24 is subnetted, 1 subnets

O 40.1.1.0 [110/74] via 30.1.1.3, 00:06:27, Ethernet1/0

10.0.0.0/24 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Serial4/2

30.0.0.0/24 is subnetted, 1 subnets

C 30.1.1.0 is directly connected, Ethernet1/0

r1#

r1#sh ip ospf data router 20.2.2.2

OSPF Router with ID (30.1.1.1) (Process ID 9)

Router Link States (Area 1)

Routing Bit Set on this LSA

LS age: 1838

Options: (No TOS-capability, DC)

LS Type: Router Links

Link State ID: 20.2.2.2

Advertising Router: 20.2.2.2

LS Seq Number: 80000003

Checksum: 0x44BB

Length: 60

Area Border Router

Number of Links: 3

Link connected to: a Stub Network

(Link ID) Network/subnet number: 20.2.2.0

(Link Data) Network Mask: 255.255.255.0

Number of TOS metrics: 0

TOS 0 Metrics: 10

Link connected to: another Router (point-to-point)

(Link ID) Neighboring Router ID: 30.1.1.1

(Link Data) Router Interface address: 10.1.1.2

Number of TOS metrics: 0

TOS 0 Metrics: 64

Link connected to: a Stub Network

(Link ID) Network/subnet number: 10.1.1.0

(Link Data) Network Mask: 255.255.255.0

Number of TOS metrics: 0

TOS 0 Metrics: 64

sh run

Building configuration...

Current configuration : 1435 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname "r2"

!

!

ip subnet-zero

ip cef

no ip domain-lookup

!

!

ip vrf v2

rd 2:2

route-target export 2:2

route-target import 2:2

!

!

!

!

interface Ethernet0

ip vrf forwarding v2

ip address 20.2.2.2 255.255.255.0

media-type 10BaseT

!

interface Ethernet1

no ip address

shutdown

media-type 10BaseT

!

interface Serial0

ip vrf forwarding v2

ip address 10.1.1.2 255.255.255.0

!

interface Serial1

no ip address

shutdown

!

interface Serial2

no ip address

shutdown

!

interface Serial3

no ip address

shutdown

!

interface BRI0

description 62359151

no ip address

encapsulation hdlc

shutdown

!

interface BRI1

no ip address

encapsulation hdlc

shutdown

!

interface BRI2

no ip address

encapsulation hdlc

shutdown

!

interface BRI3

no ip address

encapsulation hdlc

shutdown

!

interface BRI4

no ip address

encapsulation hdlc

shutdown

!

interface BRI5

no ip address

encapsulation hdlc

shutdown

!

interface BRI6

no ip address

encapsulation hdlc

shutdown

!

interface BRI7

no ip address

encapsulation hdlc

shutdown

!

router ospf 2 vrf v2

log-adjacency-changes

network 10.1.1.0 0.0.0.255 area 1

network 20.2.2.0 0.0.0.255 area 1

!

ip classless

no ip http server

ip pim bidir-enable

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

length 0

line aux 0

line vty 0 4

login

!

end

r2#sh ip ospf data

OSPF Router with ID (20.2.2.2) (Process ID 2)

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count

20.2.2.2 20.2.2.2 1760 0x80000003 0x0044BB 3

30.1.1.1 30.1.1.1 1563 0x80000005 0x00A5E4 2

Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

30.1.1.0 30.1.1.1 1520 0x80000004 0x0025C9

40.1.1.0 30.1.1.1 461 0x80000003 0x00277E

r2#sh ip route vrf v2

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 1 subnets

C 20.2.2.0 is directly connected, Ethernet0

10.0.0.0/24 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Serial0

r2#

New Member

Re: ospf and vrf route strange question?

somebody can help me

Cisco Employee

Re: ospf and vrf route strange question?

The PE will ignored the IA routes unless the PE-CE link is in area 0. So if you were to configure the link between R1 and R2 to be in area 0 and all the other links in area 1, you would see IA routes on R2.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
98
Views
0
Helpful
4
Replies