Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

OSPF Assistance

I am relativley new to OSPF and I have a question regarding Route propegation. If I have the following entry:

router ospf 1

redistribute connected subnets

redistribute static subnets

passive-interface FastEthernet1

network 10.0.250.1 0.0.0.0 area 0.0.0.0

network 192.168.1.100 0.0.0.0 area 0.0.0.0

Is the mask 0.0.0.0 an exact match on the ip address allowing propegation of only that specific ip address? This is what I have read about it's use: "to put an interface in a certain area if you are having problems figuring out a mask" Does this then look for the interface defined in the config? For instance, if the network specified above was defined as:

interface Port-channel1.2

description Waltham Legacy Flat VLAN

encapsulation dot1Q

ip address 192.168.1.100 255.255.255.0

no ip redirects

no ip directed-broadcast

would it basically distribute the route for the network 192.168.1.x/24?

Also, if I wanted to specify the network 192.168.2.0/24 for OSPF route distribution using the correct mask, would the syntax be defined as "network 192.168.2.1 255.255.255.0 area 0.0.0.0?

Thanks in advance,

DF

2 REPLIES
New Member

Re: OSPF Assistance

hi,

yes the mask 0.0.0.0 is a exact match.and what the statement "network 10.0.250.1 0.0.0.0 area 0.0.0.0"

do is that it will trace all the defined interface ip address and will put only the interface having address 10.0.250.1 in area 0.

your question about redistributing 192.168.1.x/24 i didnt exactly understand it,but the network statement does is that it will let those interfaces to participate in ospf.To add all the 192.168.1.x/24

you need

network 192.168.1.1 0.0.0.255 area 0

Best regards,

ahmad.bilal@pakistan.ncr.com

New Member

Re: OSPF Assistance

Yes he is corect but to claify the mask is a wildcard mask (oppisite of subnet mask).

same usage as access lists.

100
Views
0
Helpful
2
Replies
CreatePlease to create content