Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Ospf ...Geting stuck in INIT state .

I m configureing ospf on two router which are directly connected on ethernet segment.

but not creating neighbour relationship

geting following output

P5#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

3.3.3.3 1 INIT/DROTHER 00:00:31 50.50.50.1 FastEthernet0/

0

7.7.7.7 1 FULL/DR 00:00:30 40.40.40.2 FastEthernet0/

1

it geting stuck in INIT state.What will be the problem ?

7 REPLIES

Re: Ospf ...Geting stuck in INIT state .

Hi Ganpat,

Could you please provide the running configurations of both the routers.

New Member

Re: Ospf ...Geting stuck in INIT state .

Thanks .royalblues

Pls see running Config of both router.

P3 (e0/1)is connected to P5(fa0/0)

PE3# sh running-config

Building configuration...

Current configuration : 1646 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname PE3

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

!

!

no ip ips deny-action ips-interface

!

mpls label protocol ldp

mpls traffic-eng tunnels

no ftp-server write-enable

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

no crypto isakmp ccm

!

!

!

!

interface Loopback0

ip address 3.3.x.x.255.255.255

!

interface FastEthernet0/0

ip address 172.20.13.2 255.255.255.252

duplex auto

speed auto

mpls traffic-eng tunnels

tag-switching ip

!

interface Serial0/0

ip address 10.10.10.1 255.255.255.252

mpls traffic-eng tunnels

tag-switching ip

no fair-queue

!

interface FastEthernet0/1

ip address 50.50.x.x.255.255.252

duplex auto

speed auto

mpls label protocol ldp

mpls traffic-eng tunnels

tag-switching ip

!

interface Ethernet1/0

ip address 30.30.x.x.255.255.252

half-duplex

mpls label protocol ldp

mpls traffic-eng tunnels

tag-switching ip

!

router ospf 1

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

log-adjacency-changes

network 3.3.3.3 0.0.0.0 area 0

network 10.10.10.0 0.0.0.255 area 0

network 30.30.30.0 0.0.0.255 area 0

network 50.50.50.0 0.0.0.255 area 0

network 172.20.13.0 0.0.0.255 area 0

!

router bgp 100

no synchronization

bgp log-neighbor-changes

no auto-summary

!

ip http server

no ip http secure-server

ip classless

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

!

end

=================

P5#sh running-config

Building configuration...

Current configuration : 1067 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname P5

!

boot-start-marker

boot-end-marker

!

enable secret xxx.

!

no aaa new-model

!

resource policy

!

memory-size iomem 25

ip subnet-zero

!

!

ip cef

!

!

!

mpls label protocol ldp

mpls traffic-eng tunnels

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 5.5.x.x.255.255.255

!

interface FastEthernet0/0

ip address 50.50.x.x.255.255.252

duplex auto

speed auto

mpls label protocol ldp

mpls ip

mpls traffic-eng tunnels

!

interface FastEthernet0/1

ip address 40.40.x.x.255.255.252

duplex auto

speed auto

mpls label protocol ldp

mpls traffic-eng tunnels

!

router ospf 1

log-adjacency-changes

network 5.5.5.5 0.0.0.0 area 0

network 40.40.40.0 0.0.0.255 area 0

network 50.50.50.0 0.0.0.255 area 0

!

ip http server

no ip http secure-server

ip classless

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

!

end

Purple

Re: Ospf ...Geting stuck in INIT state .

Hi,

2 things:

- what is the output of 'sh ip ospf neighbor' on P3

- can you ping the 50.50.50.x addresses from either end ?

Paresh

Re: Ospf ...Geting stuck in INIT state .

Can you check by having the same configuration on

both the ethernet interfaces connected to each other.

Narayan

New Member

Re: Ospf ...Geting stuck in INIT state .

Thanks Narayan and paresh.

Actually i m able to ping from PE3 to PE5 but not form PE5 to PE3.and regarding configuration ,is same on both side's.

Purple

Re: Ospf ...Geting stuck in INIT state .

You may have to debug ospf , that will usually give you an idea why it is not coming up . Check that the MTU size is the same on both interfaces.

New Member

Hi , OSPF can be stuck in

Hi ,

 

OSPF can be stuck in INIT due to the mismatch in hello packet parameters such as

 

1. Hello/dead intervals

2. Authentication

3. Stubflag

4. Interface subnet mask

5. Area ID

 

MTU will come into picture when the exstart state get active (if there is an MTU mismatch it will not get into EXSTART).

 

17958
Views
0
Helpful
7
Replies
CreatePlease login to create content