Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ospf problem !?!

hi,

we have an 3640 connected over 2xFrameRelayMultipoint and 2xFrameRelayPoint_Point.

The P-P links have a much greater cost than the MultipointInterfaces - but the router always gets the defaultrouter over the Point_point Interfaces -

Any Idea ???

WHY ??

interface Serial0/0

description BR-GRZTR1: FrameRelay to GRZ (Se0/0)

bandwidth 4900

no ip address

encapsulation frame-relay

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

load-interval 30

keepalive 5

serial restart-delay 0

frame-relay traffic-shaping

frame-relay lmi-type q933a

!

interface Serial0/0.1 multipoint

description BR-GRZTR1: FR to GRZRBGO1 (Se0/0.1) - PROD

bandwidth 512

ip address 172.16.33.22 255.255.255.252

no ip route-cache same-interface

ip ospf network point-to-multipoint

frame-relay class 1024k

frame-relay interface-dlci 199

!

interface Serial0/0.2 multipoint

description BR-GRZTR1: FR to GRZRBGO2 (Se0/0.2) - BACKUP

bandwidth 512

ip address 172.16.33.122 255.255.255.252

no ip route-cache same-interface

ip ospf network point-to-multipoint

ip ospf cost 1000

frame-relay class 1024k

frame-relay interface-dlci 599

!

interface Serial0/0.299 point-to-point

description BR-GRZTR1: to MPLSRBGOPE01 (Se0/0.299) - PROD

bandwidth 512

ip address 172.16.25.30 255.255.255.252

ip ospf message-digest-key 1 md5 7 011C15145D5F140D26

ip ospf cost 1500

tag-switching mtu 1512

tag-switching ip

frame-relay class mpls_1024k

frame-relay interface-dlci 299

!

interface Serial0/0.699 point-to-point

description BR-GRZTR1: to MPLSRBGOPE02 (Se0/0.699) - BACKUP

bandwidth 512

ip address 172.16.25.130 255.255.255.252

ip ospf message-digest-key 1 md5 7 011C15145D5F140D26

ip ospf cost 2000

tag-switching mtu 1512

tag-switching ip

frame-relay class mpls_1024k

frame-relay interface-dlci 699

!

7 REPLIES
Silver

Re: ospf problem !?!

There is no 'ip ospf cost ' statement on interface interface Serial0/0.1 multipoint , without this statement OSPF uses the bandwidth statement , since the bandwidth on this interface is 512 K the cost associated with this would be approx 90 .

Another thing you may want to check is are there OSPF neibors on the all the links , and the cost is used for outbound traffic , you may want to check the cost on the side that you are receiving the default router from .

New Member

Re: ospf problem !?!

hi,

you are right - so the router should get the defaultroute over s0/0.1 because it has approx cost=90 and all other have a higher cost.

BUT:

it receives the defaultroute over s0/0.299 - and that is my problem !

(could it be that a router sees a P-P interface better than a multipoint ??)

Silver

Re: ospf problem !?!

How is the default route being propagated ? redistribution ?

could you paste in a 'sh ip o dat external 0.0.0.0 '

New Member

Re: ospf problem !?!

hi,

thanks for answer - we do a "default-information originate always metric-type 1"

the problem is that i have "shut" the int 0/0.299 and 0/0.699 because we have problems - it´s a productionenviroment.

so i can paste a "sh ip os ....." without 0/0.299 and 0/0.699:

br-grztr1#sh ip ospf data ext 0.0.0.0

OSPF Router with ID (172.16.24.9) (Process ID 65052)

OSPF Router with ID (10.22.208.254) (Process ID 100)

Type-5 AS External Link States

Routing Bit Set on this LSA

LS age: 537

Options: (No TOS-capability, DC)

LS Type: AS External Link

Link State ID: 0.0.0.0 (External Network Number )

Advertising Router: grzrbgo2.rbgooe.at

LS Seq Number: 80008F49

Checksum: 0x10E1

Length: 36

Network Mask: /0

Metric Type: 1 (Comparable directly to link state metric)

TOS: 0

Metric: 1

Forward Address: 0.0.0.0

External Route Tag: 100

Routing Bit Set on this LSA

LS age: 1095

Options: (No TOS-capability, DC)

LS Type: AS External Link

Link State ID: 0.0.0.0 (External Network Number )

Advertising Router: grzrbgo1.rbgooe.at

LS Seq Number: 8000A1EB

Checksum: 0x46E9

Length: 36

Network Mask: /0

Metric Type: 1 (Comparable directly to link state metric)

TOS: 0

Metric: 1

Forward Address: 0.0.0.0

External Route Tag: 100

br-grztr1#

but i even have problems to interpret this:

why is the metric=1 over both advertising router ?

on rbgo1-router it should be approx=90 and over rbgo2 it should be 1000

(thats the interface-cost)

Silver

Re: ospf problem !?!

are you sure you have ospf neighbors across Serial0/0.2 & Serial0/0.1 ?

do you have access to the routers on both sides of PVC ?

did you look for mismatched ospf network types this would result in mismatched timers , this would not allow the neighbors to become adjacent.

New Member

Re: ospf problem !?!

hi,

a.) yes - i have ospf neigbors on all 4 int.

b.) yes - i have access on all routers

c.) the networktype ons0/0.1 and 0/0.2 is multipoint on all sides and the

networktype on s0/0.299 and 0/0.699 is point-point on all sides.

one thing to mention:

i have 2 different ospf-processes running on the router which has the "wrong"

defaultroute.

we migrating to mpls, so this distributionsrouter has two links (s0/0.1 and s0/0.2) to the "old" world with ospf process 100 and 2 links (s0/0.299 and 699) to the new mpls core-routers with process-id 65052.

so the distributionsrouter gets the defaultroute over 2 different ospf-processes.

it should install the defaultroute from the "old" routers.

today i have changed the networktype from s0/0.1 and 0/0.2 to point-point.

we will try in 4 hours - perhaps the different networktype between the old and the new world is the issue.

do you know on what parameter a router installs the route in the routingtable if it gets a route over 2 different ospf-processes?

(as you saw we configured different ospf cost - is this enough ?)

Silver

Re: ospf problem !?!

Ok I think I see the problem

Your default has a tag of 100, the interface s0/0.1 , is in AS 65052 , in order for you to default all your traffic you this interface a router upstream in this

AS will have to generate a default, currently the default is being propagated in AS 100.

96
Views
3
Helpful
7
Replies
CreatePlease to create content