Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF Problem

Hi all

iam using test setup metro Ethernet Ring

using my cisco routers for testing for proof testing

my setup looks like below

Rt1---rt2----rt3---rt4--Rt1

above sai routers all connected to Ring

using their Etherent devices using cross cable

and each Router i have connected One PC

to one of the Ethernet

iam using OSPF to take routing decission shortest path for the other PC communication

i have problem here is

i can reach adjacent routers PC

but iam not able to reach other side of the PC

example

rt1 (PC) can reach rt1 PC and RT3 PC

but not able to reach RT4 PC

all loopbacks in one range

192.168.200.0 area 1

local networks configured area 0

can you some tell me why iam not able to reach other side of the routers..

thanks

ram

18 REPLIES

Re: OSPF Problem

Hi

would be better to post out the configs as well as the show ip route incorporated in that..

that will be useful to troubleshoot this issue..

regds

New Member

Re: OSPF Problem

Hi

here is my config goes for the test setup

RT1

interface Loopback0

ip address 192.168.200.1 255.255.255.0

no ip directed broadcast

interface eth 0/0

ip address 192.168.100.13 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.1 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.1.1 255.255.255.252

no shutdown

interface eth 0/3

ip address 192.168.5.1 255.255.255.252

no shutdown

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

RT2

interface Loopback0

ip address 192.168.200.2 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.4.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.100.12 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.10 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.4.1 255.255.255.252

no shutdown

RT3

interface Loopback0

ip address 192.168.200.3 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.2.1 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.2 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.100.5 255.255.255.252

no shutdown

RT4

interface Loopback0

ip address 192.168.200.4 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.100.6 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.9 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.3.1 255.255.255.252

no shutdown

New Member

Re: OSPF Problem

Hi

here is my config goes for the test setup

RT1

interface Loopback0

ip address 192.168.200.1 255.255.255.0

no ip directed broadcast

interface eth 0/0

ip address 192.168.100.13 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.1 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.1.1 255.255.255.252

no shutdown

interface eth 0/3

ip address 192.168.5.1 255.255.255.252

no shutdown

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

RT2

interface Loopback0

ip address 192.168.200.2 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.4.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.100.12 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.10 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.4.1 255.255.255.252

no shutdown

RT3

interface Loopback0

ip address 192.168.200.3 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.2.1 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.2 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.100.5 255.255.255.252

no shutdown

RT4

interface Loopback0

ip address 192.168.200.4 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.100.6 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.9 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.3.1 255.255.255.252

no shutdown

New Member

Re: OSPF Problem

Hi

here is my config goes for the test setup

RT1

interface Loopback0

ip address 192.168.200.1 255.255.255.0

no ip directed broadcast

interface eth 0/0

ip address 192.168.100.13 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.1 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.1.1 255.255.255.252

no shutdown

interface eth 0/3

ip address 192.168.5.1 255.255.255.252

no shutdown

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

RT2

interface Loopback0

ip address 192.168.200.2 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.4.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.100.12 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.10 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.4.1 255.255.255.252

no shutdown

RT3

interface Loopback0

ip address 192.168.200.3 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.2.1 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.2 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.100.5 255.255.255.252

no shutdown

RT4

interface Loopback0

ip address 192.168.200.4 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.100.6 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.9 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.3.1 255.255.255.252

no shutdown

New Member

Re: OSPF Problem

Hi

here is my config goes for the test setup

RT1

interface Loopback0

ip address 192.168.200.1 255.255.255.0

no ip directed broadcast

interface eth 0/0

ip address 192.168.100.13 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.1 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.1.1 255.255.255.252

no shutdown

interface eth 0/3

ip address 192.168.5.1 255.255.255.252

no shutdown

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

RT2

interface Loopback0

ip address 192.168.200.2 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.4.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.100.12 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.10 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.4.1 255.255.255.252

no shutdown

RT3

interface Loopback0

ip address 192.168.200.3 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.2.1 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.2 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.100.5 255.255.255.252

no shutdown

RT4

interface Loopback0

ip address 192.168.200.4 255.255.255.0

no ip directed broadcast

router ospf 0

network 192.168.200.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 0

interface eth 0/0

ip address 192.168.100.6 255.255.255.252

no shutdown

interface eth 0/1

ip address 192.168.100.9 255.255.255.252

no shutdown

interface eth 0/2

ip address 192.168.3.1 255.255.255.252

no shutdown

Re: OSPF Problem

Hi

i would like to suggest few changes related to your ospf config.

1.Change the network type under the ethernet interface connected back to back between the routers to point to point.

2.Instead of advertising the whole /24 in the network statements would suggest to advertise the particular subnet alone.

do refer this sample config of your RT1

interface Loopback0

ip address 192.168.200.1 255.255.255.0

no ip directed broadcast

interface eth 0/0

ip address 192.168.100.13 255.255.255.252

ip ospf network point-to-point

no shutdown

interface eth 0/1

ip address 192.168.100.1 255.255.255.252

ip ospf network point-to-point

no shutdown

interface eth 0/2

ip address 192.168.1.1 255.255.255.252

ip ospf network point-to-point

no shutdown

interface eth 0/3

ip address 192.168.5.1 255.255.255.252

ip ospf network point-to-point

no shutdown

router ospf 0

network 192.168.200.1 0.0.0.0 area 1

network 192.168.100.0 0.0.0.3 area 0

network 192.168.1.0 0.0.0.3 area 0

network 192.168.5.0 0.0.0.3 area 0

regds

Re: OSPF Problem

Hi

i would like to suggest few changes related to your ospf config.

1.Change the network type under the ethernet interface connected back to back between the routers to point to point.

2.Instead of advertising the whole /24 in the network statements would suggest to advertise the particular subnet alone.

do refer this sample config of your RT1

interface Loopback0

ip address 192.168.200.1 255.255.255.0

no ip directed broadcast

interface eth 0/0

ip address 192.168.100.13 255.255.255.252

ip ospf network point-to-point

no shutdown

interface eth 0/1

ip address 192.168.100.1 255.255.255.252

ip ospf network point-to-point

no shutdown

interface eth 0/2

ip address 192.168.1.1 255.255.255.252

ip ospf network point-to-point

no shutdown

interface eth 0/3

ip address 192.168.5.1 255.255.255.252

ip ospf network point-to-point

no shutdown

router ospf 0

network 192.168.200.1 0.0.0.0 area 1

network 192.168.100.0 0.0.0.3 area 0

network 192.168.1.0 0.0.0.3 area 0

network 192.168.5.0 0.0.0.3 area 0

regds

Note : do repeat the samekinda configs in all ur routers also the network 192.168.5.0 0.0.0.3 area 0 statement wasnt their in ur post may be thts the reason for the conenctivity issue..

New Member

Re: OSPF Problem

Hi Prem

I just configured this 192.168.5.1

so i can connect some PC Later testing of OSPF in ring

why do i need to anounce local networks

iam already anoucing local area right

so it should automatically refelect with adjacents

ram

Re: OSPF Problem

Hi

Sorry about the loopback announcement you need to make it as /32 instead of having them as whole /24s.

and can accordingly use the network statement for that block.

Also you have configured /30s on ur interfaces and announcing whole /24s in the ospf process.its gernal and normally recommended to announce the subnets whatever is being used or configured in ur boxes.

regds

New Member

Re: OSPF Problem

1. Fix wildcard masks.

2. Advertise Local Networks (How else are the other routers going to know about the local networks?

New Member

Re: OSPF Problem

Hi

which Wild mask

Loopback, what should be the wildmask

/32 or /30

ya iam doing local anouncements only

that is /24 network, where i connected to My LAN Pc

how about wan connected to each other with /32

i should anounce them both the routers

or any one of the side enough

ram

New Member

Re: OSPF Problem

I think you shouldnt use 5 routers, because it adds more work but you dont learn anything extra. Use 5 routers later when you configure multi area ospf.

If you just want some basic ring, you just need 3.

Here is a basic two router config, you can modify to fit 3 routers, i have left out the obvious commands, like interface commands.

Router 1 - WAN

ip address 192.168.0.1 255.255.255.252

Router 1 - LAN

ip address 192.168.1.0 255.255.255.0

Router 1 - OSPF config

router ospf 1

network 192.168.0.0 0.0.0.3 area 0

network 192.168.1.0 0.0.0.255 area 0

Router 2 - WAN ( connects to R1 )

ip address 192.168.0.2 255.255.255.252

Router 2 - LAN

ip address 192.168.2.0 255.255.255.0

Router 2 - OSPF config

router ospf 1

network 192.168.0.0 0.0.0.3 area 0

network 192.168.2.0 0.0.0.255 area 0

If you wish to connect R3, you would add teh following to antoher interface.

ip address 192.168.0.5 255.255.255.252

and

network 192.168.0.4 0.0.0.3 area 0

Just remember, you need to use the Network command to advertise everything that is connected to the local router, whether it is LAN or WAN and it will all work.

New Member

Re: OSPF Problem

Hi

thanks for the suggestion

foir 3 routers its working fine

since all the routers are adjacent

iam looking more than adjacents

so its not working

iam talking about the routes are not getting reflected

when the router is not in adjacent

can you suggest me how can u do this

and make the update routes

if u can send me the config

ram

Re: OSPF Problem

Hi ram

would suggest to go thru this link to get the things in place and start ur configs afresh..

http://cisco.com/en/US/tech/tk365/tk480/tsd_technology_support_sub-protocol_home.html

regds

New Member

Re: OSPF Problem

Hi

iam using that link only to configure

then only iam posting here for the help

i could not able to get the updates..

so iam refering here to correct my config

and get the results success

ram

Re: OSPF Problem

Hi ram

As pointed out in my earlier mail and also pointed out by other poster do configure the loopback interface in /32.

the main point in doing this is the router will take this as the router id while establshing the neighborship with other routers.

and again its the best/general practice to go with a loopback interface esp if ur running any routing protocol so that u dont face any undesired result like duplicate router id etc.,.

configure your ethernet interface as /30 since you are going in a point to point kinda connectivity.

also key in the network type as point to point so that it shuldnt get onto DR/BDR election which it does by default on a ethernet interface.

this is required on the ethernet interfaces which inturn connects to other router ethernet interface.

in ur local lan since ur going for a single pc connectivity u can configure a /30 ip under that ethernet interface and no need for point to point there in those interfaces which connects to ur PC.

if u r having a large network behind that ethernet u can configure up a /24 subnet over there..

now comes ur ospf config place all the ip subnets which are there in the router.

i would suggest to have the interconnect interface ips in area 0 and also the loopback ip in area 0

configure your local lan in area1 or may be you can try it in area 0 itself..

using this setup u can try out for stub are configs,TSSA configs also u can try out for virtual link..

regds

New Member

Re: OSPF Problem

Hi

thanks for the quick reply

can you clarify that.. you want me to establish a

Virtual link config, when the router is not connected directly ??

is that correct ??

ram

Re: OSPF Problem

Hi ram

i was just mentioning the different scenarios which you can try up there with ur boxes that it..

like if u got a router which is not directly connected to area 0 like u can place that in different area altogether and try the virtual link configss..

regds

179
Views
0
Helpful
18
Replies
CreatePlease login to create content