cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
366
Views
0
Helpful
9
Replies

OSPF Redistribution Issue

abbas.ali
Level 1
Level 1

I have this issue:

R2: running area 0 and 3 (ABR)

R1: running area 3 only (Internal router) and also is ASBR

I created a loopback interface on R1 assign ip address 150.50.200.1 and then

advertise this network in RIP. I then redistributed RIP into OSPF, hoping that I would see this route on my R2.

Area 3: 150.50.17.0/24

RIP is on 150.50.200.0/24

Redistribution commands.

rotuer ospf 1

redistribute RIP subnets metric-type I metric 20.

I don't know what I am doing wrong, but R2 is not seeing this route as an E2.

Thanks,

9 Replies 9

rwiesmann
Level 4
Level 4

hi

You could try to do the following:

router ospf 1

redistribute connected subnets route-map "loopback"

!

route-map "loopback" permit 10

match ip address 50

!

access-list 10 permit 150.50.200.0 0.0.0.255

So you just redistribute connected networks and filter all except the loopback out.

Hope that helps

Roger

Thanks Roger !

I should have thought about this, but didn't click.

Thanks Again,

Regards,

deilert
Level 6
Level 6

try to clear out your type 5 lsa's bu doing a 'clear ip ospf redistribution '

Also it would see it as an E1 because you are specifying metric-type 1

It still didn't work. Here is the configs.

r2#wr t

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname r2

!

!

ip subnet-zero

no ip domain-lookup

isdn switch-type basic-ni

!

!

!

interface Loopback0

ip address 200.0.0.2 255.255.255.255

no ip directed-broadcast

!

interface Ethernet0

ip address 150.50.17.2 255.255.255.0

no ip directed-broadcast

media-type 10BaseT

!

interface Ethernet1

no ip address

no ip directed-broadcast

shutdown

media-type 10BaseT

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

frame-relay lmi-type ansi

!

interface Serial0.24 point-to-point

ip address 150.50.24.2 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 103

!

interface Serial0.256 multipoint

ip address 150.50.100.2 255.255.255.224

no ip directed-broadcast

ip ospf message-digest-key 1 md5 cisco

frame-relay map ip 150.50.100.2 102

frame-relay map ip 150.50.100.5 102 broadcast

frame-relay map ip 150.50.100.6 107 broadcast

!

interface Serial1

no ip address

no ip directed-broadcast

ip ospf network broadcast

shutdown

!

interface Serial2

no ip address

no ip directed-broadcast

shutdown

!

interface Serial3

no ip address

no ip directed-broadcast

shutdown

!

interface BRI0

no ip address

no ip directed-broadcast

dialer string 963-6000

interface BRI1

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-ni

!

interface BRI2

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-ni

!

interface BRI3

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-ni

!

router ospf 1

area 0 authentication message-digest

network 150.50.17.2 0.0.0.0 area 3

network 150.50.24.2 0.0.0.0 area 1

network 150.50.100.2 0.0.0.0 area 0

network 200.0.0.2 0.0.0.0 area 22

neighbor 150.50.100.5

neighbor 150.50.100.6

!

ip classless

!

!

line con 0

transport input none

line aux 0

line vty 0 4

!

end

r2#

r1#wr t

Building configuration...

Current configuration : 834 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname r1

!

!

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

!

!

!

interface Loopback0

ip address 200.0.0.1 255.255.255.255

!

interface Loopback10

ip address 150.50.200.1 255.255.255.0

!

interface Ethernet0/0

ip address 150.50.17.1 255.255.255.0

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface Serial0/1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

redistribute connected subnets route-map cisco

network 150.50.17.1 0.0.0.0 area 3

network 200.0.0.1 0.0.0.0 area 11

!

ip classless

ip http server

!

access-list 1 permit 150.50.200.0

route-map cisco permit 10

match ip address 1

!

route-map cisco permit 20

!

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

end

r1#

r2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 5 subnets

C 200.0.0.2 is directly connected, Loopback0

O 200.0.0.4 [110/65] via 150.50.24.4, 01:54:08, Serial0.24

O 200.0.0.5 [110/65] via 150.50.24.4, 01:54:08, Serial0.24

O IA 200.0.0.6 [110/65] via 150.50.100.6, 00:07:22, Serial0.256

O IA 200.0.0.7 [110/75] via 150.50.100.5, 00:07:22, Serial0.256

10.0.0.0/24 is subnetted, 1 subnets

O 10.1.1.0 [110/74] via 150.50.24.4, 01:54:08, Serial0.24

O E2 192.168.1.0/24 [110/20] via 150.50.100.5, 00:07:22, Serial0.256

O E2 192.168.2.0/24 [110/20] via 150.50.100.5, 00:07:22, Serial0.256

150.50.0.0/16 is variably subnetted, 5 subnets, 3 masks

O 150.50.7.0/25 [110/74] via 150.50.100.5, 01:51:45, Serial0.256

C 150.50.17.0/24 is directly connected, Ethernet0

C 150.50.24.0/24 is directly connected, Serial0.24

C 150.50.100.0/27 is directly connected, Serial0.256

O IA 150.50.5.64/27 [110/138] via 150.50.100.5, 00:07:24, Serial0.256

O E2 192.168.3.0/24 [110/20] via 150.50.100.5, 00:07:24, Serial0.256

r2#

What does a ' sh ip o dat external 150.50.200.0 ' show ?

Also you referecne ACL 1 in your route-map , I do not see ACL 1 in your config

I would like to see a sho ip ospf neighbors on these routers. I dont think they are connecting. What does the wildcard 0.0.0.0 do on the ospf network statements?

i suppose that R1 and R2 are not OSPF neighbors..that's why R2 don't see routes from RIP route redistributed into OSPF

plz add "sho ip ospf nei" command output

thanks

add the command output for R1 and R2

show ip ospf nei

&

show ip ospf database

...........

Thanks everbody in the forum ! I tried all the suggestions I received from you guys, but still couldn't make it to work. I checked configurations tons of times to see if there was any glitch. The weird thing was that R2 didn't have the entry for the route 150.50.200.0/24, but the routers beyond the R2 had that entry with default gatway through R2.

I got so frustrated that I erased both r1 and r2 completely, reloaded them and reconfigured them. Bingo! Everything is working now with the same configs I had before.

Anyway ! Thanks everyone for so responsive.

Regards,

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco