Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

OSPF route filtering

Hi Expert,

How can I limited the route from advertised to a neigbhor?

The network setup is as follow:

Subnet A - Router A -- Router B - Subnet B

Subnet C

Router A have subnet A and C

Router B have subnet B.

I want to stop router A advertised subnet C to router B, but not prevent router B from installed learned Subnet C into router B (which can be achieve by distribution list).

Any comment is welcome and thanks in advance.

3 REPLIES

Re: OSPF route filtering

Hello,

In case you do not need to announce the subnet A at all, then just leave away the network statement in OSPF including this subnet. Example:

Router A:

interface Ethernet0

description subnet A

ip address 10.1.0.1 255.255.255.0

interface Ethernet1

description subnet C

ip address 10.1.1.1 255.255.255.0

router ospf 10

network 10.1.0.1 0.0.0.0 area 0

This will only announce 10.1.0.0/24 and not 10.1.1.0/24 to any neighbor.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: OSPF route filtering

Hi martin,

I am sorry that I have simpify the qestion in the way which mislead you.

In fact there is RouterAA, RouterAB, RouterAC, RouterAD etc in the RouterA network, those router need to communication with each other with subnet A and C.

My goal is only allow subnet A to RouterB not no subnet C and any other subnet.

One solution is use route filter in RouterB, but the constrain to me is:

1. The RouterB is not under our admin which being to another dept, which is hard to ask them to do so.

2. This solution will increase the RAM usage in RouterB.

Therefore I am posting to asking another solution available.

Thanks.

New Member

Re: OSPF route filtering

Hi Ricel:

You can do it this way:

1. Put RouterAA,AB,AC,AD in a different area from area 0, saying area 100;

2. Assuming RouterAD is linked to RouterB, use it as ABR and put it in area 0 along with RouterB;

3. Use interarea filtering in RouterAD to deny Network C out of Area 100 and permit Network B into Area 0.

RouterAD(config)# router ospf 1

area 100 filter-list prefix NetC_OUT out

area 0 filter-list prefix NetB_IN in

ip prefix-list NetC_OUT deny xx.xx.xx.xx/xx

ip prefix-list NetB_IN permit xx.xx.xx.xx/xx

Please let me know how this works out.

Gary

116
Views
0
Helpful
3
Replies
CreatePlease to create content