Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF route summarization

I have attempted to summarize my OSPF routes using the "area x range x.x.x.x x.x.x.x" statement as described in the Cisco documentation for route summarization. I run 12.0(7) on the ABR router so I used a default route statement also(as recommended by Cisco). I have tried on several occasions to get the summarization to work but have encountered routing problems to the areas that I attempt to summarize.

Does anyone have examples of the OSPF statements and any default route statements that are needed to successfully do this?

Thanks,

Dave

20 REPLIES

Re: OSPF route summarization

David, Do you have a discontigous network addressing scheme in your network....That can create routing problems, during summarization. Also since your version of IOS is below 12.1(6) you need to manually configure the summary route pointing to null0 interface on the local router which is summarizing.

Visit this for more details http://www.cisco.com/warp/public/104/3.html#12.0

Perhaps if we could get a picture of your network + some configs (relevant) we might be able to troubleshoot more...

Hope that helps!

New Member

Re: OSPF route summarization

The areas I am summarize have contiguous addressing. I have included an example of the config below:

ip route 10.60.128.0 255.255.128.0 null0

router ospf 1

area 5 range 10.60.128.0 255.255.128.0

I removed the following statement from router ospf 1:

network 10.60.128.0 0.0.127.255 area 5

The ABR router that I'm working with is the core router(area 0).

When I implement these changes, my routes to the area 5 subnets use the default route for area 5 subnets and then I cannot get to those subnets.

Thanks for your quick response.

Dave

Re: OSPF route summarization

I see that, before summarization you had the command,

network 10.60.128.0 0.0.127.255 area 5 - which means, this router has an interface configured with an ip address from network 10.60.128.0/17 and that interface is in area 5. and OSPF is enabled on that interface.

Now you have given a summarization command "area 5 range 10.60.128.0 255.255.128.0 ".

The removal of the network command, actually disables OSPF on the routers interface with ip address from 10.60.128.0/17. So that is the reason why, you were not able to reach routes in area 5.

After the removal of the command, give a "show ip ospf neighbor" on this router, and see if there are any neighbors in area 5 through the corresponding interface.

Solution is that, you should not remove the network command, because, that is the key command, which enables OSPF on an interface.

Hope that helps!

New Member

Re: OSPF route summarization

Thanks for the info. So the key being that the network statement must remain and you then add the area 5 range statement to perform the summarization.

I'll give this a try.

I should be able to see only one route advertised for area 5 within an another areas router(area 1 for example) when everything is all said and done?

Re: OSPF route summarization

Yes thats correct.

New Member

Re: OSPF route summarization

I added only the area 5 range statement and the default route statement for that range and I can get to my area 5 routers.

How can I tell if the summarization is actually taking place? I've looked on other areas routers and still see the routes for each subnet in area 5. I though I would only see the area summarization route or statement. Maybe I'm not looking in the right place to see if my routing table is actually smaller.

Thanks,

Dave

Bronze

Re: OSPF route summarization

Dave,

Do you have more than one ABR in area 5? You need this same summarization on all ABRs.

Mark

New Member

Re: OSPF route summarization

Mark,

I only have one ABR for area 5. I have other routers in area 5 but they are only in area 5. I have not changed anything in my area 5(only) routers at this point.

I'm assuming you mean the ABR is the router that touches area 5 and area 0 which is the case here.

Thanks,

Dave

Re: OSPF route summarization

Perhaps, there could be a mistake in the summarized prefix, wrt the individual prefixes. Please paste your summarized prefix, along with individual ones, so that we can check out if the summarization is correct.

New Member

Re: OSPF route summarization

My summarization statement is as follows:

router ospf 1

area 5 range 10.60.128.0 255.255.128.0

my routing statement within ospf is as follows:

network 10.60.128.0 0.0.127.255 area 5

My default router for the summarized areas is:

ip route 10.60.128.0 255.255.128.0 Null0

When I do a show ip route | inlclude 10.60 on one of my area 1 routers I still get all my 10.60.129.x and above subnets in the list. I have made no changes to any of my area 5 routers as I did not think I would need to modify any OSPF statements on them.

Thanks,

Dave

Re: OSPF route summarization

Hello Dave,

I understand clearly the above setup. But what I asked for in the previous posting, is this:

I want to know all the prefixes that your area 5 routers are advertising to this ABR.

I know that the summary is 10.60.128.0/17.

I need to know the individual prefixes and their masks that are involved in this summary, which your routers in area 5 are advertising. ( such as 10.60.129.x)

New Member

Re: OSPF route summarization

Sorry about that. I have attached a partial config of one of the area 5 routers. It has the subnets and masks you asked for. Let me know what I'm overlooking.

interface Ethernet0/0

ip address 10.60.155.1 255.255.255.0

full-duplex

no cdp enable

!

interface Serial0/0

bandwidth 56

ip address 10.60.129.14 255.255.255.252

priority-group 1

router ospf 1

log-adjacency-changes

network 10.60.129.14 0.0.0.0 area 5

network 10.60.155.1 0.0.0.0 area 5

Let me know if I need to include additional info.

Thanks,

Dave

Bronze

Re: OSPF route summarization

Dave,

By any chance, do any of your routers have static routes to anything in the 10.60.128.0/17 range? If these routes are redistributed into OSPF, the summarization will not cover them.

Mark

Re: OSPF route summarization

Yeah, got that,

I see that one of the links in area 5 is having a network address, 10.60.129.12/30. I wanted to know the reason why your summarization address is 10.60.128.0/17. For this i need to know the network address of all the links in area 5. The area 5 routes are still there in area 1 routes, because of wrong summarization. Please input the remaining /30 prefixes in area 5.

New Member

Re: OSPF route summarization

I additionally have 10.60.129.18/30 10.60.129.10/30 and 10.60.129.22/30.

I also have 10.60.147.1/24, 10.60.148.1/24 and 10.60.149.1/24. I have chosen our smallest area to test with first to ensure I can get summarization working. I have other different areas to summarize that have hundreds of routes within them. I used the summary statement to try to encompass any subnet between 10.60.128.0 and 10.60.254.0. Maybe I am incorrect in doing it that way.

Thanks a bunch,

Dave

Re: OSPF route summarization

By summarizing such a huge range, you would be creating problems, later on while summarizing at other ABRs. Its always better to summarise to the next highest (supernet) prefix that is available).

I would recommend using two summarization commands, to summarize the 10.60.129.x and 10.60.147.x networks separately.

The networks falling in the 10.60.129.x range are,

10.60.129.12/30

10.60.129.16/30

10.60.129.20/30

In this case your best bet summary would be 10.60.129.0/27

The networks falling in the 10.60.147.x range are,

10.60.147.0/24

10.60.148.0/24

10.60.149.0/24

The best summary would be, 10.60.147.144/21

Your commands should apper as,

area 5 range 10.60.129.0 255.255.255.224

area 5 range 10.60.147.144 255.255.248

Hope its now clear.

New Member

Re: OSPF route summarization

I will try what you have suggested. Thanks for your prompt and informative answers.

Dave

New Member

Re: OSPF route summarization

The area range command will only summarize OSPF routes at the ABR. You will still see the external networks. If you have external routes in this area they must be summarized at the ASBR not the ABR.

Sorry if I am way off in left field on this reply and this is a purely OSPF area.

Jim Coffey

New Member

Re: OSPF route summarization

Jim,

Thanks for your input. I am trying to summarize OSPF areas only at the ABR. I'm trying to reduce the size of my routing table in all my enpoint routers. So far, I have had no success in getting the summarization to work as advertised.

I have a subnet outside of my ospf areas that I have trouble getting to when I do the summarization. I use the IP classless statement but I don't have a default route coded for this subnet. I am thinking that I need to have a default route coded for any subnet that does not fall within my summarization range and that is what I'm going to try.

Thanks for responding and let me know if I'm way of base with my idea.

Dave

Re: OSPF route summarization

Hello David,

I hope you were able to solve the previous problem you had with summarization. If not let us know, the exact problem you are facing again.

For the network, that is outside the area, instead of setting a default route, it would be much better to redistribute that route. If you include a default route instead, to reach this network, that would become a more general route, and in future, if you plan to use defaults in OSPF, this can cause problems.

381
Views
0
Helpful
20
Replies
CreatePlease to create content