Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF routing filter

Hallo,

I have some troubles with OSPF and filtering routing table:

I have two interfaces on a ABR. One interface (ethernet) is in Backbone area 0 and the other is in area 1 (frame-relay seriel interface).

The Ip address for the LAN interface is 10.1.2.254/24 and on the frame-relay there are some networks with 193.x.x.x

No I would like to filter all the routing updates from 10.0.0.0 /8 from being advertised to area 1.

Distribution-lists didn't work.

my ospf config is something like that:

router ospf 100

log-adjacency-changes

redistribute static metric-type 1 subnets

network 10.1.2.0 0.0.0.255 area 0

network 193.171.x.x 0.0.0.255 area 1

distribute-list 1 out

!

access-list 1 deny 10.1.2.0

access-list 1 deny 10.1.2.0 0.0.0.255

access-list 1 permit any

Thanks a lot

Max

6 REPLIES
Silver

Re: OSPF routing filter

In OSPF linkstate updates are only sent to neighbors in the same area. So your interface in area 0 will only send updates to other neighbors in area 0. The same goes for your frame-relay it will only send updates to neighbors in area 1.

If you want to prevent certain networks from being learned about by routers in area 1 or area 0 you have to use a route-map

New Member

Re: OSPF routing filter

Hallo,

But in OSPF I am not able to configure route-maps. I only can start two OSPF processes each for one area. Then I can redistribute between these two processes and set a route-map.

Do you think that is the only solution to filter these network from being advertised to area 1?

Thanks a lot

Markus

Re: OSPF routing filter

OSPF doesnt send updates as routing table entries, but as LSAs. Distribute lists cannot touch LSAs, they can only prevent something coming in/out of routing table. So what you need to do is configure a inbound distributed list on the routers in area 1, deny the desired networks. Still those routes would be there in the OSPF database and flooded from there to other routers, but the route wont be installed into the routing table.

New Member

Re: OSPF routing filter

So there is no way to prevent any networks of the backbone area being advertised to all other routers?

Re: OSPF routing filter

You can use a new feature called OSPF LSA 3 filtering, where interarea routes are filtered from one area to another area.

You can check this link.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087be9.html

New Member

Re: OSPF routing filter

hello,

i try to implement this filetring, but it don't seems to work. and i don't found other explenation on the cisco site.

i got one router in area 0 (f0/0 ) and area 3 (f0/1.1 dot1q)

with this config:

router ospf 109

router-id 172.17.7.5

log-adjacency-changes

area 0 authentication

area 3 filter-list prefix AREA_0-vers-AREA_3 in

redistribute connected metric 50 subnets

redistribute static metric 50 subnets

network 172.27.64.14 0.0.0.0 area 0

network 172.27.65.253 0.0.0.0 area 3

distribute-list OSPF-CONNECTED out connected

distribute-list OSPF-STATIC out static

ip prefix-list AREA_0-vers-AREA_3 seq 5 permit 128.1.0.0/16

ip prefix-list AREA_0-vers-AREA_3 seq 10 permit 172.29.0.0/16

the second router has only this config:

interface Ethernet0/0

ip address 172.27.65.250 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0/1

no ip address

no ip directed-broadcast

shutdown

!

router ospf 109

network 172.27.65.250 0.0.0.0 area 3

but i received all the routing table from the area 0

did i make something wrong ?

fabrice

213
Views
4
Helpful
6
Replies