Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF Routing Issues

I have 2 routers connecting each other via LAN. Each router has 2 ethernet ports. Router A and Router B

Router A Config:

interface Loopback0

ip address 192.168.1.1 255.255.255.255

!

interface FastEthernet0/0

description Internal Connection

ip address 192.168.2.1 255.255.255.224

ip ospf network broadcast

ip ospf hello-interval 30

ip ospf priority 2

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/1

description Connection to ISP

bandwidth 6000

ip address 203.108.205.218 255.255.255.252

ip ospf hello-interval 30

speed 100

full-duplex

no cdp enable

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.1.0 0.0.0.0 area 0

network 192.168.2.0 0.0.0.31 area 0

passive-interface fa0/1

default-information originate always

!

Router B config:

interface Loopback0

ip address 192.168.1.2 255.255.255.255

!

interface Ethernet0

description External INterface

ip address 192.168.2.2 255.255.255.224

ip ospf network broadcast

ip ospf hello-interval 30

ip ospf priority 0

full-duplex

!

interface FastEthernet0

description Internal Network

ip address 192.168.3.1 255.255.255.0

ip ospf network broadcast

ip ospf hello-interval 30

ip ospf priority 0

speed 100

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.2.0 0.0.0.31 area 0

network 192.168.3.0 0.0.0.255 area 1

network 192.168.1.2 0.0.0.0 area 0

!

But, when issue an the " show ip ospf nei" command at router B, there is no output. Neighbor relationship cannot be established...can I know why?

19 REPLIES
New Member

Re: OSPF Routing Issues

I guess there is a fault with your topology or ur interface state .. cause the Configuration seems to be okay.

do a show prot

do a show cdp neighbour

Gold

Re: OSPF Routing Issues

A few comments on your configuration.... Just some things I don't understand, and a couple that could be impacting your ability to build an adjacency.

Router A Config:

interface Loopback0

ip address 192.168.1.1 255.255.255.255

!

interface FastEthernet0/0

description Internal Connection

ip address 192.168.2.1 255.255.255.224

ip ospf network broadcast

-- You don't need this configuration--in fact, it shouldn't print out even if you configure it (?). fat ethernet should always be broadcast.

ip ospf hello-interval 30

--> You're not configuring your dead-interval as well, which might be messing you up. This is a long hello interval, and the default dead interval is only 40 seconds, so you could be dropping neighbors just because of this.

....

interface FastEthernet0/1

....

--> You don't have a network statement that covers this interface, and further, you have it marked as passive. You don't need to set the hello interval on an interface you're not running ospf on.

....

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.1.0 0.0.0.0 area 0

--> You don't have any interface numbered 192.168.1.0? I think this is a typo, you intended to cover the loopback interface, but you didn't.

network 192.168.2.0 0.0.0.31 area 0

passive-interface fa0/1

--> You don't have any network command covering fast ethernet 0/1, so you don't need to make it passive.

default-information originate always

!

Router B config:

interface Loopback0

ip address 192.168.1.2 255.255.255.255

!

interface Ethernet0

description External INterface

ip address 192.168.2.2 255.255.255.224

ip ospf network broadcast

ip ospf hello-interval 30

ip ospf priority 0

--> You don't have a network statement which covers this interface, and you're marking it passive. Why do you have ospf commands here?

full-duplex

!

interface FastEthernet0

description Internal Network

ip address 192.168.3.1 255.255.255.0

ip ospf network broadcast

--> Again, you don't really need this configuration.

ip ospf hello-interval 30

--> Same comment as above on the hello interval.

ip ospf priority 0

--> Why?

speed 100

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.2.0 0.0.0.31 area 0

network 192.168.3.0 0.0.0.255 area 1

network 192.168.1.2 0.0.0.0 area 0

Second, I would turn on debug ip ospf adj--that should tell you precisely why ospf isn't building an adjacency. :-)

Russ.W

New Member

Re: OSPF Routing Issues

Router A

interface FastEthernet0/0

description Internal Connection

ip address 203.115.220.65 255.255.255.224 secondary

ip address 203.115.220.97 255.255.255.224 secondary

ip address 203.115.220.1 255.255.255.224

ip ospf hello-interval 8

ip ospf dead-interval 30

ip ospf priority 2

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/1

description Connection to ISP

bandwidth 6000

ip address 203.115.200.218 255.255.255.252

ip wccp web-cache redirect out

ip ospf hello-interval 30

speed 100

full-duplex

no cdp enable

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

passive-interface FastEthernet0/1

network 203.115.220.0 0.0.0.31 area 0

network 203.115.220.64 0.0.0.31 area 0

network 203.115.220.96 0.0.0.31 area 0

network 203.115.220.248 0.0.0.0 area 0

default-information originate always

!

Rauter B

interface Loopback0

ip address 203.115.220.249 255.255.255.255

!

interface Ethernet0

description External INterface

ip address 203.115.220.13 255.255.255.224

ip ospf hello-interval 8

ip ospf dead-interval 30

full-duplex

!

interface FastEthernet0

description Formosa Internal Network

ip address 192.168.3.1 255.255.255.0 secondary

ip address 203.115.221.17 255.255.255.248

ip ospf hello-interval 8

ip ospf dead-interval 30

speed 100

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.3.0 0.0.0.255 area 1

network 203.115.220.0 0.0.0.31 area 0

network 203.115.221.16 0.0.0.7 area 1

Debug Message from Router B:

clear ip ospf proc

Reset ALL OSPF processes? [no]: y

formosa#

3w6d: OSPF: Flushing External Links

3w6d: OSPF: Flushing Opaque AS Links

3w6d: OSPF: Flushing Link states in area 0

3w6d: OSPF: Interface Ethernet0 going Down

3w6d: OSPF: 203.115.220.249 address 203.115.220.13 on Ethernet0 is dead, state DOWN

3w6d: OSPF: Neighbor change Event on interface Ethernet0

3w6d: OSPF: DR/BDR election on Ethernet0

3w6d: OSPF: Elect BDR 0.0.0.0

3w6d: OSPF: Elect DR 0.0.0.0

3w6d: OSPF: Elect BDR 0.0.0.0

3w6d: OSPF: Elect DR 0.0.0.0

3w6d: DR: none BDR: none

3w6d: OSPF: Flush network LSA immediately

3w6d: OSPF: Remember old DR 203.115.220.249 (id)

3w6d: OSPF: Flushing Link states in area 1

3w6d: OSPF: Interface FastEthernet0 going Down

3w6d: OSPF: 203.115.220.249 address 203.115.221.17 on FastEthernet0 is dead, state DOWN

3w6d: OSPF: Neighbor change Event on interface FastEthernet0

3w6d: OSPF: DR/BDR election on FastEthernet0

3w6d: OSPF: Elect BDR 0.0.0.0

3w6d: OSPF: Elect DR 0.0.0.0

3w6d: OSPF: Elect BDR 0.0.0.0

3w6d: OSPF: Elect DR 0.0.0.0

3w6d: DR: none BDR: none

3w6d: OSPF: Flush network LSA immediately

3w6d: OSPF: Remember old DR 203.115.220.249 (id)

3w6d: OSPF: Interface Ethernet0 going Up

3w6d: OSPF: Interface FastEthernet0 going Up

3w6d: OSPF: We are not DR to build Net Lsa for interface Ethernet0

3w6d: OSPF: Build router LSA for area 0, router ID 203.115.220.249, seq 0x80000001

3w6d: OSPF: We are not DR to build Net Lsa for interface FastEthernet0

3w6d: OSPF: Build router LSA for area 1, router ID 203.115.220.249, seq 0x80000001

3w6d: OSPF: end of Wait on interface Ethernet0

3w6d: OSPF: DR/BDR election on Ethernet0

3w6d: OSPF: Elect BDR 203.115.220.249

3w6d: OSPF: Elect DR 203.115.220.249

3w6d: OSPF: Elect BDR 0.0.0.0

3w6d: OSPF: Elect DR 203.115.220.249

3w6d: DR: 203.115.220.249 (Id) BDR: none

3w6d: OSPF: end of Wait on interface FastEthernet0

3w6d: OSPF: DR/BDR election on FastEthernet0

3w6d: OSPF: Elect BDR 203.115.220.249

3w6d: OSPF: Elect DR 203.115.220.249

3w6d: OSPF: Elect BDR 0.0.0.0

3w6d: OSPF: Elect DR 203.115.220.249

3w6d: DR: 203.115.220.249 (Id) BDR: none

3w6d: OSPF: No full nbrs to build Net Lsa for interface Ethernet0

3w6d: OSPF: No full nbrs to build Net Lsa for interface FastEthernet0

Still cannot build neighbor relationship

Silver

Re: OSPF Routing Issues

do you have ip subnet zero configured ? in not try to enable it .

New Member

Re: OSPF Routing Issues

Yeap. It is enabled. Actually, the two routers are connected via Wireless link. Still no luck to establish the adjacent relationship. Any idea why? I can ping each other, but, no ospf adjacent relationship.

Silver

Re: OSPF Routing Issues

Why don't you try and set the hello and dead timers to the default value, also you do not need

network 203.115.220.0 0.0.0.31 area 0

network 203.115.220.64 0.0.0.31 area 0

network 203.115.220.96 0.0.0.31 area 0

network 203.115.220.248 0.0.0.0 area 0

you can cover it with one statement

network 203.115.220.0 0.0.0.255 area 0

the box will advertise all the interfaces that fall

in that range

you can do the same on router B

New Member

Re: OSPF Routing Issues

Hello,

Can you ping between the two interfaces?

Can you see the other router with show cdp nei?

Please post the full output of "show ip ospf interface" for both interfaces?

Regards

Ian

Gold

Re: OSPF Routing Issues

What debug is this? It doesn't look like debug ip ospf adj, which is what we need to see why this router isn't building any full adj's. It just tells us that there's no full adj's to build a network LSA for.

Russ.W

Re: OSPF Routing Issues

Hi

we faced the same type of issue.we hve 2 links between 2 of our offices (leased lines).OSPF configured @ both end routers we werent able to c ospf adj once we did debug ip ospf adj we came to know that the interface/ip swapped.once we changed(swapped) the ips of the both the interfaces ospf started wkg..

regds

prem

New Member

Re: OSPF Routing Issues

Yes. I did turn on "debug ip ospf adj", but, there is no output message display. Can it be IOS bug?

I am using 1 cisco 2651XM router and 1 Cisco 1721 router

IOS for 1721 router

c1700-y-mz.122-4.YA2.bin

IOS for 2651XM router

c2600-is-mz.121-19.bin

New Member

Re: OSPF Routing Issues

Hello,

You may not be sending the debug to the console. When telnetted in please enter terminal monitor at the exec prompt. Please also ensure you have "no logging console" configured,

Regards

Ian

New Member

Re: OSPF Routing Issues

Yes. The following is what I am getting...

1d01h: OSPF: end of Wait on interface Ethernet0

1d01h: OSPF: DR/BDR election on Ethernet0

1d01h: OSPF: Elect BDR 203.115.220.249

1d01h: OSPF: Elect DR 203.115.220.249

1d01h: OSPF: Elect BDR 0.0.0.0

1d01h: OSPF: Elect DR 203.115.220.249

1d01h: DR: 203.115.220.249 (Id) BDR: none

1d01h: OSPF: end of Wait on interface FastEthernet0

1d01h: OSPF: DR/BDR election on FastEthernet0

1d01h: OSPF: Elect BDR 203.115.220.249

1d01h: OSPF: Elect DR 203.115.220.249

1d01h: OSPF: Elect BDR 0.0.0.0

1d01h: OSPF: Elect DR 203.115.220.249

1d01h: DR: 203.115.220.249 (Id) BDR: none

1d01h: OSPF: No full nbrs to build Net Lsa for interface Ethernet0

1d01h: OSPF: No full nbrs to build Net Lsa for interface FastEthernet0

There is not much useful information.

New Member

Re: OSPF Routing Issues

Hello,

Which router is 203.115.220.249, I don't see it in your configs?

Please send

show ip ospf interface

sh interface

for both routers? It looks like the other router is sending no hellos.

Regards

ian

New Member

Re: OSPF Routing Issues

Router A Config:

interface Loopback0

ip address 192.168.1.1 255.255.255.255

!

interface FastEthernet0/0

description Internal Connection

ip address 192.168.2.1 255.255.255.224

ip ospf network broadcast

The above statement can be removed. The network will be broadcast through your ospf statements

ip ospf hello-interval 30

The above statement can be removed. The default timers are normally sufficient. If you experience problems after you establish adjacencies then these can be adjusted. However, when manipulating the hello-interval the dead timer should also be adjusted accordingly.

ip ospf priority 2

Running only two routers does not really require on ospf priority statement since one will be the DR and one will be the BDR. Having this statement in will not hurt anything though.

speed 100

full-duplex

no cdp enable

CDP enable! I have experienced similar problems when I have turned this protocol off. Since it is a layer 2 protocol it discovers router b prior to ospf trying to make a connection. Enable cdp, it certainly won’t hurt anything.

!

interface FastEthernet0/1

description Connection to ISP

bandwidth 6000

ip address 203.108.205.218 255.255.255.252

ip ospf hello-interval 30

The above statement can be removed due to the fact that this interface is passive. There will not be any ospf hello packets propagated down this link.

speed 100

full-duplex

no cdp enable

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.1.0 0.0.0.0 area 0

Remove network 192.168.1.0 0.0.0.0 area 0 and replace it with network 192.168.1.1 0.0.0.0 area 0

network 192.168.2.0 0.0.0.31 area 0

passive-interface fa0/1

default-information originate always

This statement can be removed

!

Router B config:

interface Loopback0

ip address 192.168.1.2 255.255.255.255

!

interface Ethernet0

description External INterface

ip address 192.168.2.2 255.255.255.224

ip ospf network broadcast

ip ospf hello-interval 30

ip ospf priority 0

These statements can be removed

full-duplex

!

interface FastEthernet0

description Internal Network

ip address 192.168.3.1 255.255.255.0

ip ospf network broadcast

ip ospf hello-interval 30

These statements can be removed

ip ospf priority 0

I would only keep this if you want this router to always the BDR

speed 100

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.2.0 0.0.0.31 area 0

network 192.168.3.0 0.0.0.255 area 0

network 192.168.1.2 0.0.0.0 area 0

!

New Member

Re: OSPF Routing Issues

sending for stansr537 next message

New Member

Re: OSPF Routing Issues

Router A Config:

interface Loopback0

ip address 192.168.1.1 255.255.255.255

!

interface FastEthernet0/0

description Internal Connection

ip address 192.168.2.1 255.255.255.224

ip ospf network broadcast

This statement can be removed. The network will be broadcast through your ospf statements

ip ospf hello-interval 30

This statement can be removed. The default timers are normally sufficient. If you experience problems after you establish adjacencies then these can be adjusted. However, when manipulating the hello-interval the dead timer should also be adjusted accordingly.

ip ospf priority 2

Running only two routers does not really require on ospf priority statement since one will be the DR and one will be the BDR. Having this statement in will not hurt anything though.

speed 100

I do not know why you have this statement.

full-duplex

no cdp enable

CDP enable! I have experienced similar problems when I have turned this protocol off. Since it is a layer 2 protocol it discovers router b prior to ospf trying to make a connection. Enable cdp, it certainly won’t hurt anything.

!

interface FastEthernet0/1

description Connection to ISP

bandwidth 6000

ip address 203.108.205.218 255.255.255.252

ip ospf hello-interval 30

This statement can be removed due to the fact that this interface is passive. There will not be any ospf hello packets propagated down this link.

speed 100

full-duplex

no cdp enable

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.1.0 0.0.0.0 area 0

Remove this statement and replace it with network 192.168.1.1 0.0.0.0 area 0

network 192.168.2.0 0.0.0.31 area 0

passive-interface fa0/1

default-information originate always

This statement can be removed

!

Router B config:

interface Loopback0

ip address 192.168.1.2 255.255.255.255

!

interface Ethernet0

description External INterface

ip address 192.168.2.2 255.255.255.224

ip ospf network broadcast

ip ospf hello-interval 30

ip ospf priority 0

These statements can be removed

full-duplex

!

interface FastEthernet0

description Internal Network

ip address 192.168.3.1 255.255.255.0

ip ospf network broadcast

ip ospf hello-interval 30

These statements can be removed

ip ospf priority 0

I would only keep this if you want this router to always the BDR

speed 100

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 192.168.2.0 0.0.0.31 area 0

network 192.168.3.0 0.0.0.255 area 1

network 192.168.1.2 0.0.0.0 area 0

These statements are good.

!

New Member

Re: OSPF Routing Issues

istt_affin_router#s ip ospf

Routing Process "ospf 100" with ID 203.115.220.248

Supports only single TOS(TOS0) routes

Supports opaque LSA

It is an autonomous system boundary router

Redistributing External Routes from,

connected, includes subnets in redistribution

SPF schedule delay 5 secs, Hold time between two SPFs 10 secs

Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs

Number of external LSA 3. Checksum Sum 0x15E75

Number of opaque AS LSA 0. Checksum Sum 0x0

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

External flood list length 0

Area BACKBONE(0) (Inactive)

Number of interfaces in this area is 2

Area has no authentication

SPF algorithm executed 9 times

Area ranges are

Number of LSA 1. Checksum Sum 0x7496

Number of opaque link LSA 0. Checksum Sum 0x0

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

This show that my area 0 is inactive which I am not sure why?

New Member

Re: OSPF Routing Issues

which router is this for? just curious wher the id of 203.115.220.248 came from.

Gold

Re: OSPF Routing Issues

So far, three people have said something about your ospf hello interval being 30, with your dead time being default. The default dead time is 40 seconds, and you're setting the hello interval to 30 seconds, which will almost gaurentee a loss in neighbor adjacency on a periodic basis.

Further, we've all made comments on your network statements, and other issues in your configuration. My first step in this problem would be to change the configurations around as three of us have suggested, and see if the problem clears up.

Russ.W

842
Views
3
Helpful
19
Replies