Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

OSPF routing problem

I have very intersting problem in my network.

I will tried to describe it.

I have two computer 10.2.1.130 mask 255.255.255.0 and 10.2.1.131 255.255.255.0 conect to switch it. The router 1610 have Vlan interface configuration as following 

interface Vlan1

description Lan

ip address 10.2.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

the switch is conect to this Vlan.  Also the router has FastEthernet 0 and FastEthernet 1 service two diferent provider.

track 1 ip sla 1 reachability

delay down 15 up 60

!

track 2 ip sla 2 reachability

delay down 15 up 60

ip sla 1

icmp-echo 172.16.10.1

frequency 5000

ip sla schedule 1 life forever start-time now

ip sla 2

icmp-echo 172.16.11.1

frequency 500

ip sla schedule 2 life forever start-time now

!

interface FastEthernet0

description PIN WAN

ip address 172.16.10.7 255.255.255.0

ip nat inside

ip virtual-reassembly

ip ospf cost 2

delay 10

duplex auto

speed auto

!

!

interface FastEthernet1

description EOT WAN

ip address 172.16.11.7 255.255.255.0

ip nat inside

ip virtual-reassembly

ip ospf cost 6

delay 12

duplex auto

speed auto

The ospf configuration into router 1610 is

router ospf 7

log-adjacency-changes

network 10.2.1.0 0.0.0.255 area 0

network 172.16.10.0 0.0.0.255 area 0

network 172.16.11.0 0.0.0.255 area 0

I have other two router other diferent location.Corporate location  and Data center location.

Corporate location is my router to conect 172.16.10.0 Network and get Datacenter router trougth 10.0.1.0 network it conect trougth fiber optic.

interface GigabitEthernet0/0

description PIN

ip address 172.16.10.1 255.255.255.0

ip flow ingress

ip nat inside

ip virtual-reassembly

ip ospf cost 1

ip ospf priority 100

delay 10

duplex auto

speed auto

media-type rj45

interface FastEthernet0/3/1

ip address 10.0.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip ospf priority 90

duplex auto

speed auto

!

router ospf 20

log-adjacency-changes

network 10.0.1.0 0.0.0.255 area 0   Lan to Datacenter

network 10.1.1.0 0.0.0.255 area 0    Lan to Corporate

network xx.16.x4.0 0.0.0.255 area 0  Internet

network 172.16.10.0 0.0.0.255 area 0  external offices

Data center rotuer configuration

interface GigabitEthernet0/0

ip address 10.0.1.2 255.255.255.0

ip nat inside

ip virtual-reassembly

ip ospf priority 100

duplex auto

speed auto

media-type rj45

interface GigabitEthernet0/1

ip address 172.16.11.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip ospf cost 2

ip ospf priority 90

duplex auto

speed auto

media-type rj45

analysis-module monitoring

router ospf 111

log-adjacency-changes

network 10.0.1.0 0.0.0.255 area 0       Lan to Corporate

network 172.16.11.0 0.0.0.255 area 0  backup external network

network xx.x7.x8.0 0.0.0.255 area 0  second internet access

My problem is ping from 10.2.1.130 mask 255.255.255.0  to 10.0. 1.130 it is ok and I ping 10.0.1.150 it is ok.

Now  ping from 10.2.1.131 255.255.255.0   to 10.0. 1.130 it is ok and I ping 10.0.1.150 it is get it or get one ping four.

one way to do solution is turn off interface

interface FastEthernet1 into router 1610 after that two computer ping server with problem.

I what I apreciation help bring to work it.

Thanks

Roberto Londono

437
Views
0
Helpful
0
Replies
CreatePlease to create content