Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF Static route redistributed into BGP

Hi..I have a legacy DDR router that is running OSPF and this is required to redistribute its static routes to a local WAN BGP router.When we fail a remote WAN link to DDR initiates a call and so far so good.When we re-establish the remote WAN link the local BGP router does NOT see a better route via BGP so the isdn call does not drop.Any ides how to redistribute so the floating static will be correctly aged when a route with a better metric is available

router ospf 100

redistribute static

passive-interface Serial1/0:15

network 193.116.135.0 0.0.0.255 area 0

!

ip classless

ip route 10.44.30.64 255.255.255.240 10.220.65.163 250

ip route 10.44.30.80 255.255.255.240 10.220.65.164 250

ip route 10.44.30.96 255.255.255.240 10.220.65.165 250

ip route 10.44.30.112 255.255.255.240 10.220.65.166 250

ip route 10.44.30.128 255.255.255.240 10.220.65.167 250

ip route 10.44.30.144 255.255.255.240 10.220.65.168 250

ip route 10.44.30.160 255.255.255.240 10.220.65.169 250

ip route 10.44.30.176 255.255.255.240 10.220.65.170 250

ip route 10.44.30.192 255.255.255.240 10.220.65.171 250

ip route 10.44.30.208 255.255.255.240 10.220.65.172 250

ip route 10.44.30.224 255.255.255.240 10.220.65.173 250

ip route 10.44.30.240 255.255.255.240 193.116.135.120 200

ip route 10.44.30.240 255.255.255.240 10.220.65.174 250

ip route 10.44.31.0 255.255.255.240 10.220.65.175 250

ip route 10.44.31.16 255.255.255.240 10.220.65.176 250

ip route 172.16.1.0 255.255.255.0 10.220.65.162 250

router ospf 100

log-adjacency-changes

redistribute bgp 64589 subnets

network 172.13.0.0 0.0.255.255 area 0

network 172.31.37.52 0.0.0.3 area 0

!

router bgp 64589

no synchronization

bgp log-neighbor-changes

network 63.130.52.161 mask 255.255.255.255

network 172.13.0.0

network 0.0.0.0

redistribute ospf 100 match internal external 2

neighbor 172.31.37.53 remote-as 4445

neighbor 172.31.37.53 password 7

no auto-summary

Many Thanks

Mike

11 REPLIES
Bronze

Re: OSPF Static route redistributed into BGP

Hi Mike

What does the a debug dialer event give you?

Regards

Roger

New Member

Re: OSPF Static route redistributed into BGP

Hi Roger,

I don't think the issue is with DDR but more towards the way BGP selects its best route..When the remote WAN link comes back up the core router should learn of the new route with a better AD via BGP but it never does and always uses the DDR static route.

Regards

Mike

Gold

Re: OSPF Static route redistributed into BGP

So, on the first router above, you are redistributing from statics into OSPF, and on the second router, you are mutually redistributing between OSPF and BGP. I assume the dial link is on the first router, with the static routes configured. When the primary link fails, the route learned through BGP on the second router (the WAN router) drops out, and the OSPF route redistirbuted from BGP is lost as well, so the first router (the dial router) loses this route through OSPF.

Which means the static comes into the table, and is then redistributed into OSPF, and then to the WAN router, where it is redistributed into BGP, and the remote is now reachable again. When the primary link comes back up, the route is again learned through BGP on the WAN router, but the BGP route won't go back into the table over the OSPF route.

Is this the correct sequence of events? If so, is the route being learned on the WAN router through iBGP, or through eBGP? I would assume it's through iBGP, in which case you would need to make certain iBGP routes are preferred over OSPF externals.

Russ.W

New Member

Re: OSPF Static route redistributed into BGP

Hi Russ and thanks for responding..Yes you have correctly summarised the problem..We drop a remote WAN link so the PRI router uses its static to reach the remote network.We re-establish the remote WAN link but the CORE VPN router running BGP never updates its routing table so will still route via the PRI router although it "should" have learnt of a better router via BGP with a AD of 20.

Regards

Mike

Bronze

Re: OSPF Static route redistributed into BGP

Does the WAN router have the re-learned routes in the BGP table?

New Member

Re: OSPF Static route redistributed into BGP

NO...When we re-connect the remote WAN that router correctly learns all its routes via BGP but the core WAN router still has the best route via the static DDR router and NOT via BGP .To get round this we delete the static and then the core WAN router correctly learns a BGP route with a metric of 0 and an AD of 20.

Mike

Bronze

Re: OSPF Static route redistributed into BGP

I'm not talking about the route table. When BGP learns routes it puts them in a topology table called the BGP table. Like OSPF learns routes and puts them in the OSPF database. THEN the router decides which routes to install in the route table. If you dont have any routes in the BGP table they cant be moved into the route table.

Gold

Re: OSPF Static route redistributed into BGP

They are eBGP then.... Which makes this much harder. Does one of those two network statements cover the route you're dealing with in the config above? BGP normally won't reinstall its route in the table if there's an IGP route there that matches, even if the BGP admin distance is lower. There isn't much of a way around this at the moment, though I have been able to work with locally redistributed routes to get around it in some situations.

If one of the network statements in the config above covers the route you're dealing with, try removing that, if possible. If not, then you could try and make the route come in as an iBGP route. I assume you can't do this because you're using ipefr, or some similar service, that requires BGP over the link (?).

Russ.W

New Member

Re: OSPF Static route redistributed into BGP

Hi Russ,

Think I have come up witha work around..Have created a distribute list with OSPF on the core WAN router that denies the LAN subnets of the remote routers so the only way the core can learn of a route is via BGP..Tested it last night and works a treat..Many thanks for your time and trouble !

router ospf 100

log-adjacency-changes

redistribute bgp 64589 subnets

network 172.13.0.0 0.0.255.255 area 0

network 172.31.37.52 0.0.0.3 area 0

distribute-list 30 in

access-list 30 deny 10.44.30.0 0.0.0.255

access-list 30 permit any

access-list 30 remark PRI Distribute ACL

Cheers

Mike

Gold

Re: OSPF Static route redistributed into BGP

Yes, that will work, as long as you don't need the routes learned from OSPF at all.... It's a great solution, though.

:-)

Russ.W

New Member

Re: OSPF Static route redistributed into BGP

By configuring this way, How can your spokes that run on BGP link, able to reach the spoke that runs on ISDN link since your core WAN router do not know how to reach the ISDN spoke via your DDR router?

224
Views
0
Helpful
11
Replies
CreatePlease login to create content