Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF....Urgent

following configuration file of the routers here "redistribute static" did not work. Also it was observed in another router where OSPF

was getting configured but it was not exchanging the routes over OSPF,

but was able to do the same over eigrp.

We tried erasing the flash and then copy the IOS, it did not work.

IOS in ra router c3640-is-mz.122-5.bin

IOS in om router c3640-d-mz.120-7.XK3

where OSPF did not exchange routes with other OSPF router.

ra#sh conf

Using 6480 out of 129016 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ra!

no logging buffered

!

memory-size iomem 10

ip subnet-zero

!

!

interface Ethernet0/0

ip address 172.16.101.1 255.255.255.0

no ip mroute-cache

shutdown

half-duplex

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

no fair-queue

ignore-dcd

!

interface Ethernet0/1

ip address x.x.x.x 255.255.255.0 secondary

ip address 172.16.18.1 255.255.255.0 secondary

ip address 172.16.94.1 255.255.255.0 secondary

ip address x.x.x.x 255.255.255.0

ip access-group 111 in

no ip mroute-cache

half-duplex

!

interface FastEthernet1/0

ip address 172.16.10.1 255.255.255.0 secondary

ip address x.x.x.x 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet1/1

ip address x.x.x.1 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet3/0

ip address x.x.x.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet3/1

no ip address

shutdown

duplex auto

speed auto

!

router eigrp 172

redistribute static

redistribute ospf 172

network 144.0.0.0

network 172.16.0.0

auto-summary

no eigrp log-neighbor-changes

!

router ospf 172

log-adjacency-changes

redistribute connected

redistribute static

redistribute eigrp 172

network x.x.x.0 0.0.255.255 area 0

network 172.16.101.0 0.0.0.255 area 0

network 172.16.0.0 0.0.255.255 area 0

!

ip classless

no ip forward-protocol udp bootps

no ip forward-protocol udp bootpc

ip route x.x.x.0 255.255.255.0 172.16.101.2

ip route x.x.x.0 255.255.255.0 144.0.51.4

ip route x.x.x.0 255.255.255.0 144.0.51.4

ip route x.x.x.0 255.255.255.0 144.0.51.3

ip route 172.16.2.0 255.255.255.0 144.0.51.20 permanent

ip route 172.16.3.0 255.255.255.0 144.0.51.20 permanent

ip route 172.16.4.0 255.255.255.0 144.0.51.20 permanent

ip route 172.16.17.0 255.255.255.0 172.16.101.2

ip route 172.16.200.0 255.255.255.0 172.16.101.2

ip route 172.16.201.0 255.255.255.0 172.16.101.2

no ip http server

ip pim bidir-enable

!

logging 172.16.18.81

access-list 111 permit ip any host 172.16.201.11

access-list 111 permit ip any host 172.16.201.12

access-list 111 permit ip any host 172.16.201.13

access-list 111 permit ip any host 172.16.201.14

access-list 111 permit ip any host 172.16.201.15

access-list 111 permit ip any host 172.16.201.16

access-list 111 permit ip any host 172.16.201.17

access-list 111 permit ip any host 172.16.201.18

access-list 111 permit ip any host 144.0.41.164

access-list 111 permit ip any host 172.16.18.12

access-list 111 permit ip any host 144.0.51.9

access-list 111 permit ip any host 144.0.51.58

access-list 111 permit ip any host 144.0.51.2

access-list 111 permit ip any host 172.16.17.2

access-list 111 permit ip any host 144.0.41.6

access-list 111 permit ip any host 144.0.1.20

access-list 111 permit ip any host 144.0.70.211

access-list 111 permit ip any host 172.16.18.98

access-list 111 permit ip any host 144.0.41.143

access-list 111 permit ip any host 172.16.9.60

access-list 111 permit ip any host 172.16.18.74

access-list 111 permit ip any host 144.0.1.2

access-list 111 permit ip any host 144.0.1.29

access-list 111 permit ip any host 144.0.61.49

access-list 111 permit ip any host 144.0.1.94

access-list 111 permit ip any host 144.0.20.36

access-list 111 permit ip any host 144.0.20.39

access-list 111 permit ip any host 144.0.20.40

access-list 111 permit ip any host 144.0.20.42

access-list 111 permit ip any host 144.0.20.5

access-list 111 permit ip any host 144.0.20.9

access-list 111 permit ip any host 144.0.51.5

access-list 111 permit ip any host 144.0.20.10

access-list 111 permit ip any host 172.16.51.7

access-list 111 permit ip any host 172.16.51.9

access-list 111 permit ip any host 172.16.18.8

access-list 111 permit ip any host 172.16.18.4

access-list 111 permit ip any host 144.0.1.1

access-list 111 permit ip any host 144.0.1.4

access-list 111 permit ip any host 172.16.200.10

access-list 111 permit ip any host 172.16.200.18

access-list 111 permit ip any host 172.16.200.14

access-list 111 permit ip any host 144.0.21.102

access-list 111 permit ip any host 144.0.51.219

access-list 111 permit ip any host 172.16.18.17

access-list 111 permit ip any host 172.16.18.81

access-list 111 permit ip any host 172.16.18.80

access-list 111 permit ip any host 144.0.51.29

access-list 111 permit ip any host 144.0.51.70

access-list 111 permit ip any host 144.0.51.119

access-list 111 permit ip any host 144.0.51.6

access-list 111 permit ip any host 144.0.61.19

access-list 111 permit ip any host 144.0.51.191

access-list 111 permit ip host 144.0.51.58 any

access-list 111 permit ip host 172.16.18.17 any

access-list 111 permit ip host 172.16.18.81 any

access-list 111 permit ip host 144.0.1.2 any

access-list 111 permit ip host 172.16.18.80 any

access-list 111 permit ip host 144.0.51.29 any

access-list 111 permit ip host 144.0.51.70 any

access-list 111 permit ip host 144.0.51.119 any

access-list 111 permit ip host 144.0.51.6 any

access-list 111 permit ip host 144.0.61.19 any

access-list 111 permit ip host 144.0.51.191 any

access-list 111 permit ip any host 144.0.51.4

access-list 111 permit ip any host 144.0.51.1

access-list 111 permit ip host 144.0.51.4 any

access-list 111 permit ip host 172.16.18.74 any

access-list 111 permit ip host 172.16.18.12 any

access-list 111 permit ip host 144.0.51.3 any

access-list 111 permit ip host 144.0.51.219 any

access-list 111 permit ip host 144.0.51.19 any

access-list 111 permit ip host 144.0.51.5 any

access-list 111 permit ip host 144.0.70.211 any

access-list 111 permit ip any host 172.16.11.1

access-list 111 permit ip host 172.16.18.250 any

access-list 111 permit ip host 144.0.51.75 any

access-list 111 permit ip host 172.16.18.98 any

access-list 111 permit ip host 144.0.51.200 any

access-list 111 permit ip any host 144.0.51.200

access-list 111 permit ip host 172.16.18.14 any

access-list 111 permit ip any host 172.16.18.14

access-list 111 permit ip host 144.0.51.17 any

access-list 111 permit ip x.x.x.x 0.0.0.255 172.16.18.0 0.0.0.255

access-list 111 permit ip 172.16.18.0 0.0.0.255 144.0.51.0 0.0.0.255

snmp-server engineID local xxxxxx

snmp-server community public RO

!

dial-peer cor custom

!

!

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

access-class 12 in

password xxxxx

login

!

end

om# router conf

ip subnet-zero

ip name-server 144.0.1.2

ip name-server 144.0.1.29

!

ipx routing 00b0.6449.02c1

!

!

!

interface Ethernet0/0

description WAN LINK TO LOAD DESPATCH

ip address 144.0.22.3 255.255.255.0 secondary

ip address 172.16.9.1 255.255.255.0

ip directed-broadcast

no ip mroute-cache

half-duplex

ipx network 112

ipx type-20-propagation

!

interface Ethernet0/1

description MAINTENANCE TROMBAY WAN LINK

ip address 172.16.5.1 255.255.255.0 secondary

ip address 172.16.8.1 255.255.255.0 secondary

ip address x.0.x.x 255.255.255.0

ip directed-broadcast

no ip mroute-cache

half-duplex

ipx network 111

ipx type-20-propagation

!

interface Ethernet2/0

description WAN CONNECTIVITY FOR SALSETTE SAKI TECNOPOLIS BORIVALI

KALYAN

ip address 172.16.1.1 255.255.255.0 secondary

ip address 172.16.13.1 255.255.255.0 secondary

ip address x.x.x.x 255.255.255.0 secondary

ip address 172.16.29.1 255.255.255.0 secondary

ip address 172.16.7.1 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

half-duplex

!

interface Ethernet2/1

description TROMBAY SERVER WAN LINK

ip address 144.0.1.3 255.255.255.0

ip directed-broadcast

no ip mroute-cache

half-duplex

!

interface FastEthernet3/0

description PAREL MAHALAXMI BACKBAY WAN LINK

ip address x.x.x.x 255.255.255.0 secondary

ip address 172.16.20.1 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet3/1

description WAN LINK TO DHARAVI

ip address 172.16.10.2 255.255.255.0 secondary

ip address x.x.x.x 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

duplex auto

speed auto

!

router eigrp 172

redistribute static

network 144.0.0.0

network 172.16.0.0

!

router ospf 172

log-adjacency-changes

redistribute connected subnets

redistribute static

network 144.0.0.0 0.0.255.255 area 0

network 172.16.0.0 0.0.255.255 area 0

!

ip classless

ip route x.x.x.0 255.255.255.0 144.0.40.1

ip route x.x.x.0 255.255.255.0 172.16.9.4

ip route 172.16.2.0 255.255.255.0 144.0.51.1 permanent

ip route 172.16.3.0 255.255.255.0 144.0.51.1 permanent

ip route 172.16.4.0 255.255.255.0 144.0.51.1 permanent

ip route 172.16.11.0 255.255.255.0 172.16.13.6 permanent

no ip http server

!

logging 172.16.18.81

!

!

!

snmp-server engineID local xxxxx

snmp-server community public RO

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxxxx

login

!

4 REPLIES
Gold

Re: OSPF....Urgent

Try 'redistribute static subnets' instead of just 'redistribute static'.

Silver

Re: OSPF....Urgent

Can you post 'sh ip ospf database external 144.0.61.0 ' this will show if the network is getting in to the ospf database . If it is make sure your next hop is pingable

Gold

Re: OSPF....Urgent

You'll need the subnets keyword, and you will probably also need a default metric for the routes. So, try:

redistribute statics subnets

default-metric 10

Russ.W

New Member

Re: OSPF....Urgent

use redistribute connected and static with subnet keyword under ospf process

298
Views
0
Helpful
4
Replies