Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Ospf with ip unnumbered ?

Hello together,

we like to configure OSPF with ip unnumbered pt-to-pt interfaces.

If we do this at first sight it looks good, neighbor adjacency is established and the database is filled up, but no routes are in the routing table.

We recognized that if we perform an "sh ip ospf interface" that instead of the loopback ip address the address 0.0.0.0/30 is displayed for the particular interface.

If we configure the ip address directly to the physical interface everything works fine.

Is there an configuration issue with ip unnumberd and OSPF. Or is it a bug or not supported ?

Can someone provide a example configuration with OSPF using ip unnumbered feature ?

Thanx in advance.

1 REPLY
Gold

Re: Ospf with ip unnumbered ?

It should work fine....

First router:

!

interface FastEthernet0/1

ip address 208.0.0.11 255.255.255.0

....

!

interface Serial0/3

ip unnumbered FastEthernet0/1

!

router ospf 100

log-adjacency-changes

network 208.0.0.0 0.0.0.255 area 0

Second Router:

!

interface FastEthernet0/0

ip address 208.0.6.10 255.255.255.0

....

!

interface Serial0/2

ip unnumbered FastEthernet0/0

....

!

router ospf 100

log-adjacency-changes

network 208.0.6.0 0.0.0.255 area 0

redistribute connected subnets metric 10

And back on the first router:

2651B#sho ip route

....

O 208.0.9.0/24 [110/129] via 208.0.6.10, 00:00:06, Serial0/3

So, it's working fine here. Are the routes showing up in the local ospf database, when you do a show ip ospf data, followed by the type of route you're expecting? Could you post the ospf configuration, and the ospf database for the type of route the routes that are missing should be (in other words, show ip ospf data router, network, summary, or external)?

Russ.W

332
Views
0
Helpful
1
Replies
CreatePlease to create content