Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ospf

Dear all

i have a OSPF with multi zones my problem is the OSPF routing table is showing static routes even without mentioning "redistribute static" i tried to

increase the administative distance of static route but with no luck

i need the OSPF routing table not to show those static route

please help

tks

10 REPLIES
New Member

Re: ospf

Can you please post the static route and your entries under router ospf.

Re: ospf

Can you copy-paste sh run and sh ip route.

Silver

Re: ospf

you are mostlikely missing the metrics

try this

redistribute static metric x metric type 1 subnets

the metric X is what ever you wish the metric to be , metric-type 1 indicates that all the costs along the way will added to the metric . subnets will apply vlsm.

Bronze

Re: ospf

Do these static routes point to an interface, instead of to an address? If so, the routes are considered to be connected, not static, and will be advertised by OSPF if there is a network statement covering the destination.

HTH

Mark

Silver

Re: ospf

I did not read your problem correctly . I agree with Mark , This is most likely the problem

New Member

Re: ospf

A B

Main(cloude) <======> (s0/0) RT-1 (s0/3)<=======> (s0/0)RT-2

when the connection A is down the dial up of RT-1 work coz no Link to X.X.1.0 255.255.255.0 (no problem)

"now I need RT-2 to Dial up when connection A is down" , the dial up in RT-2 don't work because it see the route X.X.1.0 255.255.255.0 in OSPF route table

from rt-1 asyn int and consider the line up

how can i make RT-2 Dial up ?(i need RT-2 to connect to the cloude)

RT-1

=====

!

aaa new-model

!

!

aaa authentication login access group tacacs+ enable

aaa authentication enable default group tacacs+ enable

aaa session-id common

ip subnet-zero !

!

no ip domain lookup

!

ipx routing 00e0.b064.48b0

!

chat-script test "atdt790243"

chat-script name:verdundl word:qwert ">" "ppp default"

chat-script logrouter "" name: verdundl\r word:

qwert\r ">" "ppp default\r"

chat-script buprouter "" "ATDP 92,790242" TIMEOUT 60 "CONNECT"

chat-script multitech-mt1932zdx-v32 "" "ATZ"

chat-script bdialing TIMEOUT 35 "OK"

chat-script script dd2 "at" "ok" "l5"

chat-script verdundd "" "atdt 790242" TIMEOUT 60 "CONNECT"

chat-script ppplogin "" \r name: verdundl word: qwert

> "ppp negotiate"

chat-script tdialing "" "atdt790480" TIMEOUT 60 "CONNECT"

chat-script tdialing2 "" "atdt366560" TIMEOUT 60 "CONNECT"

!

!

!

interface Loopback0

ip address 71.71.71.71 255.255.255.0

!

interface FastEthernet0/0

ip address X.X.3.1 255.255.255.0

duplex auto

speed auto

no mop enabled

!

interface Serial0/0

description link to AB

ip address X..24.193.2 255.255.255.0

encapsulation ppp

no fair-queue

ppp authentication chap

!

interface FastEthernet0/1

ip address X..24.71.219 255.255.255.0

duplex auto

speed auto

ipx network 6271

!

interface Serial0/1

description LINK TO MAIN

bandwidth 64

ip address X.X.182.2 255.255.255.0

ip helper-address X.X.1.2

encapsulation ppp

ip ospf authentication-key 7

ipx network 62182

no keepalive

ignore-dcd

!

interface Serial0/2

no ip address

shutdown

!

interface Serial0/3

description link to rt-2

ip address x.23.22.1 255.255.255.0

encapsulation ppp

ipx network 2322

no fair-queue

ppp authentication chap

!

interface Async65

ip address X.24.6.71 255.255.255.0

encapsulation ppp

dialer in-band

dialer idle-timeout 30

dialer string 366560

dialer watch-group 1

dialer-group 1

async default routing

async mode interactive

no peer neighbor-route

no peer default ip address

keepalive 500

pulse-time 1

ppp authentication chap

!

router ospf 1

log-adjacency-changes

network X.X.0.0 0.0.255.255 area 1

network X.23.0.0 0.0.255.255 area 1

network X.24.0.0 0.0.255.255 area 1

!

ip http server

no ip classless

ip route X.X.1.0 255.255.255.0 Async65 150

ip route X.X.7.0 255.255.255.0 Async65 150

ip route X.X.121.0 255.255.255.0 Async65 150

ip route X.X.199.0 255.255.255.0 Async65 150

ip route 192.168.100.0 255.255.255.0 X.X.7.220 150

ip tacacs source-interface FastEthernet0/1

!

!

!

logging X.X.1.59

logging X.X.1.177

access-list 111 deny ospf any any

access-list 111 deny ip host X.24.6.71 any

access-list 111 permit ip any any

access-list 171 permit icmp host X.X.71.1 host X.X.1.2 access-list 171 permit udp host X.X.71.1 host X.X.1.2 access-list 1000 deny FFFFFFFF 0

dialer watch-list 1 ip X.X.1.0 255.255.255.0

dialer watch-list 1 delay connect 5

dialer-list 1 protocol ip list 111

!

!

!

tacacs-server host X.X.1.41

tacacs-server directed-request

tacacs-server key axaxaxax

line con 0

login authentication access

line aux 0

script dialer tdialing2

login authentication access

modem InOut

autohangup

stopbits 1

flowcontrol hardware

line vty 0 4

login authentication access

!

ntp clock-period 17179873

ntp server X.X.1.217

ntp server X.X.1.219

RT-2

====

!

aaa new-model

!

!

aaa authentication login access group tacacs+ enable

aaa authentication enable default group tacacs+ enable

aaa session-id common ip subnet-zero

!

!

no ip domain lookup

!

no ip bootp server

ipx routing 000c.31ea.be40

!

chat-script script dd2 "at" "ok" "l5"

chat-script verdun" "atdt 790242" TIMEOUT 60 "CONNECT"

chat-script ppplogin "" \r name: verdundl word: qwert

> "ppp negotiate"

chat-script test "atdt790243"

chat-script name:verdundl word:qwert ">" "ppp default"

chat-script logrouter "" name: verdundl\r word:

qwert\r ">" "ppp default\r"

chat-script buprouter "" "ATDP 92,790242" TIMEOUT 60 "CONNECT"

chat-script tdialing "" "atdt790242" TIMEOUT 60 "CONNECT"

chat-script tdialing2 "" "atdt366560" TIMEOUT 60 "CONNECT"

!

!

!

interface Loopback0

ip address X.25.22.219 255.255.255.0

!

interface FastEthernet0/0

ip address X.24.22.219 255.255.255.0

no ip route-cache

no ip mroute-cache

duplex auto

speed auto

!

interface Serial0/0

description link RT-1

ip address X.23.22.2 255.255.255.0

encapsulation ppp

no ip route-cache

no ip mroute-cache

ipx network 2322

no fair-queue

ppp authentication chap

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

interface Async65

ip address X.24.6.22 255.255.255.0

encapsulation ppp

dialer in-band

dialer idle-timeout 30

dialer string 366560

dialer watch-group 1

dialer-group 1

async default routing

async mode interactive

no peer default ip address

keepalive 500

pulse-time 1

!

router ospf 1

no log-adjacency-changes

network X.X.0.0 0.0.255.255 area 1

network X.23.0.0 0.0.255.255 area 1

network X.24.0.0 0.0.255.255 area 1

!

no ip http server

no ip classless

ip route X.X.1.0 255.255.255.0 Async65 150

ip route X.X.7.0 255.255.255.0 Async65 150

ip route X.X.121.0 255.255.255.0 Async65 150

ip route X.X.199.0 255.255.255.0 Async65 150

ip route X.24.1.0 255.255.255.0 Async65 150

ip route 192.168.100.0 255.255.255.0 X.X.7.220

ip tacacs source-interface FastEthernet0/0 !

!

!

logging X.X.1.177

access-list 111 deny ospf any any

access-list 111 deny ip host X.24.6.22 any

access-list 111 deny ip host X.X.1.177 any

access-list 111 permit ip any any

dialer watch-list 1 ip X.X.1.0 255.255.255.0 dialer watch-list 1 delay connect 5 dialer-list 1 protocol ip list 111 !

!

!

tacacs-server host X.X.1.41

tacacs-server directed-request

tacacs-server key axaxaxax

line con 0

login authentication access

line aux 0

script dialer tdialing2

login authentication access

modem InOut

transport input all

autohangup

stopbits 1

flowcontrol hardware

line vty 0 4

login authentication access

!

Silver

Re: ospf

Like Mark stated above on rtr 1 try redefine your static routes from

ip route X.X.1.0 255.255.255.0 Async65 150

ip route X.X.7.0 255.255.255.0 Async65 150

ip route X.X.121.0 255.255.255.0 Async65 150

ip route X.X.199.0 255.255.255.0 Async65 150

to

ip route X.X.1.0 255.255.255.0 next hop ip address 150

ip route X.X.7.0 255.255.255.0 next hop ip address 150

ip route X.X.121.0 255.255.255.0 next hop ip addrress 150

ip route X.X.199.0 255.255.255.0 nex hop ip address 150

When you define static routes that point out an interface and that interface is defined by a network statement the router thinks that all the subnets that are in the static routes are connected to that interface hence advertises them in the routing process.

New Member

Re: ospf

Hello,

I notice that X.X.1.0 does not have a network statement on RT-1. Therefore, when the RT-1 async comes up, I assume you are running OSPF on the async, and X.X.1.0 is learned over this. Is this correct?

If so, I would remove OSPF from the asyncs on RT-1 and RT-2 and run RIP or EIGRP on the async on RT-1 and RT-2, but filter the X.X.1.0 in RIP/EIGRP between RT-1 and RT-2 (or even better don't run the RIP/EIGRP it between them at all)

This should stop the X.X.1.0 learned by OSPF over the RT-1 async being sent to RT-2,

Regards

Ian

Bronze

Re: ospf

The statement "network x.x.0.0 0.0.255.255 area 1" does cover x.x.1.0.

Mark

New Member

Re: ospf

tks all for contribution

i think i will try EIGRP , i will go with ipotts

i will let u know

122
Views
0
Helpful
10
Replies
CreatePlease login to create content