Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ospf

I am new to ospf, I have always used eigrp, Is this simple to set up, and is it better than eigrp, are the areas equivalent to different autonomous systems like eigrp, can anyone show me a simple config say 3 different networks on 3 different routers ?

14 REPLIES
New Member

Re: ospf

This is a good starting point with examples. Have fun..-)

http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080094e9e.shtml

Rgds

E.

New Member

Re: ospf

I have had a read through this, my questions are, does each network subnet have its own area ? so the only way 2 routers would be in the same area are if they both had interfaces advertising the same subnet ?, can any one show me a sample config to help me on my way ?

thankyou

New Member

Re: ospf

Two routers to form an adjacency they have to run ospf on the interface enable with the network command under the ospf process, see example below. Both interfaces have to be in the same area. Note that it is not the router which belongs to an area but the interface. Therefore each router can have connections to multiple areas.

RTA#

hostname RTA

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

router ospf 10

network 10.1.1.1 0.0.0.0 area 0

RTF#

hostname RTF

interface Ethernet0

ip address 10.1.1.2 255.255.255.0

router ospf 10

network 10.1.1.2 0.0.0.0 area 0

New Member

Re: ospf

Firstly, why is there a 0.0.0.0 mask after the netowkr you want to advertise ? secondly, is the area same has say router eigrp 100 etc, would you define an area say as an office block, central office area 0, other offices area 1, 2 etc etc, also how would I join 2 different areas ?

New Member

Re: ospf

Ok,

first 0.0.0.0 is a wildcard. It specifies the i/f to run ospf. You could have used 10.1.1.0 0.0.0.255 would have achieved the same result. The OSPF area is not like eigrp 100. 100 is not an area as far as eigrp is concerned but the autonomous system number. Eigrp does not have the concept of areas. As for the rest of your questions Area-0 is always the backbone area. The ABR joins different areas to the backbone i.e Area1--ABR_router1---Area0---ABR_router2---Area-2, etc...

I suggest you get a book on OSPF in order to undertand how to design OSPF network. Basic OSPF configuration is relatively easy, but to design a good ospf network with summarization and use other features such as stub and nssa areas requires a bit more knowledge which not all can be explained in this forum. Best to read up and ask questions on things you don't understand.

HTH

E.

Bronze

Re: ospf

To add, the network commands tells the OSPF process which interfaces will run OSPF and what area they belong to. In the given example an inverse mask of 0.0.0.0 was used. The inverse mask when compared to the network address tells the router what interfaces to include in the OPSF. '0.0.0.0 255.255.255.255' would include all interfaces whilst 'network 10.1.1.2 0.0.0.0 area 0' includes only the interface configured with 10.1.1.2 ip address.

New Member

Re: ospf

can you please tell me what the areas are used for then, why do we have them ?,

also if for example i had a config like

eth1 ip 10.1.1.1 255.255.255.0

eth2 ip 172.19.45.1 255.255.255.0

router ospf 100

network 10.1.1.0 0.0.0.255 area 0

network 172.19.45.0 0.0.0.255 area 1

would this join 2 areas together, would this be a border router ABR config ?

New Member

Re: ospf

yes, this router is an abr and joins the two areas

New Member

Re: ospf

why would have have different areas, would each area say be a seperate building for example ?

New Member

Re: ospf

Can anyone eleborate on this ? im a little stuck

New Member

Re: ospf

Hey Carl,

When we dont want the routes in Area 1 to exchange the routes of Area 2 ,we create areas at that time.

regards

Ab

Re: ospf

Hi

And to add more if we divide our network in different area if there are route changes in a particular area it is going to be propogated in that particular area thus saving u r convergence time n bandwidth if u were having all the routers in the same area then it will increase u r cpu power memory etc.and it is very easy to isolate the problems.

Hope this helps

Mahmood

New Member

Re: ospf

so if I configure an abr, would both areas know about all the routes in each others area ?

Bronze

Re: ospf

It depends on your configuration. For the purpose of simplification let’s use standard areas.

Within an OSPF area flooding of Link State Advertisements (LSAs), database maintenance, and the SPF algorithm are used to construct and maintain a ‘map’ of the entire OSPF area. OPSF LSAs carry the routes and information relevant to the map. This is processor intensive so it is only done within an area. Inter-area routes are still exchanged but its behavior closely resembles a distant vector routing protocol using summary-type LSA.

To answer your question yes routes are exchanged between areas. Within an area the entire topology is maintained within the router. External area routes are received but the router only knows the advertising router or the next-hop address (very similar to distance vector routing).

HTH,

Ryan

157
Views
0
Helpful
14
Replies
CreatePlease login to create content