Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ospf

hello,

I have advertise the network 10.0.0.0 in OSPF, i am getting whole routes of my company. now i want to advertise only 10.3.0.0 whish is my Intranet network. following is my conf.( At present )

router ospf 1

log-adjacency-changes

network 10.0.0.0 0.255.255.255 area 10.1.1.1

!

ip classless

ip forward-protocol spanning-tree

ip route 0.0.0.0 0.0.0.0 10.3.1.10

ip route 0.0.0.0 0.0.0.0 10.3.1.11 100

i hv 20 vlans in core router, and all vlan's subnet is 10.3.0.0

Please suggest me

Thanks

11 REPLIES

Re: ospf

If you only want to advertise 10.3.0.0, try this:

router ospf 1

log-adjacency-changes

network 10.3.0.0 0.0.255.255 area 10.1.1.1

Hope it helps.

Steve

New Member

Re: ospf

hi steve,

Thanks for ur reply, one more doubt, i hv 6506 core switch and in that , 20 vlan's r configured. after advertising the network 10.3.0.0, shall configure the static route for each vlan. i mean pointing to each vlan gateway.and i vh 2 6506 core router for redundancy.

Thanks & Regards,

ciscobuddy

New Member

Re: ospf

Do you have your 20 vlans directly connected to your 6506 core switch? if your 6506 core switch know how to reach the vlans, you do not need to configure the static for each vlan because the routing bahave hop-by-hop, and if the netwrok 10.3.0.0 you advertised to the company can direct the traffic to the vlans of 10.3.0.0 to your core switch, then the 6506 will know how to foward the traffic.

New Member

Re: ospf

Hi Jeffrey,

Thanks Again, it means i hv to advertise my all vlans in the ospf

e.g. :- network 10.3.2.0 0.0.0.255 area 2

network 10.3.4.0 0.0.0.255 area 4 up to vlan's 20.

one more doubt i hv 5 locations, if i advertise only my vlan's network in my core then is it affect on other site users? i mean they can come to my network or not?

Thanks & Regards,

ciscobuddy

New Member

Re: ospf

If you only advertise your vlan's network, other site users can only know how to reach your network.From your provided information, I think your 20 vlans are directly connected to your core switches. so you need not configure any static routes for them.

In fact, you don't need to advertise all your vlans in the ospf, instead, you can only adverties a summary route that aggreate all your vlan exactly from the configuration i gave you above. After you advertised the summary, the traffic destinated to your 20 vlans will follow your summary route to your 6506 core switch and then because your 6506 core switch has the more specifc routes to the vlans, so the traffic shoud find their ways. In addition, when you do the summay, you should take care the summary will not covered other network than your 20 vlans.

New Member

Re: ospf

Hi Jeffery,

Thanks jeffery and sorry to trouble u again. now i understand..can u just check my final conf so i will implement this.

router ospf 1

log-adjacency-changes

network 10.3.0.0 0.0.255.255 area 10.1.1.1

redistribute connected subnets

summary-address 10.3.0.0 255.255.0.0

!

ip classless

ip forward-protocol spanning-tree

ip route 0.0.0.0 0.0.0.0 10.3.1.10

ip route 0.0.0.0 0.0.0.0 10.3.1.11 100

* 10.3.1.10 is my lease line router ip addres

* 10.3.1.11 is my VSAT router ip address

please guide me.

Thanks & Regards,

ciscobuddy

New Member

Re: ospf

Hi,

I need to know if the statement "network 10.3.0.0 0.0.255.255 area 10.1.1.1" will cover all the subnets that are directly connected to your core swtich. If it is so, all your vlans will be put into ospf with LSA type 1 or type 2, and you can not summary these types of route with command "summary-address ". So I think you should use "network 10.3.1.10 0.0.0.0 area 10.1.1.1" to put only your lease line interface into ospf and then use "redistribute the connected subnets" command to put all your vlans into ospf asLAS type 5, so you can use "summary-address" to summary the redistributed routes( your vlans) into one route.

New Member

Re: ospf

Hi Jeffery,

Thankx again, and sorry to trouble you. yes in 10.3.0.0 will cover all the subnets that r directly connected to core. for lease line VSAT is redundancy . so one more doubt from this above conf , if lease line is down then VSAT router will take over?

If u don't mind jeffery shall i send u the my core conf. but for this i need ur mail address. my mail id is milind_dc@yahoo.com

please help me.

Thanks & Regards,

Milind Tare

New Member

Re: ospf

Hi Milind,

I am pleasure to discuss the problem with you, my email is yfzhou@netease.com -or- jeffrey_zhou@macroview.com. You can send your config to me. I hope I can help you.

For your question, in the nomal case, if the lease line is down, the VSAT router should take over because the primary route to lease line will disapper and the floating static router will be installed in routing table. But you should also notice in some cases the primary static default will not disapper and the floating static will not be installed such as the interface and the line protocol not down (e.g looped, frame-relay ) when the connection broken.

In addition, you achieve the outbound traffic redundancy by using the the floating static, I think you need to advertise your network over the VSAT line to achieve the inbound traffic redundancy. If you only want to use the VSAT line as a backup line and not load balance, you can adjust the path cost of ospf to prevent your inbound traffic from going though the VSAT line.

In the end, you can also refer to the following doucment when you specify the next hop of the static route.

http://www.cisco.com/en/US/tech/tk648/tk365/technologies_tech_note09186a00800ef7b2.shtml

Regards

Jeffrey

New Member

Re: ospf

If you only want to advertise the network 10.3.0.0, you can try the following configuration:

router ospf 1

log-adjacency-changes

network "interface address of your WAN links" 0.0.0.0 area 10.1.1.1

redistribute connected subnets

summary-address 10.3.0.0 255.255.0.0

! I think you should replace the "interface address of your WAN links" with your actual IP address of your interface that connected to your company.

Regards

Jeffrey

New Member

Re: ospf

hi jeffrey,

Thanks for reply, Thanks for ur reply, one more doubt, i hv 6506 core switch and in that , 20 vlan's r configured. after advertising the network 10.3.0.0, shall configure the static route for each vlan. or i have to advertise each vlan subnet.

i am using /23 mask.

network 10.3.2.0 0.0.0.255 area 2 like this i hv to advertise for each vlan.

Thanks & Regards,

ciscobuddy

159
Views
0
Helpful
11
Replies
CreatePlease login to create content