Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Outbound Calls on E1 PRI Failing

Hi I am trying to set up outbound dialing on a Cisco 2600 with E1 Controler. It already accepts inbound calls but when I change the config to attempt out bound calls the call setup fails with the following q931 output:

ISDN Se1/0:15: TX -> SETUP pd = 8 callref = 0x0042

Bearer Capability i = 0x8890

Channel ID i = 0xA9838F

Called Party Number i = 0x80, '01883730839'

ISDN Se1/0:15: RX <- RELEASE_COMP pd = 8 callref = 0x804

Cause i = 0x82AC - Requested channel not available

Can anyone help with this one?

Thanks

Chris

5 REPLIES

Re: Outbound Calls on E1 PRI Failing

Looks like you are using euro-ISDN.

Check your configuration for the following:

isdn switch-type primary-net5 (or anything else if not euro-ISDN)

and controller config:

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-31

It could also be that you have not assigned a rotary-group or dialer-pool.

Issue a debug dialer to check for this.

New Member

Re: Outbound Calls on E1 PRI Failing

Thanks for your response. Enclosed in sthe config. I am on euro and the Primary rate line is up and accepting calls so config for the controller looks good. I have tried lagacy ddr and dialer profiles but same result. I have contaced the service provided and they have said there is no issue but doing a search on the internet for the ISDN disconnect error points to a problem with the telco's switch. I don't know what else to try at the moment.

Current configuration:

!

version 12.0

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname CSD_EPSOM

!

logging buffered 500000 debugging

aaa new-model

aaa authentication login default local

aaa authentication login console enable

aaa authentication login vty local

aaa authentication login dialin local

aaa authentication ppp default local

aaa authentication ppp dialin if-needed local

enable secret 5 $1$l1AB$uWgZ.leG.eI2UmOx1GmRV/

enable password 7 0820584B080A00

!

username admin password 7 0005070305480E57

username csd_maple password 7 1218111213180955

username csd_caterham password 7 050A120A205F4B58

username csd_oxted password 7 104F1D1C0404175A

username csd_merstham password 7 130403170A1F017B

username csd_horley password 7 011212015A18035E

username csd_lingfield password 7 094D5A0C18161243

ip subnet-zero

no ip finger

no ip domain-lookup

isdn switch-type primary-net5

call-history-mib retain-timer 500

call-history-mib max-size 500

!

!

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-16

!

!

interface Ethernet0/0

description Ethernet Link to LAN

ip address 195.106.51.254 255.255.255.0

ip broadcast-address 195.106.51.255

no ip directed-broadcast

no ip mroute-cache

!

interface Serial1/0:15

description connected to ESPCT Community Sites

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 0

isdn switch-type primary-net5

no cdp enable

!

interface Dialer0

description Dialer Group for ESPCT Comminty Sites

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer map ip 194.189.4.33 name CSD_OXTED 01883730839

dialer-group 1

no peer default ip address

no cdp enable

ppp authentication chap

ppp multilink

!

ip default-gateway 195.106.51.1

ip classless

ip route 0.0.0.0 0.0.0.0 195.106.51.1

ip route 194.189.4.0 255.255.255.224 194.189.4.1

ip route 194.189.4.1 255.255.255.255 Dialer0

ip route 194.189.4.32 255.255.255.224 194.189.4.33

ip route 194.189.4.33 255.255.255.255 Dialer0

ip route 194.189.4.64 255.255.255.224 194.189.4.65

ip route 194.189.4.65 255.255.255.255 Dialer0

ip route 194.189.4.96 255.255.255.224 194.189.4.97

ip route 194.189.4.97 255.255.255.255 Dialer0

ip route 194.189.4.128 255.255.255.224 194.189.4.129

ip route 194.189.4.129 255.255.255.255 Dialer0

ip route 194.189.4.160 255.255.255.224 194.189.4.161

ip route 194.189.4.161 255.255.255.255 Dialer0

ip route 194.189.4.192 255.255.255.224 194.189.4.193

ip route 194.189.4.193 255.255.255.255 Dialer0

!

dialer-list 1 protocol ip permit

snmp-server community public RO

!

line con 0

login authentication consoleport

transport input none

line aux 0

line vty 0 4

password 7 0005070305480E

login authentication vty

transport input telnet rlogin

!

no scheduler allocate

end

Cisco Employee

Re: Outbound Calls on E1 PRI Failing

You need to talk to your E1-PRI telco provider as the call is rejected by them. This may be because of E1/PRI line will never be provisioned for ougoing call.

Does outgoing call ever worked on this E1 line?

Here is the url which will help you to decode the isdn disconnect cause codes.

http://www.cisco.com/warp/public/129/isdn_disc_code.html

For isdn switch-type codes and vaules

http://www.cisco.com/univercd/cc/td/doc/product/software/ios113ed/dbook/disdn.htm

New Member

Re: Outbound Calls on E1 PRI Failing

Thanks for that. I may have found the issue. The telco originaly said that 15 timeslots were enabled today I have found out that only 12 timeslots are in fact enabled so will reconfigure and test. Would this casue the problem?

Cisco Employee

Re: Outbound Calls on E1 PRI Failing

Yes..You need to ask telco about how many channels and its numbers that they have configured to be in service for you. For dialout, router will start grabbing free channels from bottoms-up..So you need to configure

pri-group timeslots x-y command accordingly..

272
Views
0
Helpful
5
Replies