Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

cwy
New Member

Overload NAT Problem

Hello,

I configured NAT (overload mode) in the router, but there was problem about the connection. The error message and configuration are listed below. Please help.

Debug Error:

2w0d: NAT: address not stolen for 192.168.0.26, proto 1 port 256

2w0d: NAT: failed to allocate address for 192.168.0.26, list/map 1

2w0d: NAT: translation failed (A), dropping packet s=192.168.0.26 d=xxx.xxx.xxx.xxx

Configuration:

ip subnet-zero

!

interface Ethernet0/0

ip address 192.168.0.254 255.255.255.0

ip nat inside

full-duplex

!

interface Serial0/0

ip address 10.1.1.100 255.255.255.0

ip nat outside

encapsulation frame-relay IETF

no ip mroute-cache

frame-relay map ip 10.1.1.1 20

frame-relay map ip 10.1.1.2 21

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

ip address 10.2.2.2 255.255.255.252

frame-relay interface-dlci 200

!

router bgp 101

no synchronization

bgp log-neighbor-changes

neighbor 10.1.1.1 remote-as 100

!

ip nat pool nat 10.10.10.3 10.10.10.3 netmask 255.255.255.240

ip nat inside source list 1 pool nat overload

ip nat inside source static 192.168.0.1 10.10.10.1

ip nat inside source static 192.168.0.254 10.10.10.2

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.2

ip route 192.168.1.0 255.255.255.0 Serial0/0.1

no ip http server

ip pim bidir-enable

!

access-list 1 permit 192.168.0.0 0.0.0.255

Thanks!

Andy

3 REPLIES
New Member

Re: Overload NAT Problem

Andy,

How busy is the translation table? You may be overloading the interface. Check and see how many NAT entries you have allocated. (SH IP NAT TRANS). If you have a lot, consider increasing your POOL to include a few more IP's.

Jason

cwy
New Member

Re: Overload NAT Problem

Hello Jason,

So if I add few more ip address in the pool, the problem may also happen if the interface is overloading? Any suggestion on the no. of ip address in the pool?

Andy

New Member

Re: Overload NAT Problem

Andy

ip nat pool nat 10.10.10.3 10.10.10.3 netmask 255.255.255.240 -> is this correct?

Try changing your config to the following.

interface loopback0

ip address 10.10.10.3 255.255.255.255.

!

ip nat inside source list 1 interface Loopback0 overload

!

212
Views
4
Helpful
3
Replies
CreatePlease login to create content