Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

overriding cef in 6500

I am trying to use policy based routing to override the PFC in a 6500. Since the traffic is being switched via L3 on the PFC, PBR should be able to override it. But I am having no luck. I have a connection from a 6500 to two Foundry's and am trying to send traffic destined for 172.16.60&70.0 to MCN A and traffic destined for 172.16.80&90.0 to MCN B. Should be farily straight up but......

As you can see from below I have tried adjusting precedence, turning off cef on the interface itself (I know this does nothing, getting desperate here) Anyway I know I can screw with my OSPF to adjust the routing which will then sort things out, but I was under the impression from all that I have read that PBR would override this. Any help would be appreciated.

Here is the config

interface Vlan20

description VLAN CONNECTION TO PIX

ip address 172.16.20.6 255.255.255.0 alt ip address 172.16.20.7 255.255.255.0

no ip redirects

no ip route-cache cef

ip policy route-map 6090

standby 20 ip 172.16.20.5

interface Vlan101

description CONNECTION TO MCNA

ip address 172.16.40.3 255.255.255.248 alt ip address 172.16.40.4 255.255.255.248

ip access-group 101 out

no ip redirects

no ip route-cache cef

!

interface Vlan102

description CONNECTION TO MCNB

ip address 172.16.40.11 255.255.255.248 alt ip address 172.16.40.12 255.255.255.248

ip access-group 102 out

no ip redirects

no ip route-cache cef

access-list 120 permit ip any 172.16.60.0 0.0.0.255

access-list 120 permit ip any 172.16.70.0 0.0.0.255

access-list 130 permit ip any 172.16.80.0 0.0.0.255

access-list 130 permit ip any 172.16.90.0 0.0.0.255

route-map 6090 permit 10

match ip address 120

set ip precedence critical

set ip default next-hop 172.16.40.10

!

route-map 6090 permit 20

match ip address 130

set ip precedence critical

set ip default next-hop 172.16.40.2

1 REPLY
Bronze

Re: overriding cef in 6500

What is the software version on the supervisor and the msfc. Is it Sup2/msfc2

106
Views
0
Helpful
1
Replies
CreatePlease to create content