Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

PAD pb with Cisco2600 integrated modem

The problem is between a PDA , and the 2600 integrated modems ( 8-NM module ).

The PDA is calling a PSTN number of 2600 integrated modem connected to the pstn, the router is configured to work as an X25 PAD so when the PDA is supposed to connect to the asynchronous line of the router , automatically an X28 session is opened and the PDA makes an X25 call to the x25 address of an x25 device connected to the serial line of the router.

We tried, the configuration with an external modem connected to an asynchronous serial line of the router and every thing was Ok.

When we try this configuration with the integrated modems , the message modem failed to handle the call appears in the router console and an x28 debug shows that the router after many attempts connects to modem but it sends many strange caracters than it disconnects few times after.

The external modem used in this experiment is a v32bis/v32 modem and the pda is connected with a speed of 9600 bps or 300 bps usally with no error correction.

We configured the integrated modems of the 2600 with the their at commands , we set the modulation protocol as v32bis/v32 with no error correction no MNP and no v42bis but the the same problem occured.

8 REPLIES
Bronze

Re: PAD pb with Cisco2600 integrated modem

Can you post your config?

Do you have "modem autoconf type microcom" configured?

Community Member

Re: PAD pb with Cisco2600 integrated modem

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname PAD_SHELL

!

logging queue-limit 100

enable secret xxxxxx

!

username xxxx password xxxx

ip subnet-zero

!

!

no ip domain-lookup

ip host toto 2033 172.1.1.1

!

!

x29 profile cisco 1:1 2:0 3:0 4:1 5:0 6:16 7:4 8:0 9:0 10:0 12:0 13:0 14:0 15:00

x25 routing

!

!

!

interface Loopback0

ip address xxx.xxx.1.1 255.255.255.0

!

interface Loopback1

no ip address

!

interface FastEthernet0/0

ip address xxx.xxx.128.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address xxxx.1.1.2 255.255.255.0

encapsulation x25 dce

x25 address 100

x25 htc 1

x25 map ip 192.1.1.1 200

clockrate 64000

!

interface Serial0/1

physical-layer async

no ip address

encapsulation slip

!

interface Async65

no ip address

encapsulation slip

!

interface Async33

no ip address

encapsulation slip

!

ip classless

ip http server

!

no cdp run

x25 route .* interface Serial0/0

x25 host PAD_SHELL 300

!

line con 0

line 2

flush-at-activation

login

modem InOut

autocommand x28

terminal-type tty

transport input pad telnet

autoselect during-login

autoselect slip

stopbits 1

flowcontrol hardware

line 33

no flush-at-activation

modem InOut

rotary 33

autocommand x28

transport preferred none

transport input pad telnet

stopbits 1

line 34 40

flush-at-activation

line aux 0

modem InOut

autocommand x28

transport input pad

stopbits 1

line vty 0 4

password xxxxx

login

!

end

Bronze

Re: PAD pb with Cisco2600 integrated modem

Is it line 33 you're using?

Try

line 33

modem autoconfigure type microcom

If that doesn't help, what does debug confmodem say?

BTW, do you need "flush-at-activation" on this line?

hth

Herbert

Community Member

Re: PAD pb with Cisco2600 integrated modem

> Is it line 33 you're using?

Yes

> modem autoconfigure type microcom

We tried this command with no success !

> If that doesn't help, what does debug confmodem say?

We have a log file with debug output but it looks like there is no abnormal operation when establishing the call.

> BTW, do you need "flush-at-activation" on this line?

We tried both with a,d without "flush-at-activation" and we didn't changes

Bronze

Re: PAD pb with Cisco2600 integrated modem

>> If that doesn't help, what does debug confmodem say?

>We have a log file with debug output but it looks like there is no abnormal operation when establishing the call.

I suppose you mean "debug modem" output. But what does "debug confmodem" show?

Community Member

Re: PAD pb with Cisco2600 integrated modem

PAD_SHELL#deb modem

Modem control/process activation debugging is on

PAD_SHELL#deb confmodem

Modem Configuration Database debugging is on

PAD_SHELL#

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:00, reason (0x1) Lost Carrier

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:25, reason (0x1) Lost Carrier

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:25, reason (0x1) Lost Carrier

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:25, reason (0x1) Lost Carrier

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:30, reason (0x1) Lost Carrier

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:25, reason (0x1) Lost Carrier

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE 0

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:25, reason (0x1) Lost Carrier

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:25, reason (0x1) Lost Carrier

Community Member

Re: PAD pb with Cisco2600 integrated modem

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: TTY0: timer type 1 expired

1w2d: TTY0: Exec timer (continued)

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:25, reason (0x1) Lost Carrier

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:28, reason (0x1) Lost Carrier

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: TTY33: restoring DTR

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: Modem 1/0 Mcom: in modem state 'Retrain Initiated'

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:25, reason (0x1) Lost Carrier

1w2d: TTY33: DSR was dropped

1w2d: TTY33: Quickly dropping DTR

1w2d: tty33: Modem: READY->HASPROC

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: HASPROC->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

1w2d: Modem 1/0 Mcom: in modem state 'Dialing/Answering'

1w2d: Modem 1/0 Mcom: in modem state 'Incoming ring'

1w2d: Modem 1/0 Mcom: in modem state 'Waiting for Carrier'

1w2d: Modem 1/0 Mcom: in modem state 'Connected'

1w2d: Call Handle failed for Modem 1/0

1w2d: Modem 1/0 Mcom: CONNECT at 14400/14400(Tx/Rx), V32bis, Normal, None, Answer

1w2d: TTY33: DSR came up

1w2d: tty33: Modem: IDLE->(unknown)

1w2d: TTY33: EXEC creation

1w2d: TTY33: create timer type 1, 600 seconds

1w2d: TTY33: Line reset by "Exec"

1w2d: TTY33: Modem: (unknown)->HANGUP

1w2d: TTY33: no timer type 0 to destroy

1w2d: TTY33: destroy timer type 1

1w2d: TTY33: no timer type 3 to destroy

1w2d: TTY33: no timer type 4 to destroy

1w2d: TTY33: no timer type 10 to destroy

1w2d: TTY33: no timer type 2 to destroy

1w2d: TTY33: dropping DTR, hanging up

1w2d: tty33: Modem: HANGUP->IDLE

1w2d: Modem 1/0 Mcom: in modem state 'Disconnecting'

1w2d: Modem 1/0 Mcom: DISCONNECT, duration = 00:00:11, reason (0x9) DTR Drop:00:30

Autoselect Initial Wait

1w2d: Modem 1/0 Mcom: in modem state 'Idle'

1w2d: TTY33: restoring DTR

1w2d: TTY33: autoconfigure probe started

1w2d: TTY33: Modem command: --AT&F--

1w2d: TTY33: Modem configuration succeeded

1w2d: TTY33: Detected modem speed 9600

1w2d: TTY33: Done with modem configuration

Community Member

Re: PAD pb with Cisco2600 integrated modem

We finally solved the problem : we created a new modemcap with the parameters specific to european PoS and associated it to the modem line. We used the configuration presented in http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis3600/sw_conf/firmware/analogat.htm#26333

(PoS Support for Cisco 2600 Integarted Modems).

We only replaced "%b1200" in modemcap entry "misc" with "%b2400". Neither %b1200 or %b9600 worked.

Now the PoS establishes the connection properly and the screen displays "Connexion PAD OK". The connection is established with 2400 bps (Tx/Rx), V22bis, no error correction, no compression and Normal Mode (although the PoS documentation only mentions V32/V32bis).

180
Views
0
Helpful
8
Replies
CreatePlease to create content