Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PAD pb with Cisco2600 integrated modem

The problem is between a PDA , and the 2600 integrated modems ( 8-NM module ).

The PDA is calling a PSTN number of 2600 integrated modem connected to the pstn, the router is configured to work as an X25 PAD so when the PDA is supposed to connect to the asynchronous line of the router , automatically an X28 session is opened and the PDA makes an X25 call to the x25 address of an x25 device connected to the serial line of the router.

We tried, the configuration with an external modem connected to an asynchronous serial line of the router and every thing was Ok.

When we try this configuration with the integrated modems , the message modem failed to handle the call appears in the router console and an x28 debug shows that the router after many attempts connects to modem but it sends many strange caracters than it disconnects few times after.

The external modem used in this experiment is a v32bis/v32 modem and the pda is connected with a speed of 9600 bps or 300 bps usally with no error correction.

We configured the integrated modems of the 2600 with the their at commands , we set the modulation protocol as v32bis/v32 with no error correction no MNP and no v42bis but the the same problem occured.

2 REPLIES
New Member

Re: PAD pb with Cisco2600 integrated modem

Probably I think the problem is in your configuration. Configure the line for the respective internal modems in Cisco 2600 and also configure the line vty with password assigned.

Also check the following links for more information.

Configuring a Router as a PAD for XOT to an Asynchronous Host

http://www.cisco.com/warp/public/116/x25_pad_xot.html

Also you can check the following main link

http://www.cisco.com/pcgi-bin/Support/browse/psp_view.pl?p=Internetworking:X25

New Member

Re: PAD pb with Cisco2600 integrated modem

Hello

A password is already assigned to line vty. And we have used exactly the same first link you provided for our x25 configuration.

Here is the line configuration for the internal modem :

line 33

no flush-at-activation

modem InOut

rotary 33

autocommand x28

transport preferred none

transport input pad telnet

stopbits 1

The same line configuration works properly with an external modem. Even if there is an x25 configuration problem, a connection to the remote modem should be established first. Is this right ?

There is no way to change the speed of the serial line which appears as 14400 bps on modem debug and as 38400 bps with show modem conf. Besides, this serial line speed never appears in show line. Is this normal ? According to the documentation, similar problems (call failure after trainup ok) may appear when the serial line speed does not appear in show line.

Could there be compatibility problems between different modem vendors ?

Thank you in advance for your help.

113
Views
0
Helpful
2
Replies
CreatePlease login to create content