Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

parallel link between router

Hi, we have remote site with 1720 router connected to main office with 3640 router. I configured the routers to use two dialup link to add more speed because we are using oracle application in the remote office. but it become more slower..any help pls....

3 REPLIES

Re: parallel link between router

We will need some info on your config. Can you post a sh run of the 1720 and paste the relevant part of the 3640 config?

New Member

Re: parallel link between router

pls. check the config below...

3540 router:

ip cef

ip cef accounting load-balance-hash

interface Serial1/2

ip address 192.168.1.45 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

!

interface Serial1/3

ip address 192.168.1.49 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

!

!

router ospf 1

network 10.20.0.0 0.0.3.255 area 0

network 192.168.1.44 0.0.0.3 area 0

network 192.168.1.48 0.0.0.3 area 0

maximum-paths 2

!

ip classless

ip route 10.2.2.0 255.255.255.0 192.168.1.41

ip route 10.10.0.0 255.255.0.0 192.168.1.41

ip route 10.24.0.0 255.255.252.0 192.168.1.46

ip route 10.24.0.0 255.255.252.0 192.168.1.50

no ip http server

cisco 1720 router:

Current configuration : 1443 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RHEWH-RO

!

logging rate-limit console 10 except errors

enable secret 5 $1$BDiD$VFlV8a6on9Um4ki6S2UFJ1

enable password 7 030752180500

!

username JED-RO password 7 013E0F3768020921

memory-size iomem 25

ip subnet-zero

no ip finger

no ip domain-lookup

!

!

!

!

interface FastEthernet0

ip address 10.24.0.11 255.255.252.0

speed auto

!

interface Serial0

ip address 192.168.1.46 255.255.255.252

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer string 6823387

dialer-group 1

!

interface Serial1

ip address 192.168.1.50 255.255.255.252

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer string 6827636

dialer-group 1

!

router ospf 1

log-adjacency-changes

network 10.24.0.0 0.0.3.255 area 0

network 192.168.1.44 0.0.0.3 area 0

network 192.168.1.48 0.0.0.3 area 0

maximum-paths 2

!

ip classless

ip route 10.2.2.0 255.255.255.0 192.168.1.45

ip route 10.2.2.0 255.255.255.0 192.168.1.49

ip route 10.10.0.0 255.255.0.0 192.168.1.45

ip route 10.10.0.0 255.255.0.0 192.168.1.49

ip route 192.168.1.44 255.255.255.252 Serial0

ip route 192.168.1.48 255.255.255.252 Serial1

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

line aux 0

line vty 0 4

password 7 11241036241B0422

login

!

end

New Member

Re: parallel link between router

With your actual configuration you try to increase bandwidth by having two lines/two nexthops for the same ip-subnet. Indeed you will see two routes for the same network (for example 10.2.2.0). But load-sharing will occur in your config only per-destination traffic and not per-packet traffic: this means from the spokes (1720) there will always be used the same line for a specific server. This is the normal way of default fast-switching. You could change to process-switching (no ip route-cache). But this would be even slower because every IP-packet would go through several cpu cycles before forwarding.

Question: What kind of dial interfaces are serial1 and serial 0? Modems or ISDN? Rethink of ppp multilink with dialer pools or group-async interfaces in case of analog modems.

Good luck

William Boye, iuvandis GmbH

119
Views
0
Helpful
3
Replies