Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

%parser-4-badcfg unexpected end of configuration file

i tried to upgrade the ios on a mc3800 series router from 12.2 to 12.0 using an tftp server and now i get this error and at the prompt it now says Router (boot)> and whatever i do it will not correct itself i tried loading other ios versions and changing the config-reg ifto 0x2101 and then back to 0x2102 if i am missing something here please let me know maybe it is something simple this is the second one in a row today

MC3810 CPU restarted, RSR=E8000000, reason(s):,

loss of PLL,

checkstop reset

Router(boot)>

flashfs[8]: 1 files, 1 directories

flashfs[8]: 0 orphaned files, 0 orphaned directories

flashfs[8]: Total bytes: 16320000

flashfs[8]: Bytes used: 3526656

flashfs[8]: Bytes available: 12793344

flashfs[8]: flashfs fsck took 16 seconds.

flashfs[8]: Initialization complete.

1 REPLY
Silver

Re: %parser-4-badcfg unexpected end of configuration file

For the parser-4-badcfg error message, this indicates that the config may be incomplete or corrupt. Do a show run and verify that the config is correct, then do a "copy run start" to save the config to NVRAM.

If you are in boot mode now...Router(boot)>, from that prompt you can try doing the copy tftp flash again. You may want to download the IOS again from cisco's web site (possibly the file got corrupted when you downloaded it).

4723
Views
0
Helpful
1
Replies
CreatePlease login to create content