Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Passive-interface default on eigrp

When using the passive-interface default on a router, to advertise networks you have to use the no passive-interface Vlan20, for example, what happens to the following network statements, are they ignored? For example, I have the following config:

router eigrp 1

passive-interface default

no passive-interface vlan 1

no passive-interface vlan 2

no passive-interface vlan 3

no passive-interface vlan 4

network 10.0.0.0

network 172.0.0.0

no auto-summary

Will I still advertise the networks defined over the vlan interfaces?

Just curious.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Passive-interface default on eigrp

Mitch

It may help to logically separate some of the functions that EIGRP performs. EIGRP uses the network statemet(s) to identify what interfaces to include within the protocol. It looks at the address(es) and mask(s) and chooses every interface that matches. Having chosen those interfaces it knows what subnets (and networks) that it will advertise.

After EIGRP has chosen which interfaces to include it then decides which interfaces it will actively attempt to find neighbors and to exchange routing updates. Of all the interfaces chosen in the previous step it does not consider those that are passive to send hello messages. It sends hello messages on its active interfaces. If it recieves hello messages (with appropriate parameters) it then forms neighbor relationships and advertises its routes.

So to summarize: EIGRP will advertise all the subnets (and networks) on any interfaces that match the network statement(s) and it will advertise them to neighbors only on interfaces that are active.

HTH

Rick

4 REPLIES
Hall of Fame Super Silver

Re: Passive-interface default on eigrp

Mitch

It may help to logically separate some of the functions that EIGRP performs. EIGRP uses the network statemet(s) to identify what interfaces to include within the protocol. It looks at the address(es) and mask(s) and chooses every interface that matches. Having chosen those interfaces it knows what subnets (and networks) that it will advertise.

After EIGRP has chosen which interfaces to include it then decides which interfaces it will actively attempt to find neighbors and to exchange routing updates. Of all the interfaces chosen in the previous step it does not consider those that are passive to send hello messages. It sends hello messages on its active interfaces. If it recieves hello messages (with appropriate parameters) it then forms neighbor relationships and advertises its routes.

So to summarize: EIGRP will advertise all the subnets (and networks) on any interfaces that match the network statement(s) and it will advertise them to neighbors only on interfaces that are active.

HTH

Rick

New Member

Re: Passive-interface default on eigrp

I have a question that builds upon the (excellent) explanation you've provided....

In most every configuration example I've seen on Cisco's website or elsewhere, the EIGRP network statements are defined to match the subnet of the interface, not just the interface IP itself. For example:

interface FastEthernet0/0

ip address 192.168.10.1 255.255.255.0

router eigrp 123

network 192.168.10.0 0.0.0.255

If the network statement is just used to select which interfaces EIGRP will include based on interface IP address, why not specify the exact IP of the interface:

interface FastEthernet0/0

ip address 192.168.10.1 255.255.255.0

router eigrp 123

network 192.168.10.1 0.0.0.0

Is there any reason (historical, useful, traditional, whatever) that it seems to always be specified to match the subnet of the interface instead of the interface IP? I've wondered about this for a while, and figured it's time to ask someone.... :)

Thanks!

-Mason

Purple

Re: Passive-interface default on eigrp

Hi Mason,

There is some historical reasoning here. Until IOS release 12.0(4)T, you could not specify a wildcard mask when configuring the 'network' statement for EIGRP. In fact, the 'network' statement would only accept classful (i.e. major) networks at that time. So the ability to add a wildcard mask has been a relatively recent invention.

However, there is absolutely no problem with using a '0.0.0.0' wildcard in order to limit the network statement to a single IP address. From a convenience perspective, though, people tend to use a wildcard mask that reflects the actual subnet mask used on the interface. Either way is perfectly acceptable.

Now, if you are using a protocol such as OSPF, the wildcard mask becomes a bit more significant. The following link describes why that is so:

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009405a.shtml

Hope that helps - pls do rate the post if it does.

Paresh

New Member

Re: Passive-interface default on eigrp

Yep, that's exactly what I was looking to find.

I've come to prefer controlling the routing environment very specifically, and I always have the feeling that matching based on subnets leaves me open to accidentally enabling something I didn't mean to.

So thanks for letting me know that it's ok to use the '0.0.0.0' wildcard in eigrp and I'm not losing anything as a result.

-Mason

7611
Views
9
Helpful
4
Replies