cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
276
Views
0
Helpful
2
Replies

PB compression

lfere
Level 1
Level 1

When i do the following command sh ip int dialer 0 I receive the following message : tcp header compression is enabled but not compressing

rt102#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname rt102

!

!

username rt102 password 0 routeur

!

!

!

!

ip subnet-zero

ip cef

!

isdn switch-type basic-net3

isdn voice-call-failure 0

!

!

controller E1 2/0

!

!

!

!

interface Loopback0

ip address 199.0.97.32 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0/0

ip address 76.135.0.32 255.254.0.0

no ip directed-broadcast

shutdown

full-duplex

!

interface BRI1/0

no ip address

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression

dialer rotary-group 0

isdn switch-type basic-net3

isdn sending-complete

!

interface BRI1/1

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/2

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/3

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/4

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/5

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/6

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/7

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface FastEthernet2/0

ip address 199.0.81.30 255.255.255.0

no ip directed-broadcast

speed 10

half-duplex

!

interface Dialer0

ip address 199.0.99.32 255.255.255.0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression

ip tcp compression-connections 100

dialer in-band

dialer map ip 199.0.99.30 name rt100 broadcast 22200098

dialer load-threshold 1 either

dialer-group 1

ppp multilink

!

router ospf 1

router-id 199.0.97.32

redistribute connected

network 199.0.99.0 0.0.0.255 area 0

!

ip classless

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 3600 0

transport input none

line aux 0

line vty 0 4

login

!

end

rt102#

rt100#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname rt100

!

!

username rt100 password 0 routeur

!

!

!

!

ip subnet-zero

ip cef

!

isdn switch-type basic-net3

isdn voice-call-failure 0

!

!

!

!

!

interface Loopback0

ip address 199.0.97.30 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0/0

ip address 76.135.0.30 255.254.0.0

no ip directed-broadcast

shutdown

full-duplex

!

interface BRI1/0

no ip address

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression

dialer rotary-group 0

isdn switch-type basic-net3

isdn sending-complete

!

interface BRI1/1

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/2

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/3

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/4

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/5

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/6

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/7

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface FastEthernet2/0

ip address 199.0.80.30 255.255.255.0

no ip directed-broadcast

duplex auto

speed auto

!

interface Dialer0

ip address 199.0.99.30 255.255.255.0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression

ip tcp compression-connections 100

dialer in-band

dialer map ip 199.0.99.32 name rt102 broadcast 22200099

dialer load-threshold 1 either

dialer-group 1

ppp multilink

!

router ospf 1

router-id 199.0.97.30

redistribute connected

network 199.0.99.0 0.0.0.255 area 0

!

ip classless

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 3600 0

transport input none

line aux 0

line vty 0 4

login

!

end

rt100#

2 Replies 2

thisisshanky
Level 11
Level 11

HI,

I just tested this on two of my routers.

One was running IOS version 12.0(7)T2 (R3). and the other running, 12.0(2)XC2 (R2). I enabled tcp header compression on the physical bri interface (you have it on the dialer, since you are using dialer profiles.)

On R3, show ip int bri 0/0 was displaying as.... follows.

TCP/IP header compression is enabled and not compressing

On R2, show ip int bri 0/0 was displaying as .....follows.

TCP/IP header compression is enabled and compressing

So one end was showing it as enabled and working, while the other end was showing it as enabled, but not working.

But when i issued a telnet from R3 to R2 and vice versa, the statistics of TCP header compression on both routers are as follows.

R3>sh ip tcp header-compression

TCP/IP header compression statistics:

Interface BRI0/0:

Rcvd: 0 total, 0 compressed, 0 errors

0 dropped, 0 buffer copies, 0 buffer failures

Sent: 0 total, 0 compressed,

0 bytes saved, 0 bytes sent

Connect: 16 rx slots, 16 tx slots, 0 long searches, 0 misses

Interface BRI0/0:1:

Rcvd: 32 total, 30 compressed, 0 errors

0 dropped, 0 buffer copies, 0 buffer failures

Sent: 28 total, 26 compressed,

832 bytes saved, 293 bytes sent

3.83 efficiency improvement factor

Connect: 16 rx slots, 16 tx slots, 2 long searches, 2 misses

93% hit ratio, five minute miss rate 0 misses/sec, 0 max

Interface BRI0/0:2:

Rcvd: 0 total, 0 compressed, 0 errors

0 dropped, 0 buffer copies, 0 buffer failures

Sent: 0 total, 0 compressed,

0 bytes saved, 0 bytes sent

Connect: 16 rx slots, 16 tx slots, 0 long searches, 0 misses

and on R2

there is no output for sh ip tcp header compression command.

Probably this could be a bug in these IOSes, and also I think, output varies from IOS to IOS.

Shanky

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

thisisshanky
Level 11
Level 11

I found a bug which might be related to my previous reply.

Let us know what is the IOS you are running on each router.

The bug id is CSCdk38062 -

Bug description - show ip tcp header-compression counters not updated on dialer intfs.

This could be a reason why, my router R2 was not showing the counters properly, even though header compression was working either ways.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: