Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

PBR and next-hop

Hello,

I want to route all traffic received from a subnet (for example, 192.168.10.0/24) through a particular interface (FastEthernet0/1). For this reason, I've implemented a route map with "set ip next-hop":

interface FastEthernet0/0
ip address 192.168.200.1 255.255.255.0

!
interface FastEthernet0/1
ip address 192.168.250.1 255.255.255.0
!
interface FastEthernet1/0
ip address 192.168.100.2 255.255.255.0
ip policy route-map MAPA_RUTA
!
ip route 0.0.0.0 0.0.0.0 192.168.200.2
ip route 192.168.1.0 255.255.255.0 192.168.100.1
ip route 192.168.10.0 255.255.255.0 192.168.100.1
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
!
route-map MAPA_RUTA permit 10
match ip address 100
set ip next-hop 192.168.250.2

But I have a problem. If the FastEthernet0/1 goes down, I don't want the traffic from 192.168.10.0/24 to be routed though FastEthernet0/0 (as indicated by the default route). Is there any alternative to "set ip next-hop" to do it? I've tried "set ip default next-hop" but I have a similar problem.

Best regards and thanks in advance,

César.

3 REPLIES
Cisco Employee

Re: PBR and next-hop

Hi Cesar,

But I have a problem. If the FastEthernet0/1 goes down, I don't want the traffic from 192.168.10.0/24 to be routed though FastEthernet0/0 (as indicated by the default route).

You donot want it routed though fa0/0, so you want it be dropped?

Community Member

Re: PBR and next-hop

Hi Lei,

Yes, I want it be dropped. I don't want this traffic to pass though the router attached to fa0/0. If there is no alternative to the "set ip next-hop" with route maps, I've thought to using an ACL in the fa0/0.

Best Regards.

Cisco Employee

Re: PBR and next-hop

Hi Cesar,

You can change your route-map to


route-map MAPA_RUTA permit 10
match ip address 100
set ip next-hop 192.168.250.2

set interface null0

HTH,

Lei Tian

1291
Views
0
Helpful
3
Replies
CreatePlease to create content