Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

pbs dans configuration H323 de mon GK

Bonjour,

Avec la version 12.1(5)XM7 H323 installée sur mon routeur Cisco, j'essaie de faire les tests suivants :

créer deux zones

configurer le GK pour qu'il dise aux clients de chaque zone de faire une connexion directe en cas d'appel interzone

configurer le GK pour qu'il dise aux clients de chaque zone d'utiliser le proxy pour une connexion inter-zone

pour cela, j'essaie de définir deux zones de tests, chacune limitée à une seule machine.

chaque zone accepte une machine et refuse les autres

voici la configuration :

gatekeeper

zone local toulon univ-tln.fr

zone local toto toto.fr

no zone subnet toulon default enable

zone subnet toulon 10.1.65.41/32 enable

no zone subnet toto default enable

zone subnet toto 10.1.65.216/32 enable

no shutdown

Donc la zone toulon accepte la machine 10.1.65.41 et refuse les autres, la zone toto accepte la machine 10.1.65.216 et refuse les autres. Tout cela est correctement compris, d'ailleurs :

conference#show gatekeeper zone status

GATEKEEPER ZONES

================

GK name Domain Name RAS Address PORT FLAGS

------- ----------- ----------- ----- -----

toulon univ-tln.fr 10.1.65.246 1719 LS

BANDWIDTH INFORMATION (kbps) :

Maximum total bandwidth : unlimited

Current total bandwidth : 0

Maximum interzone bandwidth : unlimited

Current interzone bandwidth : 0

Maximum session bandwidth : unlimited

SUBNET ATTRIBUTES :

subnet 10.1.65.41/255.255.255.255 : (Enabled)

All Other Subnets : (Disabled)

PROXY USAGE CONFIGURATION :

Inbound Calls from all other zones :

to terminals in local zone toulon : use proxy

to gateways in local zone toulon : do not use proxy

Outbound Calls to all other zones :

from terminals in local zone toulon : use proxy

from gateways in local zone toulon : do not use proxy

toto toto.fr 10.1.65.246 1719 LS

BANDWIDTH INFORMATION (kbps) :

Maximum total bandwidth : unlimited

Current total bandwidth : 0

Maximum interzone bandwidth : unlimited

Current interzone bandwidth : 0

Maximum session bandwidth : unlimited

SUBNET ATTRIBUTES :

subnet 10.1.65.216/255.255.255.255 : (Enabled)

All Other Subnets : (Disabled)

PROXY USAGE CONFIGURATION :

Inbound Calls from all other zones :

to terminals in local zone toto : use proxy

to gateways in local zone toto : do not use proxy

Outbound Calls to all other zones :

from terminals in local zone toto : use proxy

from gateways in local zone toto : do not use proxy

Je veux donc maintenant configurer :

soit une interface avec une adresse IP normale et une secondary, chacunes pour qu'elles soient proxy pour une zones

soit chacune des interfaces du routeur pour que chacune soit proxy pour chaque zone

J'ai déjà la configuration suivante :

interface FastEthernet0/0

ip address 10.1.65.246 255.255.0.0

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

h323 interface

h323 h323-id conference@univ-tln.fr

h323 gatekeeper id toulon ipaddr 10.1.65.246

h323 t120 bypass

Et là, voici ce qui se passe quand j'essaie de définir un proxy pour une autre zone :

conference(config)#int faste 0/0

conference(config-if)#ip address 10.1.65.247 255.255.0.0 secondary

conference(config-if)#h323 gatekeeper id toto ipaddr 10.1.65.247

Maximum number (1) of configurable (Gatekeeper(s)) exceeded.

conference(config-if)#no ip address 10.1.65.247 255.255.0.0 secondary

conference(config-if)#int fast 0/1

conference(config-if)#no shut

conference(config-if)#ip address 10.1.65.247 255.255.0.0

conference(config-if)#h323 interface

Maximum number (1) of configurable (Multimedia Interface(s)) exceeded.

conference(config-if)#^Z

conference#

Quels sont ces Maximum que je rencontre ?

Et s'il y a moyen de faire autrement pouvez-vous me dire quelle doit-être ma configuration pour :

lorsqu'un client d'une zone appelle un client de la même zone avec son H323-ID enregistré le GK lui réponde avec l'adresse IP du client à atteindre (ça, j'ai testé, ça marche)

lorsqu'un client d'une zone appelle une machine non enregistrée sur le GK, celui-ci renvoie le client sur le proxy et passe l'appel

Par ailleurs, comment faire pour qu'un client externe, non client du GK (normalement) puisse appeller un poste interne en utilisant le proxy. C'est pour résoudre ce problème que je tentais notamment mes tests avec deux zones, une pour les postes internes, l'autre pour accepter les postes externes avec des plages d'adresses IP listées.

Ci-dessous, ma configuration au complet :

Current configuration : 1253 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service dhcp

!

hostname conference

!

boot system flash:c3620-ix-mz.121-5.XM7H323.bin

logging rate-limit console 10 except errors

no logging console

enable secret 5 $1$/Cp9$8Y6vBGDBlAgx2fDFmUN.P/

!

ip subnet-zero

no ip routing

!

!

no ip finger

!

!

!

!

!

!

!

!

proxy h323

!

interface FastEthernet0/0

ip address 10.1.65.246 255.255.0.0

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

h323 interface

h323 h323-id conference@univ-tln.fr

h323 gatekeeper id toulon ipaddr 10.1.65.246

h323 t120 bypass

!

interface FastEthernet0/1

no ip address

no ip route-cache

no ip mroute-cache

duplex auto

speed auto

!

ip classless

no ip http server

!

!

dial-peer cor custom

!

!

!

!

gatekeeper

zone local toulon univ-tln.fr

zone local toto toto.fr

no zone subnet toulon default enable

zone subnet toulon 10.1.65.41/32 enable

no zone subnet toto default enable

zone subnet toto 10.1.65.216/32 enable

no shutdown

!

!

line con 0

exec-timeout 0 0

transport input none

speed 115200

line aux 0

line vty 0 4

password Avalon

login

!

end

Cordialement,

1 REPLY

Re: pbs dans configuration H323 de mon GK

Moderator mote: In an effort to widen the possible audience for this question, I have had this post translated from French to English using http://http://babelfish.altavista.com/tr as follows:

-- translation begin --

Hello, With version 12.1(5)XM7 H323 installed on my router Cisco, I try to make the following tests: to create two zones to configure the GK so that he tells the customers of each zone to make a direct connection in the event of call interzone configure the GK so that he tells the customers of each zone to use the proxy for a connection inter-zone for that, I try to define two zones of tests, each one limited to only one machine. each zone accepts a machine and refuses the others here the configuration:

gatekeeper

zone local toulon univ-tln.fr

zone local toto toto.fr

no zone subnet toulon default enable

zone subnet toulon 10.1.65.41/32 enable

no zone subnet toto default enable

zone subnet toto 10.1.65.216/32 enable

no shutdown

Thus the Toulon zone accepts machine 10.1.65.41 and refuses the others, the zone louse accepts machine 10.1.65.216 and refuses the others. All that is correctly included/understood, moreover:

conference#show gatekeeper zone status

GATEKEEPER ZONES

================

GK name Domain Name RAS Address PORT FLAGS

------- ----------- ----------- ----- -----

toulon univ-tln.fr 10.1.65.246 1719 LS

BANDWIDTH INFORMATION (kbps) :

Maximum total bandwidth : unlimited

Current total bandwidth : 0

Maximum interzone bandwidth : unlimited

Current interzone bandwidth : 0

Maximum session bandwidth : unlimited

SUBNET ATTRIBUTES :

subnet 10.1.65.41/255.255.255.255 : (Enabled)

All Other Subnets : (Disabled)

PROXY USAGE CONFIGURATION :

Inbound Calls from all other zones :

to terminals in local zone toulon : use proxy

to gateways in local zone toulon : do not use proxy

Outbound Calls to all other zones :

from terminals in local zone toulon : use proxy

from gateways in local zone toulon : do not use proxy

toto toto.fr 10.1.65.246 1719 LS

BANDWIDTH INFORMATION (kbps) :

Maximum total bandwidth : unlimited

Current total bandwidth : 0

Maximum interzone bandwidth : unlimited

Current interzone bandwidth : 0

Maximum session bandwidth : unlimited

SUBNET ATTRIBUTES :

subnet 10.1.65.216/255.255.255.255 : (Enabled)

All Other Subnets : (Disabled)

PROXY USAGE CONFIGURATION :

Inbound Calls from all other zones :

to terminals in local zone toto : use proxy

to gateways in local zone toto : do not use proxy

Outbound Calls to all other zones :

from terminals in local zone toto : use proxy

from gateways in local zone toto : do not use proxy

Je veux donc maintenant configurer :

either an interface with an address IP normal and a secondary, chacunes so that they are proxy for zones or each interface of the router so that each one or proxy for each zone I have already the following configuration:

interface FastEthernet0/0

ip address 10.1.65.246 255.255.0.0

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

h323 interface

h323 h323-id conference@univ-tln.fr

h323 gatekeeper id toulon ipaddr 10.1.65.246

h323 t120 bypass

And there, here what occurs when I try to define a proxy for another zone:

conference(config)#int faste 0/0

conference(config-if)#ip address 10.1.65.247 255.255.0.0 secondary

conference(config-if)#h323 gatekeeper id toto ipaddr 10.1.65.247

Maximum number (1) of configurable (Gatekeeper(s)) exceeded.

conference(config-if)#no ip address 10.1.65.247 255.255.0.0 secondary

conference(config-if)#int fast 0/1

conference(config-if)#no shut

conference(config-if)#ip address 10.1.65.247 255.255.0.0

conference(config-if)#h323 interface

Maximum number (1) of configurable (Multimedia Interface(s)) exceeded.

conference(config-if)#^Z

conference#

Which are these Maximum which I meet? And if there is average to make differently can you say to me which must-to be my configuration for: when a customer of a zone calls a customer of the same zone with his recorded H323-id the GK answers him with address IP of the customer to reach (that, I tested, it goes) when a customer of a zone calls a machine not recorded on the GK, this one returns the customer on the proxy and passes the call In addition, how to make so that an external customer, not customer of the GK (normally) can appeller a station interns by using the proxy. It is to solve this problem that I tried in particular my tests with two zones, for the internal mails, the other to accept the external stations with beaches of listed IP addresses. Below, my complete configuration:

Current configuration : 1253 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service dhcp

!

hostname conference

!

boot system flash:c3620-ix-mz.121-5.XM7H323.bin

logging rate-limit console 10 except errors

no logging console

enable secret 5 -- moderator edit --

!

ip subnet-zero

no ip routing

!

!

no ip finger

!

!

!

!

!

!

!

!

proxy h323

!

interface FastEthernet0/0

ip address 10.1.65.246 255.255.0.0

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

h323 interface

h323 h323-id conference@univ-tln.fr

h323 gatekeeper id toulon ipaddr 10.1.65.246

h323 t120 bypass

!

interface FastEthernet0/1

no ip address

no ip route-cache

no ip mroute-cache

duplex auto

speed auto

!

ip classless

no ip http server

!

!

dial-peer cor custom

!

!

!

!

gatekeeper

zone local toulon univ-tln.fr

zone local toto toto.fr

no zone subnet toulon default enable

zone subnet toulon 10.1.65.41/32 enable

no zone subnet toto default enable

zone subnet toto 10.1.65.216/32 enable

no shutdown

!

!

line con 0

exec-timeout 0 0

transport input none

speed 115200

line aux 0

line vty 0 4

password Avalon

login

!

end

Cordially,

--translation end--

118
Views
0
Helpful
1
Replies
CreatePlease to create content