Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PC access over isdn and router to Internet

Hello, I have a simple task. Connect a PC over a cisco2611 BRI to a ISP.

Ip addresses: pc 10.10.10.2 , eth0/0 10.10.10.1, dialer1 ip address negoiated.

DNS Server address is 194.158.230.53 (known). ip routing on PC enabled.

Ping is always to this ip address. Ping from Router console to DNS is ok.

Ping from PC to dialer1 (if it is up) ipaddress is ok. But ping from PC to DNS ip address is not ok. Deb ip packets shows message: unroutable.

static route is defined.

Here is the configuration.

Thanks for help to anybody. Ruedi

sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco2611

!

enable secret 5 $1$rO0v$Cqy2Bxtqbtz4xuXttzeLQ/

!

ip subnet-zero

no ip domain-lookup

isdn switch-type basic-net3

!

!

!

interface Ethernet0/0

description connected to EthernetLAN

ip address 10.10.10.1 255.0.0.0

no ip directed-broadcast

!

interface Serial0/0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

!

interface BRI0/0

description connected to Internet

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Ethernet0/1

no ip address

no ip directed-broadcast

shutdown

!

interface Dialer1

description connected to Internet

ip address negotiated

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer string 015550065

dialer hold-queue 10

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname sunrise

ppp chap password 7 130305170E1F11382D

ppp pap sent-username sunrise password 7 121F1712171819162C

!

router rip

version 2

redistribute static metric 1

passive-interface Dialer1

network 10.0.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

dialer-list 1 protocol ip permit

snmp-server community public RO

!

line con 0

exec-timeout 0 0

password 7 070A2F4D

login

transport input none

line aux 0

line vty 0 4

password 7 0824424F

login

!

no scheduler allocate

end

Cisco2611#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C 10.0.0.0/8 is directly connected, Ethernet0/0

S* 0.0.0.0/0 is directly connected, Dialer1

Cisco2611#

________________________________________

3 REPLIES
New Member

Re: PC access over isdn and router to Internet

Hi,

the answere is very simple. Because you use no official IP address in your ethernet (10.0.0.0) which is not routed in the internet it didn't work.

You have to configure network address translation (NAT) on your router,

so that the source IP form your PC is translated into the serial IP you get

from the provider.

How to configure NAT check this URL on CCO:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml

regards Ulrich Marzoli

www.netaid.de

New Member

Re: PC access over isdn and router to Internet

Hello Ulrich,

Thanks for message. In the examples are ipaddresses for serial interface.

But what's if there is DHCP over dialer interface. Is there any way to configure nat. Or could I set 'interfacename' instead of an ip address ?

Ruedi

New Member

Re: PC access over isdn and router to Internet

Hi Ulrich,

Problem is solved. Found solution with command

ip nat inside source list 10 interface dialer 1 overload

access-list 10 permit 10.10.10.2 (my pc)

Regards Ruedi

86
Views
0
Helpful
3
Replies