Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PIM and NAT conflict ?

Hi all !

I use a CISCO 1720/IP plus router for ISDN dialup connection to Internet. I implemented NAT for the LAN and everything works fine when we navigate to Internet...

I want to use a multicast (PIM) application to a PC directly connected to Ethernet. I setup the multicast routing, but the application didn't work... I checked that problem with the ISP technicians, who claimed that there should be a conflict between PIM and NAT. Is that true? Is there any mistake in the following configuration?

-----------------------------------

Cisco1720#sh conf

Using 1540 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco1720

!

memory-size iomem 25

ip subnet-zero

!

ip multicast-routing

!

isdn switch-type basic-net3

!

interface BRI0

description connected to Internet

ip address negotiated

ip nat outside

ip pim nbma-mode

ip pim sparse-mode

encapsulation ppp

no ip route-cache

ip igmp join-group 225.6.10.10

no ip mroute-cache

no keepalive

dialer idle-timeout 300 either

dialer string 89625xxxxx

dialer hold-queue 10

dialer-group 1

isdn switch-type basic-net3

no peer default ip address

no fair-queue

ppp authentication chap callin

ppp chap hostname

ppp chap password

!

interface FastEthernet0

description *** connected to EthernetLAN ***

ip address 10.10.1.199 255.255.255.0

ip nat inside

ip pim dense-mode

speed auto

!

ip nat inside source list 1 interface BRI0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 BRI0 permanent

no ip http server

!

access-list 1 permit 10.10.1.0 0.0.0.255

!

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

snmp-server community public RO

snmp-server enable traps tty

!

password xxxxx

login

line aux 0

line vty 0 4

password xxxxx

login

!

no scheduler allocate

end

-----------------------------------------

Thanks in advance,

George.

1 REPLY
VIP Purple

Re: PIM and NAT conflict ?

Hello George,

I think you have to configure the same PIM mode on both interfaces, first of all (I would use pim sparse-dense mode on both interfaces). Second, I think you need to have an RP configured. NAT and PIM shouldn´t be an issue (the attached link might provide some more info on NAT and PIM).

http://www.cisco.com/en/US/partner/tech/tk648/tk361/technologies_tech_note09186a008009474d.shtml

Regards,

Georg

107
Views
0
Helpful
1
Replies