Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ping problem

hi

I have one 2950 switch ,that I have its interface ip address. I can ping my pc but th problem is,i can't ping the switch from my pc.

first ,I want to change the ios & upgrade the ios ,but I can't use tftp .could you pls help me?

thanks

6 REPLIES

Re: ping problem

Please paste the configuration of the switch.

Your 2950 is a layer 2 switch and you can have only one Vlan interface ( SVI-Layer3 which is used to manage the switch only ) up at any given time. Make sure that your PC is in the same vlan interface which you have given the IP. For example..

if your int vlan 1 is up and have any ip on it.. your PC should be in the same vlan to communicate with the switch for upgrade the IOS.

HTH,

regards,

-amit singh

Community Member

Re: ping problem

sho run

Building configuration...

Current configuration : 1559 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

ip subnet-zero

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no ip address

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 200.x.x.x.x.255.0

no ip route-cache

!

ip http server

!

!

line con 0

line vty 0 4

login

line vty 5 15

login

!

end

& the ip address of

my pc is 200.200.200.2 255.255.255.0

Re: ping problem

As per the config you PC is in Vlan vlan make sure that it is in the same vlan.Please check for any Personal firewall on your PC. If its is Windows XP it has a bulit in firewall,please disable that. If you have any other firewall on your system like symantec, norton etc. disable it.

Did you check all the physical layer part/connectivity.

Please paste the output of "Show int Vlan 1".

Please paste the output of the "show interface fa x/y " of the interface where your PC is connected.

regards,

-amit singh

Community Member

Re: ping problem

Switch#sho int vlan 1

Vlan1 is up, line protocol is up

Hardware is CPU Interface, address is 0012.578a.9b40 (bia 0012.578a.9b40)

Internet address is 200.200.202.1/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:02:04, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute ouxtput rate 0 bits/sec, 0 packets/sec

157 packets input, 16738 bytes, 0 no buffer

Received 70 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 7 ignored

775 packets output, 41022 bytes, 0 underruns

0 output errors, 4 interface resets

0 output buffer failures, 0 output buffers swapped out

Switch#

Re: ping problem

Hello...

Check the interface Ip ...

Internet address is 200.200.202.1/24 <<<---

Its showing something different to what you earlier pasted. Check the Ip addressing again on your Vlan interface and the Host PC.

I guess you have wrongly entered the IP addresses on either of these device. Check it again and also the firewall part. If you correct your Ip addresses and still you are unable to ping then it is definetly something to do with the software firewall, or any other software which is not letting the traffic pass through.

HTH, Please rate if it does.

regards,

-amit singh

Re: ping problem

Hi

In addition to it can u check weather u r SVI for vlan one is enable or not i mean try a shut and no shut under u r SVI.

Thanks

Mahmood

128
Views
0
Helpful
6
Replies
CreatePlease to create content