Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Please help. (2900XL)

Hi, All.

I have a LAN at Cisco switches at my work. The computers in each department united in VLANs. That's great, but i can't see computers of another departments (Vlans) in my Network Neighborhood. I heard, that possible configure it. Please help me, if you can.

Thank you.

5 REPLIES
Cisco Employee

Re: Please help. (2900XL)

You'll need a router to route between the VLANs

http://www.cisco.com/warp/public/473/50.shtml

New Member

Re: Please help. (2900XL)

I have a router, but did not know, how i must configure it. Usually i do:

conf term

int fastEthernet 0/1

switchport encapsulation dot1q

ip address x.x.x.x 255.255.255.0

So, i created gateways and had flow of traffic between LANs of departments, but can't see computers of another departments in windows Neighborhood. I see computers in Find computers, can ping it, but don't see in Network Neighborhood.

Gold

Re: Please help. (2900XL)

Svyatoslav,

What kinds of Windows computers do you have? Are you running NT domains? If you have any Windows NT 4.0 Servers, or Windows 2000 or XP Servers, then you can set up Windows Internet Name Service (WINS) on one or two of them. Then configure your desktop computers to register with one or both of them. This is much easier than using LMHOSTS and HOSTS files on each computer, especially in a dynamic environment.

If you are using Microsoft's DHCP services, then you can send the WINS server IP addresses to the desktop computers along with their IP addresses. As a DHCP option, WINS servers are option 044 I think, NBNS servers (NBNS = NetBIOS Name Servers; Windows computers use NetBIOS names). You will also need to specify a NetBIOS node type, which is DHCP option 046 I think. Usually the best choice is 0x8 which specifies "h-node" or "hybrid node". If you read up on the different node types (there are 4 of them), you will figure out that "hybrid" is the one most people choose. It is generally the most efficient.

If you are not using Microsoft DNS in-house yet, you can also set up DNS on the same servers that are running WINS. And you can link DNS to WINS, too. But that is a story for another time...

Older Windows networking runs into these complications when you have multiple IP subnets, because the underlying foundation is NetBIOS, which is non-routable. Microsoft has had to develop ways and work-arounds to get NetBIOS to run over TCP/IP. Newer Windows (2000, XP) can do it all through DNS I think, but the desktop computers have to register with the Microsoft DNS servers on your network for it to work. Oh, I almost forgot, you can also send DNS server IP addresses to the desktop computers using DHCP.

The symptoms you described are typical of Microsoft name resolution issues. It's not a Cisco problem.

Hope this helps. (MCSE 4.0, MCP+I)

New Member

Re: Please help. (2900XL)

I have win2000 server at my server with installed WINS. The ip address of WINS is written at all the computers . When i try to find computers at their names, i find it!!!

For example: Server_1 10.1.32.71 255.255.255.0.

I can type in "Find computers": "Server_1" or "10.1.32.71" and i find it. WINS HAS INSTALLED!

I try to repeat my problem: I can receive access to all computers, but only via "Find computers" by Net-Bios names or ip addresses. But i can't see computers of another subnets in my Network Neighborhood.

For example:

Department of Value papers:

ip1: 10.1.32.68... 10.1.32.72

gateway: 10.1.32.1

mask: 255.255.255.0

Department of constructors:

ip: 10.1.29.20... 10.1.29.30

gateway:10.1.29.1

mask: 255.255.255.0

If i use computer from department of Value Papers i can see only: 10.1.32.68...10.1.32.72 and no more.

I have not domain at this moment. I'm working in WorkGroups, because i'm afraid if i'll create domain, i can't see many resources (computers, printers and more).

New Member

Re: Please help. (2900XL)

I assume each VLAN has a different IP subnet allocated to it ? You need to configure trunking between all your switches for VLANS to propagate (if you want them to). You then need to configure a trunk between your switch and router.

Here is a simple example:

Router:

interface FastEthernet0/x

no ip address

speed 100

full-duplex

interface FastEthernet0/x.1

description Management VLAN

encapsulation dot1q 1

ip address 10.10.1.1 255.255.255.0

interface FastEthernet0/x.2

description Department A VLAN

encapsulation dot1q 2

ip address 10.20.1.1 255.255.255.0

interface FastEthernet0/x.3

description Department B VLAN

encapsulation dot1q 3

ip address 10.30.1.1 255.255.255.0

interface FastEthernet0/x.4

description Department C VLAN

encapsulation dot1q 4

ip address 10.40.1.1 255.255.255.0

Switch (connected to FastETh0/x of router):

interface interface_id

switchport mode trunk

switchport trunk encapsulation dot1q

85
Views
0
Helpful
5
Replies
CreatePlease to create content