Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Please help...DHCP issue

I created (4) DHCP pools in a 1751-v router. All connections are defaulting to pull an IP from the first pool only. When I statically assign each connection to it's specified pool. I am unable to ping any outside address or the default gateway of each pool.

Here is a summary of the network:

C1751-v connecting to a Linksys switchLinksys switch connects the following:

Server (192.168.2.2 192.168.2.1 255.255.255.0)

C1900 Switch (192.168.3.2 192.168.3.1 255.255.255.0)

C1900 switch (192.168.4.2 192.168.4.1 255.255.255.0)

Linksys wireless router (192.168.5.2 192.168.5.1 255.255.255.0)

When I statically assign any of the hconnecting hardware an IP address other than 192.168.2.x, it will pull an IP from the 192.168.2.x pool.

I have provided an copy of the router config for viewing.

Where am I going wrong?

6 REPLIES

Re: Please help...DHCP issue

The DHCP config on the router looks alrigth, other than you do not need this router to be a DHCP relay agent since the server is itself anyway - no need for ip helper-address on other vlans. Also, from what you said that even whne you assign a static ip address to a host that belongs to a vlan other than vlan 100 tells me that the trunk is not working. Check the switch if it's really trunking. If you assign an IP address to let say vlan 200, 192.168.3.99/24 and you can't even ping the defualt gateway which is 192.168.3.1, I would look at the turnk between this router and the switch.

New Member

Re: Please help...DHCP issue

Thanks for replying,

The server is not a DHCP server, only web/FTP server.

The first switch (Linksys) is just a plain switch. All hardware is connecting to that switch. The idea is to have a different private IP on each each hardware connected to the switch.

I figured I had the router configured correctly but for the life of me I cannot figure out why all hardware will only pull from the first DHCP pool (192.168.2.0/24). I configured a helper-address command hoping that would force the interface to pull form the stated DHCP pool.

I don't have any trunking protocols running on the network. With the network designed the way it is, could you explain why I would need to configure trunking?

Thanks again

Re: Please help...DHCP issue

If you do not have any trunking running in your network , maybe that will epxlain your issue as I earlier explain, your router have sub-interface with trunking:

interface FastEthernet0/0.1

description Server

encapsulation dot1Q 100 native

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.2

description Network

encapsulation dot1Q 200

ip address 192.168.3.1 255.255.255.0

ip helper-address 192.168.3.1

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.3

description WiFi

encapsulation dot1Q 300

ip address 192.168.4.1 255.255.255.0

ip helper-address 192.168.4.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.4

description VoIP

encapsulation dot1Q 400

ip address 192.168.5.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

do you understand what I am saying about trunking? why would you trunk on the router and not have the switch trunking?

This link might help:

http://www.cisco.com/en/US/products/hw/switches/ps663/products_configuration_example09186a008014859e.shtml#configs

Don't be alarmed if you see a catalyst switch and a 7500 router, the same concept applies with any switch and any router.

Re: Please help...DHCP issue

HI

Have u configured any vlans on u r switch may a stupid question.If u have configured vlans as bolasaza suggested verify weather u trunk link is working properly and u have allowed all ur vlans on that trunk port.As u said that they r pulling the IP address from a single pool ithink they are in single broadcast domain.

Thanks

Mahmood

New Member

Re: Please help...DHCP issue

Thanks for providing the link to read.

I rebuilt the router config as follows:

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.3.1

ip dhcp excluded-address 192.168.4.1

ip dhcp excluded-address 192.168.5.1

!

ip dhcp pool Network

network 192.168.3.0 255.255.255.0

default-router 192.168.3.1

domain-name 5thborocs.com

dns-server 63.162.x.x.33.149.39 199.2.252.10

!

ip dhcp pool WiFi

network 192.168.4.0 255.255.255.0

domain-name 5thborocs.com

dns-server 63.162.x.x.33.149.39 199.2.252.10

default-router 192.168.4.1

!

ip dhcp pool VoIP

network 192.168.5.0 255.255.255.0

default-router 192.168.5.1

domain-name 5thborocs.com

dns-server 63.162.x.x.33.149.39 199.2.252.10

option 150 ip 192.168.5.1

!

interface Ethernet0/0

description WAN

ip address 63.162.x.x.255.255.0

ip nat outside

ip virtual-reassembly

half-duplex

!

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.1

description Network

encapsulation dot1Q 2 native

ip address 192.168.3.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.2

description WiFi

encapsulation dot1Q 3

ip address 192.168.4.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.3

description VoIP

encapsulation dot1Q 4

ip address 192.168.5.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

ip route 0.0.0.0 0.0.x.x162.201.1

ip http server

no ip http secure-server

!

p nat inside source list 1 interface Ethernet0/0 overload

!

!

access-list 1 permit 192.168.3.0 0.0.0.255

access-list 1 permit 192.168.4.0 0.0.0.255

access-list 1 permit 192.168.5.0 0.0.0.255

end

I now have coonectivity from the Linksys wireless router (which is connected to the Linksys switch)

I took your advised and configured trunking on the first 1900 switch (port A) and created VLAN 3.

I can ping all interfaces and subinterfaces on the router from a client connected to the linksys wireless router, I can ping any client behind the linksys router from the Cisco 1751 router.

However, I cannot ping anything from the 1900 switch or ping the 1900 switch from either Linksys or Cisco routers.

C1900 switch

192.168.4.2

255.255.255.0

192.168.4.1

VLAN 3 (Network) enabled

Trunk status (ON) Encapsulation type: (ISL)

Allowed VLANs on this trunk: 1-1005

VTP MOde Control: Server (the switch advertises VLAN configuration

to neighboring switches via its trunks and learns new VLAN configuration

from those neighbors.)

Also verified VLAN membership ( VLAN 3, Membership type STATIC)

I appreciate all the help you guys are giving me while I learn, Nothing better than hands on training.

New Member

Re: Please help...DHCP issue

Anyone ?

149
Views
0
Helpful
6
Replies
CreatePlease login to create content