Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Please Help, switching int from dynamic to static IP

Hello,

I have a Cisco 1605r that worked fine with optimum online, which used dynamic IP (int e0 had the line "ip address dhcp")

Here is my config:

Building configuration...

Current configuration : 1356 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname

!

enable secret xxx

!

ip subnet-zero

no ip source-route

!

no ip bootp server

!

!

!

!

interface Ethernet0

ip address 64.xxx.xxx.xxx 255.255.255.0

no ip proxy-arp

ip nat outside

no cdp enable

!

interface Ethernet1

ip address 192.168.1.1 255.255.255.0

no ip proxy-arp

ip nat inside

no cdp enable

!

ip nat inside source list 1 interface Ethernet0 overload

no ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0

no ip http server

!

access-list 1 permit 192.168.1.0 0.0.0.255

no cdp run

banner login ^C

WARNING!!!

This system is soley for the use of authorized users for official purposes.

You have no expectation of privacy in its use and to ensure that the system

is functioning properly, individuals using this computer system are subject

to having all of their activities monitored and recorded by system

personnel. Use of this system evidences an express consent to such

monitoring and agreement that if such monitoring reveals evidence of

possible abuse or criminal activity, system personnel may provide the

results of such monitoring to appropriate officials.

^C

!

line con 0

password

login

line vty 0 4

exec-timeout 0 1

no login

no exec

transport input none

!

end

The only difference between the old config and the new is that optimum gave me dynamic ip and speakeasy gives me static. I entered the static IP and NetMask but I have no idea how to tell my router what my new DGW and DNS addresses are. Can anyone help me? I can only ping my DGW, I can not ping my DNS servers and my LAN can't reach the web.

Thanks, Chris

  • Other Network Infrastructure Subjects
1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Please Help, switching int from dynamic to static IP

My understanding is that in classful routing a default route isn't used for a given packet if there's a route in the routing table for the major network that the packet is destined to. In this case, he should only have a route for 64.0.0.0/8, so packets will take the default route as long as they're not destined for this netblock.

That being said, I'd also recommend using "ip classless" so that you're not blackholed from the entire 64/8 address range.

I think you need to point your default route to the default gateway rather than the Ethernet interface; e.g., ip route 0.0.0.0 0.0.0.0 . I don't know how it worked like that before.

9 REPLIES
Cisco Employee

Re: Please Help, switching int from dynamic to static IP

If Speakeasy gave you a static IP, they should have also given you their default gateway address to use, and their DNS servers. Talk to them and you should be good to go.

New Member

Re: Please Help, switching int from dynamic to static IP

They gave me my ip, my dgw, my netmask and 2 name servers addresses. I entered all of that info into my router but, still can't ping my dns servers. I am assuming that the old command "ip address dhcp" was automatically performing some function that I now need to do manually but, what that is, I don't know.

Re: Please Help, switching int from dynamic to static IP

Your default route wont be used unless you enable ip classless. Give "ip classless" on global config mode. HTH

New Member

Re: Please Help, switching int from dynamic to static IP

Are you sure? It worked fine with my cable modem.

Re: Please Help, switching int from dynamic to static IP

when it worked fine with your cable modem, did you have your router also in place or just the pc hooked to a hub/switch where the cable modem is also hooked into ?

New Member

Re: Please Help, switching int from dynamic to static IP

With both my cable modem and dsl modem, I had the modems going into e0 and my lan on e1

The only thing that has changed, as far as I know, is that my public ip address on e0 was given to me dynamically with cable so I used the line "ip address dhcp" then. Now I have a static address so I am using the command "ip address 64.x.x.x 255.255.255.0

I also added the commands

ip default-gateway

and

ip name-server

I can not ping anything past my DGW, I must have something wrong with the way I am routing... I don't know why I can't ping my DNS servers

I tried "ip classless"... no luck! :(

Thanks for your help and time, Chris

Bronze

Re: Please Help, switching int from dynamic to static IP

My understanding is that in classful routing a default route isn't used for a given packet if there's a route in the routing table for the major network that the packet is destined to. In this case, he should only have a route for 64.0.0.0/8, so packets will take the default route as long as they're not destined for this netblock.

That being said, I'd also recommend using "ip classless" so that you're not blackholed from the entire 64/8 address range.

I think you need to point your default route to the default gateway rather than the Ethernet interface; e.g., ip route 0.0.0.0 0.0.0.0 . I don't know how it worked like that before.

New Member

Re: Please Help, switching int from dynamic to static IP

I will try making a static route to my dgw. That sounds logical. Thank you for your help. I will let you know if it worked.

New Member

Re: Please Help, switching int from dynamic to static IP

YOU ARE THE MAN!

Your info worked. I can't thank you enough. Great job!

111
Views
0
Helpful
9
Replies