Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Please help with dhcp!

I have a 871w with dhcp configured on the device. It has build in wireless, and although we can see the broadcast ssids, we cannot connect/get a dhcp address. I have been dealing with this for over a week and cannot determine why I cannot get an IP. Please help, an office of 6 workstations are all on wireless, and I fear that if this goes into next week, I will have to get cabling guys in.

Thanks all!

3 REPLIES
Silver

Re: Please help with dhcp!

See the following page for help: http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a008008743b.html

One thing I notice you must either enable logging or disable it specifically. Try running this command to see if it helps:

no ip dhcp conflict logging

Hope this helps.

Steve

VIP Purple

Re: Please help with dhcp!

Hello,

looking at your config, try and make the following changes; also, make sure the SSIDs match with those on the clients:

no aaa new-model

ip subnet-zero

ip cef

ip dhcp excluded-address 10.1.5.1 10.1.5.100

ip dhcp excluded-address 10.1.5.200 10.1.5.254

!

ip dhcp pool sdm-pool1

--> no import all

network 10.1.5.0 255.255.255.0

dns-server 10.1.4.5 10.1.4.6

default-router 10.1.5.1

!

bridge irb

!

interface FastEthernet4

description $ETH-WAN$

ip address x.x.x.47 255.255.255.224

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

no cdp enable

crypto map SDM_CMAP_1

!

interface Dot11Radio0

no ip address

!

ssid Keta

vlan 1

authentication open

infrastructure-ssid optional

!

ssid Keta-Wireless

vlan 2

authentication open

guest-mode

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

no cdp enable

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no cdp enable

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 spanning-disabled

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$

--> ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Vlan2

no ip address

ip nat inside

ip virtual-reassembly

bridge-group 2

bridge-group 2 spanning-disabled

!

!

interface BVI2

--> ip address 10.1.5.1 255.255.255.0

Regards,

GP

Community Member

Re: Please help with dhcp!

Thanks all for the suggestions. I will be going up to the office shortly just to try these. The only thing I see with changing VLAN1 IP address is that I need that to stay what it is if possible. I will have corporate over a vpn depending that the range in this office be 10.1.5.1 which is being nat'ed on the outside interface for internet access as well. Any particualr reason I should change this to 192? Just asking - Im not completely sure how this will effect everything with giving the BVI the address instead.

Thanks again

118
Views
0
Helpful
3
Replies
CreatePlease to create content